Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
contentserver 454 tcp ContentServer
contentserver 454 udp ContentServer
interhdl-elmd 1454 tcp interHDL License Manager

IANA assigned this well-formed service name as a replacement for "interhdl_elmd".
Eli Sternheim Eli Sternheim
interhdl_elmd 1454 tcp interHDL License Manager Eli Sternheim Eli Sternheim This entry is an alias to "interhdl-elmd". This entry is now historic, not usable for use with many common service discovery mechanisms.
interhdl-elmd 1454 udp interHDL License Manager

IANA assigned this well-formed service name as a replacement for "interhdl_elmd".
Eli Sternheim Eli Sternheim
interhdl_elmd 1454 udp interHDL License Manager Eli Sternheim Eli Sternheim This entry is an alias to "interhdl-elmd". This entry is now historic, not usable for use with many common service discovery mechanisms.
indx-dds 2454 tcp IndX-DDS Paul Carmichael Paul Carmichael
indx-dds 2454 udp IndX-DDS Paul Carmichael Paul Carmichael
mira 3454 tcp Apple Remote Access Protocol Mike Alexander Mike Alexander
mira 3454 udp Apple Remote Access Protocol Mike Alexander Mike Alexander
nssagentmgr 4454 tcp NSS Agent Manager Jim Hill Jim Hill
nssagentmgr 4454 udp NSS Agent Manager Jim Hill Jim Hill
4539-4544 Unassigned
worldscores 4545 tcp WorldScores Steve Davis Steve Davis
worldscores 4545 udp WorldScores Steve Davis Steve Davis
sf-lm 4546 tcp SF License Manager (Sentinel) Thomas Koell Thomas Koell
sf-lm 4546 udp SF License Manager (Sentinel) Thomas Koell Thomas Koell
lanner-lm 4547 tcp Lanner License Manager Les Enstone Les Enstone
lanner-lm 4547 udp Lanner License Manager Les Enstone Les Enstone
synchromesh 4548 tcp Synchromesh Tom Hawkins Tom Hawkins 2006-02
synchromesh 4548 udp Synchromesh Tom Hawkins Tom Hawkins 2006-02
aegate 4549 tcp Aegate PMR Service Nick Warrington Nick Warrington 2006-03
aegate 4549 udp Aegate PMR Service Nick Warrington Nick Warrington 2006-03
apc-5454 5454 tcp APC 5454 American Power Conversion American Power Conversion
apc-5454 5454 udp APC 5454 American Power Conversion American Power Conversion
6447-6454 Unassigned
simco 7626 tcp SImple Middlebox COnfiguration (SIMCO) Server RFC 4540
44446-44543 Unassigned Known UNAUTHORIZED USE: Ports 44515 & 44516
44544 tcp Reserved
domiq 44544 udp DOMIQ Building Automation DOMIQ Sp. z o.o. Filip Zawadiak 2011-08-29
44545-44552 Unassigned

Contact Information

Name Organization Contact URI Last Updated
American Power Conversion ports&apcc.com 2002-02
DOMIQ Sp. z o.o. registries&domiq.pl 2011-08-29
Eli Sternheim eli&interhdl.com
Filip Zawadiak DOMIQ Sp. z o.o. fzawadiak&domiq.pl 2011-08-29
Jim Hill jhill&symantec.com
Les Enstone lenstone&lanner.co.uk
Mike Alexander mta&um.cc.umich.edu
Nick Warrington nick.warrington&paconsulting.com 2006-03
Paul Carmichael paulcarmichael&indx.net
Steve Davis sdavis&optum-inc.com
Thomas Koell info&sf.com
Tom Hawkins tomahawkins&gmail.com 2006-02