Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-11-10

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
discard 9 dccp Discard Eddie Kohler Eddie Kohler RFC 4340 1145656131
macon-tcp 456 tcp macon-tcp Yoshinobu Inoue Yoshinobu Inoue
macon-udp 456 udp macon-udp Yoshinobu Inoue Yoshinobu Inoue
dca 1456 tcp DCA Jeff Garbers Jeff Garbers
dca 1456 udp DCA Jeff Garbers Jeff Garbers
altav-remmgt 2456 tcp altav-remmgt Gary M. Allen Gary M. Allen
altav-remmgt 2456 udp altav-remmgt Gary M. Allen Gary M. Allen
vat 3456 tcp VAT default data Van Jacobson Van Jacobson
vat 3456 udp VAT default data Van Jacobson Van Jacobson
prchat-server 4456 tcp PR Chat Server
prchat-server 4456 udp PR Chat Server
4560-4562 Unassigned
amahi-anywhere 4563 tcp Amahi Anywhere Amahi Carlos Puchol 2014-02-27
4563 udp Reserved
4564-4565 Unassigned
kwtc 4566 tcp Kids Watch Time Control Service Larry Zarou Larry Zarou 2006-10
kwtc 4566 udp Kids Watch Time Control Service Larry Zarou Larry Zarou 2006-10
tram 4567 tcp TRAM Joe Wesley Joe Wesley
tram 4567 udp TRAM Joe Wesley Joe Wesley
bmc-reporting 4568 tcp BMC Reporting Portnoy Boxman Portnoy Boxman
bmc-reporting 4568 udp BMC Reporting Portnoy Boxman Portnoy Boxman
iax 4569 tcp Inter-Asterisk eXchange Benjamin Kowarsch Benjamin Kowarsch RFC 5456 Defined TXT keys:
auth plaintext | md5 | rsakeys
userid alphanumeric, additionally '_', '+', '-'
secret any printable ASCII characters
domain any DNS domain name or IP address
extension alphanumeric, additionally '*', '#', '_', '+', '-'
context alphanumeric, additionally '_', '+', '-'
trunk yes | no | 0 | 1
welcome alphanumeric, additionally '*', '#', '_', '+', '-'
voicemail alphanumeric, additionally '*', '#', '_', '+', '-'
reception alphanumeric, additionally '*', '#', '_', '+', '-'
echotest alphanumeric, additionally '*', '#', '_', '+', '-'
ivrtest alphanumeric, additionally '*', '#', '_', '+', '-'
All of these TXT record keys are optional, they may be omitted. Further keys may be added in the future.
iax 4569 udp Inter-Asterisk eXchange Benjamin Kowarsch Benjamin Kowarsch RFC 5456 Defined TXT keys:
auth plaintext | md5 | rsakeys
userid alphanumeric, additionally '_', '+', '-'
secret any printable ASCII characters
domain any DNS domain name or IP address
extension alphanumeric, additionally '*', '#', '_', '+', '-'
context alphanumeric, additionally '_', '+', '-'
trunk yes | no | 0 | 1
welcome alphanumeric, additionally '*', '#', '_', '+', '-'
voicemail alphanumeric, additionally '*', '#', '_', '+', '-'
reception alphanumeric, additionally '*', '#', '_', '+', '-'
echotest alphanumeric, additionally '*', '#', '_', '+', '-'
ivrtest alphanumeric, additionally '*', '#', '_', '+', '-'
All of these TXT record keys are optional, they may be omitted. Further keys may be added in the future.
apc-5456 5456 tcp APC 5456 American Power Conversion American Power Conversion
apc-5456 5456 udp APC 5456 American Power Conversion American Power Conversion
skip-cert-send 6456 tcp SKIP Certificate Send Tom Markson Tom Markson
skip-cert-send 6456 udp SKIP Certificate Send Tom Markson Tom Markson
8451-8456 Unassigned
aequus 23456 tcp Aequus Service James Anson James Anson 2009-02-12
23456 udp Reserved
31417-31456 Unassigned
34380-34566 Unassigned
dhanalakshmi 34567 tcp dhanalakshmi.org EDI Service Girish Gopalakrishnan Girish Gopalakrishnan 2010-04-20
edi_service 34567 udp dhanalakshmi.org EDI Service Girish Gopalakrishnan Girish Gopalakrishnan 2016-10-26
34568-34961 Unassigned
45515-45677 Unassigned
eba 45678 tcp EBA PRISE Patrick Kara Patrick Kara
eba 45678 udp EBA PRISE Patrick Kara Patrick Kara
45679-45823 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Amahi iana&amahi.org 2014-02-27
American Power Conversion ports&apcc.com 2002-02
Benjamin Kowarsch benjamin&sunrise-tel.com 2004-11
Carlos Puchol Amahi iana&amahi.org 2014-02-27
Eddie Kohler IETF dccp WG kohler&cs.ucla.edu
Gary M. Allen gallen&symantec.com
Girish Gopalakrishnan girish&shankar-software.org 2016-10-26
James Anson janson&bigpond.com 2009-02-12
Jeff Garbers jgarbers&netcom.com
Joe Wesley joe.wesley&east.sun.com
Larry Zarou zarla01&cbsits.com 2006-10
Patrick Kara Patrick&eba.net
Portnoy Boxman portnoy_boxman&bmc.com 2005-01
Tom Markson markson&osmosys.incog.com
Van Jacobson van&ee.lbl.gov
Yoshinobu Inoue