Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-27

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
47 tcp Reserved 2017-05-18 This entry has been removed on 2017-05-18.
47 udp Reserved 2017-05-18 This entry has been removed on 2017-05-18.
iso-ip 147 tcp ISO-IP Marshall Rose Marshall Rose
iso-ip 147 udp ISO-IP Marshall Rose Marshall Rose
subntbcst-tftp 247 tcp SUBNTBCST_TFTP

IANA assigned this well-formed service name as a replacement for "subntbcst_tftp".
John Fake John Fake
subntbcst_tftp 247 tcp SUBNTBCST_TFTP John Fake John Fake This entry is an alias to "subntbcst-tftp". This entry is now historic, not usable for use with many common service discovery mechanisms.
subntbcst-tftp 247 udp SUBNTBCST_TFTP

IANA assigned this well-formed service name as a replacement for "subntbcst_tftp".
John Fake John Fake
subntbcst_tftp 247 udp SUBNTBCST_TFTP John Fake John Fake This entry is an alias to "subntbcst-tftp". This entry is now historic, not usable for use with many common service discovery mechanisms.
fatserv 347 tcp Fatmen Server
fatserv 347 udp Fatmen Server
ddm-dfm 447 tcp DDM-Distributed File Management Steven Ritland Steven Ritland
ddm-dfm 447 udp DDM-Distributed File Management Steven Ritland Steven Ritland
scx-proxy 470 tcp scx-proxy Scott Narveson Scott Narveson
scx-proxy 470 udp scx-proxy Scott Narveson Scott Narveson
mondex 471 tcp Mondex Bill Reding Bill Reding
mondex 471 udp Mondex Bill Reding Bill Reding
ljk-login 472 tcp ljk-login LJK Software, Cambridge, Massachusetts LJK Software, Cambridge, Massachusetts
ljk-login 472 udp ljk-login LJK Software, Cambridge, Massachusetts LJK Software, Cambridge, Massachusetts
hybrid-pop 473 tcp hybrid-pop Rami Rubin Rami Rubin
hybrid-pop 473 udp hybrid-pop Rami Rubin Rami Rubin
tn-tl-w1 474 tcp tn-tl-w1
tn-tl-w2 474 udp tn-tl-w2 Ed Kress Ed Kress
tcpnethaspsrv 475 tcp tcpnethaspsrv Michael Zunke Michael Zunke 2010-07-23
tcpnethaspsrv 475 udp tcpnethaspsrv Michael Zunke Michael Zunke 2010-07-23
tn-tl-fd1 476 tcp tn-tl-fd1 Ed Kress Ed Kress
tn-tl-fd1 476 udp tn-tl-fd1 Ed Kress Ed Kress
ss7ns 477 tcp ss7ns Jean-Michel URSCH Jean-Michel URSCH
ss7ns 477 udp ss7ns Jean-Michel URSCH Jean-Michel URSCH
spsc 478 tcp spsc Mike Rieker Mike Rieker
spsc 478 udp spsc Mike Rieker Mike Rieker
iafserver 479 tcp iafserver
iafserver 479 udp iafserver
dhcpv6-server 547 tcp DHCPv6 Server IESG IETF Chair 2018-05-21 RFC 5460
dhcpv6-server 547 udp DHCPv6 Server IESG IETF Chair 2018-05-21 RFC 9915
idxp 603 tcp IDXP RFC 4767
idxp 603 udp IDXP RFC 4767
dhcp-failover 647 tcp DHCP Failover IESG IETF Chair 2018-05-21 RFC 8156
dhcp-failover 647 udp DHCP Failover Bernard Volz Bernard Volz
fujitsu-dev 747 tcp Fujitsu Device Control
fujitsu-dev 747 udp Fujitsu Device Control
dhcp-failover2 847 tcp dhcp-failover 2 Bernard Volz Bernard Volz
dhcp-failover2 847 udp dhcp-failover 2 Bernard Volz Bernard Volz
gdoi 848 tcp GDOI RFC 3547
gdoi 848 udp GDOI RFC 3547
nas 991 tcp Netnews Administration System Vera Heinau; Heiko Schlichting Vera Heinau; Heiko Schlichting 2017-02-10 RFC 4707
nas 991 udp Netnews Administration System Vera Heinau; Heiko Schlichting Vera Heinau; Heiko Schlichting 2017-02-10 RFC 4707
exp1 1021 tcp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp1 1021 udp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp1 1021 sctp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp1 1021 dccp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp2 1022 tcp RFC3692-style Experiment 2 IESG IETF Chair [1]RFC 4727; RFC 6335
exp2 1022 udp RFC3692-style Experiment 2 IESG IETF Chair [1]RFC 4727; RFC 6335
exp2 1022 sctp RFC3692-style Experiment 2 IESG IETF Chair [1]RFC 4727; RFC 6335
exp2 1022 dccp RFC3692-style Experiment 2 IESG IETF Chair [1]RFC 4727; RFC 6335
neod1 1047 tcp Sun's NEO Object Request Broker
neod1 1047 udp Sun's NEO Object Request Broker
capioverlan 1147 tcp CAPIoverLAN Diego Friedel Diego Friedel 2005-11
capioverlan 1147 udp CAPIoverLAN Diego Friedel Diego Friedel 2005-11
visionpyramid 1247 tcp VisionPyramid Gavin Hutchinson Gavin Hutchinson
visionpyramid 1247 udp VisionPyramid Gavin Hutchinson Gavin Hutchinson
bbn-mmc 1347 tcp multi media conferencing
bbn-mmc 1347 udp multi media conferencing
apri-lm 1447 tcp Applied Parallel Research LM Jim Dillon Jim Dillon
apri-lm 1447 udp Applied Parallel Research LM Jim Dillon Jim Dillon
uaiact 1470 tcp Universal Analytics Mark R. Ludwig Mark R. Ludwig
uaiact 1470 udp Universal Analytics Mark R. Ludwig Mark R. Ludwig
csdmbase 1471 tcp csdmbase
csdmbase 1471 udp csdmbase
csdm 1472 tcp csdm Robert Stabl Robert Stabl
csdm 1472 udp csdm Robert Stabl Robert Stabl
openmath 1473 tcp OpenMath Garth Mayville Garth Mayville
openmath 1473 udp OpenMath Garth Mayville Garth Mayville
telefinder 1474 tcp Telefinder Jim White Jim White
telefinder 1474 udp Telefinder Jim White Jim White
taligent-lm 1475 tcp Taligent License Manager Mark Sapsford Mark Sapsford
taligent-lm 1475 udp Taligent License Manager Mark Sapsford Mark Sapsford
clvm-cfg 1476 tcp clvm-cfg Eric Soderberg Eric Soderberg
clvm-cfg 1476 udp clvm-cfg Eric Soderberg Eric Soderberg
ms-sna-server 1477 tcp ms-sna-server
ms-sna-server 1477 udp ms-sna-server
ms-sna-base 1478 tcp ms-sna-base Gordon Mangione Gordon Mangione
ms-sna-base 1478 udp ms-sna-base Gordon Mangione Gordon Mangione
dberegister 1479 tcp dberegister Brian Griswold Brian Griswold
dberegister 1479 udp dberegister Brian Griswold Brian Griswold
laplink 1547 tcp laplink Michael Crawford Michael Crawford
laplink 1547 udp laplink Michael Crawford Michael Crawford
mil-2045-47001 1581 tcp MIL-2045-47001 Eric Whitehill Eric Whitehill
mil-2045-47001 1581 udp MIL-2045-47001 Eric Whitehill Eric Whitehill
rsap 1647 tcp rsap Holger Reif Holger Reif
rsap 1647 udp rsap Holger Reif Holger Reif
ftrapid-2 1747 tcp ftrapid-2 Richard J. Williams Richard J. Williams
ftrapid-2 1747 udp ftrapid-2 Richard J. Williams Richard J. Williams
slp-notify 1847 tcp SLP Notification RFC 3082
slp-notify 1847 udp SLP Notification RFC 3082
sentinelsrm 1947 tcp SentinelSRM Michael Zunke Michael Zunke 2010-07-23 Unauthorized Use Known on port 1947
sentinelsrm 1947 udp SentinelSRM Michael Zunke Michael Zunke 2010-07-23 Unauthorized Use Known on port 1947
dls 2047 tcp
dls 2047 udp
lv-auth 2147 tcp Live Vault Authentication Ted Hess Ted Hess
lv-auth 2147 udp Live Vault Authentication Ted Hess Ted Hess

Contact Information

Name Organization Contact URI Last Updated
Bernard Volz bevolz&gmail.com 2022-08-03
Bill Reding redingb&nwdt.natwest.co.uk
Brian Griswold brian&dancingbear.com
Diego Friedel d.friedel&avm.de 2006-03
Ed Kress eskress&thinknet.com
Eric Soderberg seric&cup.hp.com
Eric Whitehill Eric.Whitehill&itt.com
Garth Mayville mayville&maplesoft.on.ca
Gavin Hutchinson gavinh&visionlogistics.com
Gordon Mangione gordm&microsoft.com
Heiko Schlichting heiko.schlichting&fu-berlin.de 2022-06-07
Holger Reif Holger.Reif&prakinf.tu-ilmenau.de
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jean-Michel URSCH ursch&taec.enet.dec.com
Jim Dillon jed&apri.com
Jim White Jim_White&spiderisland.com
John Fake fake&us.ibm.com
LJK Software, Cambridge, Massachusetts support&ljk.com
Mark R. Ludwig Mark-Ludwig&uai.com
Mark Sapsford Mark_Sapsford&taligent.com
Marshall Rose mrose17&gmail.com 2024-07-29
Michael Crawford MichaelC&dev.travsoft.com
Michael Zunke michael.zunke&ealaddin.com 2010-07-23
Michael Zunke Michael.Zunke&ealaddin.com 2010-07-23
Mike Rieker mikea&sp32.com
Rami Rubin rami&hybrid.com
Richard J. Williams RJW1&trpo4.tr.unisys.com
Robert Stabl stabl&informatik.uni-muenchen.de
Scott Narveson sjn&cray.com
Steven Ritland srr&us.ibm.com
Ted Hess thess&livevault.com
Vera Heinau vera.heinau&fu-berlin.de 2022-06-07