Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
tcpnethaspsrv 475 tcp tcpnethaspsrv Michael Zunke Michael Zunke 2010-07-23
tcpnethaspsrv 475 udp tcpnethaspsrv Michael Zunke Michael Zunke 2010-07-23
taligent-lm 1475 tcp Taligent License Manager Mark Sapsford Mark Sapsford
taligent-lm 1475 udp Taligent License Manager Mark Sapsford Mark Sapsford
ace-server 2475 tcp ACE Server
ace-server 2475 udp ACE Server
genisar-port 3475 tcp Genisar Comm Port Candace Niccolson Candace Niccolson 2002-04
genisar-port 3475 udp Genisar Comm Port Candace Niccolson Candace Niccolson 2002-04
ssad 4750 tcp Simple Service Auto Discovery Dr Horst Herb Dr Horst Herb 2005-12
ssad 4750 udp Simple Service Auto Discovery Dr Horst Herb Dr Horst Herb 2005-12
spocp 4751 tcp Simple Policy Control Protocol Roland Hedberg Roland Hedberg 2005-08
spocp 4751 udp Simple Policy Control Protocol Roland Hedberg Roland Hedberg 2005-08
snap 4752 tcp Simple Network Audio Protocol Dameon Wagner Dameon Wagner 2002-02
snap 4752 udp Simple Network Audio Protocol Dameon Wagner Dameon Wagner 2002-02
simon 4753 tcp Simple Invocation of Methods Over Network (SIMON) Alexander Christian Alexander Christian 2012-04-19
simon-disc 4753 udp Simple Invocation of Methods Over Network (SIMON) Discovery Alexander Christian Alexander Christian 2012-04-19
4754 tcp Reserved
gre-in-udp 4754 udp GRE-in-UDP Encapsulation IESG IETF Chair 2016-10-05 RFC 8086
4755 tcp Reserved
gre-udp-dtls 4755 udp GRE-in-UDP Encapsulation with DTLS IESG IETF Chair 2016-10-05 RFC 8086
RDCenter 4756 tcp Reticle Decision Center KLA Tencor/RAPID George Hwa 2016-10-17
4756 udp Reserved
4757-4773 Unassigned
apsolab-data 5475 tcp The Apsolab company's data retrieval protocol Apsolab Inc. Jean-Francois Gauthier 2014-11-10
5475 udp Reserved
7475-7477 Unassigned
8475-8499 Unassigned
24728-24753 Unassigned
cslg 24754 tcp Citrix StorageLink Gateway Mark Nijmeijer Mark Nijmeijer 2009-04-17
24754 udp Reserved
24755-24849 Unassigned
neckar 37475 tcp science + computing's Venus Administration Port Ralf Allrutz Ralf Allrutz 2002-02
neckar 37475 udp science + computing's Venus Administration Port Ralf Allrutz Ralf Allrutz 2002-02
47101-47556 Unassigned
dbbrowse 47557 tcp Databeam Corporation Cindy Martin Cindy Martin
dbbrowse 47557 udp Databeam Corporation Cindy Martin Cindy Martin
47558-47623 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Alexander Christian alexander.christian&root1.de 2012-04-19
Apsolab Inc. admin&apsolab.com 2014-11-10
Candace Niccolson cniccolson&genisar.com 2002-04
Cindy Martin cmartin&databeam.com
Dameon Wagner d.wagner&freemail.absa.co.za 2002-02
Dr Horst Herb horst&dorrigomedical.com 2005-12
George Hwa george.hwa&kla-tencor.com 2016-10-17
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jean-Francois Gauthier Apsolab Inc. jfgauthier&apsolab.com 2014-11-10
KLA Tencor/RAPID george.hwa&kla-tencor.com 2016-10-17
Mark Nijmeijer Mark.Nijmeijer&citrix.com 2009-04-17
Mark Sapsford Mark_Sapsford&taligent.com
Michael Zunke michael.zunke&ealaddin.com 2010-07-23
Ralf Allrutz R.Allrutz&science-computing.de 2002-02
Roland Hedberg roland&catalogix.se 2005-08