Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
tn-tl-fd1 476 tcp tn-tl-fd1 Ed Kress Ed Kress
tn-tl-fd1 476 udp tn-tl-fd1 Ed Kress Ed Kress
idxp 603 tcp IDXP RFC 4767
idxp 603 udp IDXP RFC 4767
clvm-cfg 1476 tcp clvm-cfg Eric Soderberg Eric Soderberg
clvm-cfg 1476 udp clvm-cfg Eric Soderberg Eric Soderberg
ace-svr-prop 2476 tcp ACE Server Propagation
ace-svr-prop 2476 udp ACE Server Propagation
nppmp 3476 tcp NVIDIA Mgmt Protocol Gilbert Yeung Gilbert Yeung 2002-04
nppmp 3476 udp NVIDIA Mgmt Protocol Gilbert Yeung Gilbert Yeung 2002-04
5476-5499 Unassigned
37476-37482 Unassigned
47558-47623 Unassigned
directplaysrvr 47624 tcp Direct Play Server Ajay Jindal Ajay Jindal
directplaysrvr 47624 udp Direct Play Server Ajay Jindal Ajay Jindal
47625-47805 Unassigned

Contact Information

Name Contact URI Last Updated
Ajay Jindal ajayj&microsoft.com
Ed Kress eskress&thinknet.com
Eric Soderberg seric&cup.hp.com
Gilbert Yeung gyeung&nvidia.com 2002-04