Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| tacacs | 49 | tcp | Login Host Protocol (TACACS) | Pieter Ditmars | Pieter Ditmars | ||||||
| tacacs | 49 | udp | Login Host Protocol (TACACS) | Pieter Ditmars | Pieter Ditmars | ||||||
| aed-512 | 149 | tcp | AED 512 Emulation Service | Albert G. Broscius | Albert G. Broscius | ||||||
| aed-512 | 149 | udp | AED 512 Emulation Service | Albert G. Broscius | Albert G. Broscius | ||||||
| 249-255 | Reserved | 2024-12-20 | RFC 1060 | ||||||||
| manet | 269 | tcp | MANET Protocols | RFC 5498 | |||||||
| manet | 269 | udp | MANET Protocols | RFC 5498 | |||||||
| mftp | 349 | tcp | mftp | Dave Feinleib | Dave Feinleib | ||||||
| mftp | 349 | udp | mftp | Dave Feinleib | Dave Feinleib | ||||||
| as-servermap | 449 | tcp | AS Server Mapper | Barbara Foss | Barbara Foss | ||||||
| as-servermap | 449 | udp | AS Server Mapper | Barbara Foss | Barbara Foss | ||||||
| micom-pfs | 490 | tcp | micom-pfs | David Misunas | David Misunas | ||||||
| micom-pfs | 490 | udp | micom-pfs | David Misunas | David Misunas | ||||||
| go-login | 491 | tcp | go-login | Troy Morrison | Troy Morrison | ||||||
| go-login | 491 | udp | go-login | Troy Morrison | Troy Morrison | ||||||
| ticf-1 | 492 | tcp | Transport Independent Convergence for FNA | ||||||||
| ticf-1 | 492 | udp | Transport Independent Convergence for FNA | ||||||||
| ticf-2 | 493 | tcp | Transport Independent Convergence for FNA | Mamoru Ito | Mamoru Ito | ||||||
| ticf-2 | 493 | udp | Transport Independent Convergence for FNA | Mamoru Ito | Mamoru Ito | ||||||
| pov-ray | 494 | tcp | POV-Ray | POV-Team Co-ordinator | POV-Team Co-ordinator | ||||||
| pov-ray | 494 | udp | POV-Ray | POV-Team Co-ordinator | POV-Team Co-ordinator | ||||||
| intecourier | 495 | tcp | intecourier | Steve Favor | Steve Favor | ||||||
| intecourier | 495 | udp | intecourier | Steve Favor | Steve Favor | ||||||
| pim-rp-disc | 496 | tcp | PIM-RP-DISC | Dino Farinacci | Dino Farinacci | ||||||
| pim-rp-disc | 496 | udp | PIM-RP-DISC | Dino Farinacci | Dino Farinacci | ||||||
| retrospect | 497 | tcp | Retrospect backup and restore service | Retrospect, Inc. | JG Heithcock | 2012-02-02 | |||||
| retrospect | 497 | udp | Retrospect backup and restore service | Retrospect, Inc. | JG Heithcock | 2012-02-02 | |||||
| siam | 498 | tcp | siam | Philippe Gilbert | Philippe Gilbert | ||||||
| siam | 498 | udp | siam | Philippe Gilbert | Philippe Gilbert | ||||||
| iso-ill | 499 | tcp | ISO ILL Protocol | Mark H. Needleman | Mark H. Needleman | ||||||
| iso-ill | 499 | udp | ISO ILL Protocol | Mark H. Needleman | Mark H. Needleman | ||||||
| idfp | 549 | tcp | IDFP | Ramana Kovi | Ramana Kovi | ||||||
| idfp | 549 | udp | IDFP | Ramana Kovi | Ramana Kovi | ||||||
| cadview-3d | 649 | tcp | Cadview-3d - streaming 3d models over the internet | David Cooper | David Cooper | ||||||
| cadview-3d | 649 | udp | Cadview-3d - streaming 3d models over the internet | David Cooper | David Cooper | ||||||
| iris-xpcs | 714 | tcp | IRIS over XPCS | RFC 4992 | |||||||
| iris-xpcs | 714 | udp | IRIS over XPCS | RFC 4992 | |||||||
| iris-lwz | 715 | tcp | IRIS-LWZ | RFC 4993 | |||||||
| iris-lwz | 715 | udp | IRIS-LWZ | RFC 4993 | |||||||
| kerberos-adm | 749 | tcp | kerberos administration | ||||||||
| kerberos-adm | 749 | udp | kerberos administration | ||||||||
| 849-852 | Unassigned | ||||||||||
| td-postman | 1049 | tcp | Tobit David Postman VPMN | Franz-Josef Leuders | Franz-Josef Leuders | ||||||
| td-postman | 1049 | udp | Tobit David Postman VPMN | Franz-Josef Leuders | Franz-Josef Leuders | ||||||
| bvtsonar | 1149 | tcp | BlueView Sonar Service | Teledyne BlueView, Inc. | Cat Zimmermann | 2005-11 | 2012-09-19 | ||||
| bvtsonar | 1149 | udp | BlueView Sonar Service | Teledyne BlueView, Inc. | Cat Zimmermann | 2005-11 | 2012-09-19 | ||||
| mesavistaco | 1249 | tcp | Mesa Vista Co | Rick LaBanca | Rick LaBanca | ||||||
| mesavistaco | 1249 | udp | Mesa Vista Co | Rick LaBanca | Rick LaBanca | ||||||
| sbook | 1349 | tcp | Registration Network Protocol | ||||||||
| sbook | 1349 | udp | Registration Network Protocol | ||||||||
| peport | 1449 | tcp | PEport | Qentin Neill | Qentin Neill | ||||||
| peport | 1449 | udp | PEport | Qentin Neill | Qentin Neill | ||||||
| insitu-conf | 1490 | tcp | insitu-conf | Paul Blacknell | Paul Blacknell | ||||||
| insitu-conf | 1490 | udp | insitu-conf | Paul Blacknell | Paul Blacknell | ||||||
| 1491 | Unassigned | 2009-08-05 | Unauthorized Use Known on port 1491 | ||||||||
| stone-design-1 | 1492 | tcp | stone-design-1 | Andrew Stone | Andrew Stone | ||||||
| stone-design-1 | 1492 | udp | stone-design-1 | Andrew Stone | Andrew Stone | ||||||
| netmap-lm | 1493 | tcp | netmap_lm IANA assigned this well-formed service name as a replacement for "netmap_lm". |
Phillip Magson | Phillip Magson | ||||||
| netmap_lm | 1493 | tcp | netmap_lm | Phillip Magson | Phillip Magson | This entry is an alias to "netmap-lm". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| netmap-lm | 1493 | udp | netmap_lm IANA assigned this well-formed service name as a replacement for "netmap_lm". |
Phillip Magson | Phillip Magson | ||||||
| netmap_lm | 1493 | udp | netmap_lm | Phillip Magson | Phillip Magson | This entry is an alias to "netmap-lm". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| ica | 1494 | tcp | ica | John Richardson | John Richardson | ||||||
| ica | 1494 | udp | ica | John Richardson | John Richardson | ||||||
| cvc | 1495 | tcp | cvc | Bill Davidson | Bill Davidson | ||||||
| cvc | 1495 | udp | cvc | Bill Davidson | Bill Davidson | ||||||
| liberty-lm | 1496 | tcp | liberty-lm | Jim Rogers | Jim Rogers | ||||||
| liberty-lm | 1496 | udp | liberty-lm | Jim Rogers | Jim Rogers | ||||||
| rfx-lm | 1497 | tcp | rfx-lm | Bill Bishop | Bill Bishop | ||||||
| rfx-lm | 1497 | udp | rfx-lm | Bill Bishop | Bill Bishop | ||||||
| sybase-sqlany | 1498 | tcp | Sybase SQL Any | Dave Neudoerffer | Dave Neudoerffer | ||||||
| sybase-sqlany | 1498 | udp | Sybase SQL Any | Dave Neudoerffer | Dave Neudoerffer | ||||||
| fhc | 1499 | tcp | Federico Heinz Consultora | Federico Heinz | Federico Heinz | ||||||
| fhc | 1499 | udp | Federico Heinz Consultora | Federico Heinz | Federico Heinz | ||||||
| shivahose | 1549 | tcp | Shiva Hose | ||||||||
| shivasound | 1549 | udp | Shiva Sound | Kin Chan | Kin Chan | ||||||
| kermit | 1649 | tcp | kermit | Frank da Cruz | Frank da Cruz | ||||||
| kermit | 1649 | udp | kermit | Frank da Cruz | Frank da Cruz | ||||||
| aspen-services | 1749 | tcp | aspen-services | Mark B. Hurst | Mark B. Hurst | ||||||
| aspen-services | 1749 | udp | aspen-services | Mark B. Hurst | Mark B. Hurst | ||||||
| alpha-sms | 1849 | tcp | ALPHA-SMS | Benjamin Grimm | Benjamin Grimm | ||||||
| alpha-sms | 1849 | udp | ALPHA-SMS | Benjamin Grimm | Benjamin Grimm | ||||||
| ismaeasdaqlive | 1949 | tcp | ISMA Easdaq Live | Stephen Dunne | Stephen Dunne | ||||||
| ismaeasdaqlive | 1949 | udp | ISMA Easdaq Live | Stephen Dunne | Stephen Dunne | ||||||
| shilp | 2049 | tcp | <== NOTE Conflict on 2049 ! | ||||||||
| shilp | 2049 | udp | <== NOTE Conflict on 2049 ! | ||||||||
| nfs | 2049 | tcp | Network File System - Sun Microsystems | Brent Callaghan | Brent Callaghan | Defined TXT keys: path=<path to mount point> | |||||
| nfs | 2049 | udp | Network File System - Sun Microsystems | Brent Callaghan | Brent Callaghan | Defined TXT keys: path=<path to mount point> | |||||
| nfs | 2049 | sctp | Network File System | RFC 5665 | Defined TXT keys: path=<path to mount point> | ||||||
| acptsys | 2149 | tcp | ACPTSYS | Michael Lekias | Michael Lekias | ||||||
| acptsys | 2149 | udp | ACPTSYS | Michael Lekias | Michael Lekias | ||||||
| rfmp | 2249 | tcp | RISO File Manager Protocol | Shinji Yamanaka | Shinji Yamanaka | ||||||
| rfmp | 2249 | udp | RISO File Manager Protocol | Shinji Yamanaka | Shinji Yamanaka | ||||||
| redstorm-diag | 2349 | tcp | Diagnostics Port IANA assigned this well-formed service name as a replacement for "redstorm_diag". |
David Weinstein | David Weinstein | ||||||
| redstorm_diag | 2349 | tcp | Diagnostics Port | David Weinstein | David Weinstein | This entry is an alias to "redstorm-diag". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| redstorm-diag | 2349 | udp | Diagnostics Port IANA assigned this well-formed service name as a replacement for "redstorm_diag". |
David Weinstein | David Weinstein | ||||||
| redstorm_diag | 2349 | udp | Diagnostics Port | David Weinstein | David Weinstein | This entry is an alias to "redstorm-diag". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| ratl | 2449 | tcp | RATL | Paul Greenfield | Paul Greenfield | ||||||
| ratl | 2449 | udp | RATL | Paul Greenfield | Paul Greenfield | ||||||
| qip-qdhcp | 2490 | tcp | qip_qdhcp | Mike Morgan | Mike Morgan | ||||||
| qip-qdhcp | 2490 | udp | qip_qdhcp | Mike Morgan | Mike Morgan |