Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
0 tcp Reserved 2024-12-20 RFC 6335
0 udp Reserved 2024-12-20 RFC 6335
2 tcp Reserved 2025-02-13 De-assigned on 2025-02-13, previously compressnet by Bernie Volz
2 udp Reserved 2025-02-13 De-assigned on 2025-02-13, previously compressnet by Bernie Volz
3 tcp Reserved 2025-02-13 De-assigned on 2025-02-13, previously compressnet by Bernie Volz
3 udp Reserved 2025-02-13 De-assigned on 2025-02-13, previously compressnet by Bernie Volz
rje 5 tcp Remote Job Entry Jon Postel Jon Postel
rje 5 udp Remote Job Entry Jon Postel Jon Postel
discard 9 dccp Discard Eddie Kohler Eddie Kohler RFC 4340 1145656131
15 tcp Unassigned [was netstat]
15 udp Unassigned
ftp 21 tcp File Transfer Protocol [Control] Jon Postel Jon Postel RFC 959 Defined TXT keys: u=<username> p=<password> path=<path>
ftp 21 udp File Transfer Protocol [Control] Jon Postel Jon Postel RFC 959 Defined TXT keys: u=<username> p=<password> path=<path>
ssh 22 tcp The Secure Shell (SSH) Protocol RFC 4251 Defined TXT keys: u=<username> p=<password>
ssh 22 udp The Secure Shell (SSH) Protocol RFC 4251 Defined TXT keys: u=<username> p=<password>
telnet 23 tcp Telnet Jon Postel Jon Postel RFC 854 Defined TXT keys: u=<username> p=<password>
telnet 23 udp Telnet Jon Postel Jon Postel RFC 854 Defined TXT keys: u=<username> p=<password>
smtp 25 tcp Simple Mail Transfer IESG IETF Chair 2017-06-05 RFC-ietf-emailcore-rfc5321bis-43
smtp 25 udp Simple Mail Transfer IESG IETF Chair 2017-06-05 RFC-ietf-emailcore-rfc5321bis-43
35 tcp any private printer server Jon Postel Jon Postel
35 udp any private printer server Jon Postel Jon Postel
mpm 45 tcp Message Processing Module [recv]
mpm 45 udp Message Processing Module [recv]
47 tcp Reserved 2017-05-18 This entry has been removed on 2017-05-18.
47 udp Reserved 2017-05-18 This entry has been removed on 2017-05-18.
re-mail-ck 50 tcp Remote Mail Checking Protocol Steve Dorner Steve Dorner
re-mail-ck 50 udp Remote Mail Checking Protocol Steve Dorner Steve Dorner
51 Reserved 2013-05-24 This entry is being removed on 2013-05-24.
xns-time 52 tcp XNS Time Protocol Susie Armstrong Susie Armstrong
xns-time 52 udp XNS Time Protocol Susie Armstrong Susie Armstrong
domain 53 tcp Domain Name Server Paul Mockapetris Paul Mockapetris
domain 53 udp Domain Name Server Paul Mockapetris Paul Mockapetris
xns-ch 54 tcp XNS Clearinghouse Susie Armstrong Susie Armstrong
xns-ch 54 udp XNS Clearinghouse Susie Armstrong Susie Armstrong
isi-gl 55 tcp ISI Graphics Language
isi-gl 55 udp ISI Graphics Language
xns-auth 56 tcp XNS Authentication Susie Armstrong Susie Armstrong
xns-auth 56 udp XNS Authentication Susie Armstrong Susie Armstrong
57 tcp any private terminal access Jon Postel Jon Postel
57 udp any private terminal access Jon Postel Jon Postel
xns-mail 58 tcp XNS Mail Susie Armstrong Susie Armstrong
xns-mail 58 udp XNS Mail Susie Armstrong Susie Armstrong
59 tcp any private file service Jon Postel Jon Postel
59 udp any private file service Jon Postel Jon Postel
61 tcp Reserved 2017-05-18 This entry has been removed on 2017-05-18.
61 udp Reserved 2017-05-18 This entry has been removed on 2017-05-18.
tacacs-ds 65 tcp TACACS-Database Service Kathy Huber Kathy Huber
tacacs-ds 65 udp TACACS-Database Service Kathy Huber Kathy Huber
bootps 67 tcp Bootstrap Protocol Server Bill Croft Bill Croft RFC 951 Defined TXT keys: None
75 tcp any private dial out service Jon Postel Jon Postel
75 udp any private dial out service Jon Postel Jon Postel
mit-ml-dev 85 tcp MIT ML Device David Reed David Reed
mit-ml-dev 85 udp MIT ML Device David Reed David Reed
supdup 95 tcp SUPDUP Mark Crispin Mark Crispin
supdup 95 udp SUPDUP Mark Crispin Mark Crispin
cso 105 tcp CCSO name server protocol Martin Hamilton Martin Hamilton
cso 105 udp CCSO name server protocol Martin Hamilton Martin Hamilton
csnet-ns 105 tcp Mailbox Name Nameserver Marvin Solomon Marvin Solomon
csnet-ns 105 udp Mailbox Name Nameserver Marvin Solomon Marvin Solomon
sftp 115 tcp Simple File Transfer Protocol Mark Lottor Mark Lottor
sftp 115 udp Simple File Transfer Protocol Mark Lottor Mark Lottor
ntp 123 tcp Network Time Protocol Dave Mills Dave Mills RFC 5905
ntp 123 udp Network Time Protocol Dave Mills Dave Mills RFC 5905
locus-map 125 tcp Locus PC-Interface Net Map Ser Eric Peterson Eric Peterson
locus-map 125 udp Locus PC-Interface Net Map Ser Eric Peterson Eric Peterson
epmap 135 tcp DCE endpoint resolution Joe Pato Joe Pato
epmap 135 udp DCE endpoint resolution Joe Pato Joe Pato
imap 143 tcp Internet Message Access Protocol IESG IETF Chair 2021-02-22 RFC 3501; RFC 9051
143 udp Reserved 2021-02-22 RFC 9051
uaac 145 tcp UAAC Protocol David A. Gomberg David A. Gomberg
uaac 145 udp UAAC Protocol David A. Gomberg David A. Gomberg
aed-512 149 tcp AED 512 Emulation Service Albert G. Broscius Albert G. Broscius
aed-512 149 udp AED 512 Emulation Service Albert G. Broscius Albert G. Broscius
sql-net 150 tcp SQL-NET Martin Picard Martin Picard
sql-net 150 udp SQL-NET Martin Picard Martin Picard
hems 151 tcp HEMS
hems 151 udp HEMS
bftp 152 tcp Background File Transfer Program Annette DeSchon Annette DeSchon
bftp 152 udp Background File Transfer Program Annette DeSchon Annette DeSchon
sgmp 153 tcp SGMP Marty Schoffstahl Marty Schoffstahl
sgmp 153 udp SGMP Marty Schoffstahl Marty Schoffstahl
netsc-prod 154 tcp NETSC
netsc-prod 154 udp NETSC
netsc-dev 155 tcp NETSC Sergio Heker Sergio Heker
netsc-dev 155 udp NETSC Sergio Heker Sergio Heker
sqlsrv 156 tcp SQL Service Craig Rogers Craig Rogers
sqlsrv 156 udp SQL Service Craig Rogers Craig Rogers
knet-cmp 157 tcp KNET/VM Command/Message Protocol Gary S. Malkin Gary S. Malkin
knet-cmp 157 udp KNET/VM Command/Message Protocol Gary S. Malkin Gary S. Malkin
pcmail-srv 158 tcp PCMail Server Mark L. Lambert Mark L. Lambert
pcmail-srv 158 udp PCMail Server Mark L. Lambert Mark L. Lambert
nss-routing 159 tcp NSS-Routing Yakov Rekhter Yakov Rekhter
nss-routing 159 udp NSS-Routing Yakov Rekhter Yakov Rekhter
xns-courier 165 tcp Xerox Susie Armstrong Susie Armstrong
xns-courier 165 udp Xerox Susie Armstrong Susie Armstrong
vmnet 175 tcp VMNET Christopher Tengi Christopher Tengi
vmnet 175 udp VMNET Christopher Tengi Christopher Tengi
remote-kis 185 tcp Remote-KIS
remote-kis 185 udp Remote-KIS
dn6-nlm-aud 195 tcp DNSIX Network Level Module Audit

Contact Information

Name Organization Contact URI Last Updated
Albert G. Broscius broscius&dsl.cis.upenn.edu
Annette DeSchon DESCHON&isi.edu
Bernie Volz volz&cisco.com
Bill Croft Croft&sumex-aim.stanford.edu
Christopher Tengi tengi&princeton.edu
Craig Rogers Rogers&isi.edu
Dave Mills mills&udel.edu 2022-06-03
David A. Gomberg gomberg&gateway.mitre.org
David Reed
Eddie Kohler IETF dccp WG kohler&cs.ucla.edu
Eric Peterson lcc.eric&seas.ucla.edu
Gary S. Malkin GMALKIN&xylogics.com
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Joe Pato pato&apollo.hp.com
Jon Postel postel&isi.edu
Kathy Huber khuber&bbn.com
Mark Crispin MRC&panda.com
Mark L. Lambert markl&ptt.lcs.mit.edu
Mark Lottor MKL&nisc.sri.com
Martin Hamilton martin&mrrl.lut.as.uk
Martin Picard
Marty Schoffstahl schoff&nisc.nyser.net
Marvin Solomon solomon&cs.wisc.edu
Paul Mockapetris PVM&isi.edu
Sergio Heker heker&jvncc.csc.org
Steve Dorner s-dorner&uiuc.edu
Susie Armstrong Armstrong.wbst128@xerox
Susie Armstrong Armstrong.wbst128&xerox.com
Yakov Rekhter Yakov&ibm.com