Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| isakmp | 500 | tcp | isakmp | Mark Schertler | Mark Schertler | ||||||
| isakmp | 500 | udp | isakmp | Mark Schertler | Mark Schertler | ||||||
| vlsi-lm | 1500 | tcp | VLSI License Manager | Shue-Lin Kuo | Shue-Lin Kuo | ||||||
| vlsi-lm | 1500 | udp | VLSI License Manager | Shue-Lin Kuo | Shue-Lin Kuo | ||||||
| apx500api-1 | 2264 | tcp | Audio Precision Apx500 API Port 1 | ||||||||
| apx500api-1 | 2264 | udp | Audio Precision Apx500 API Port 1 | ||||||||
| apx500api-2 | 2265 | tcp | Audio Precision Apx500 API Port 2 | Robert Wright, Founder and Principal Engineer | Robert Wright, Founder and Principal Engineer | ||||||
| apx500api-2 | 2265 | udp | Audio Precision Apx500 API Port 2 | Robert Wright, Founder and Principal Engineer | Robert Wright, Founder and Principal Engineer | ||||||
| rtsserv | 2500 | tcp | Resource Tracking system server | ||||||||
| rtsserv | 2500 | udp | Resource Tracking system server | ||||||||
| astronova-main | 2864 | tcp | main 5001 cmd | AstroNova, Inc. | Chris Tate | 2020-03-03 | |||||
| astronova-main | 2864 | udp | main 5001 cmd | AstroNova, Inc. | Chris Tate | 2020-03-03 | |||||
| rtmp-port | 3500 | tcp | RTMP Port | Miriam Wohlgelernter | Miriam Wohlgelernter | ||||||
| rtmp-port | 3500 | udp | RTMP Port | Miriam Wohlgelernter | Miriam Wohlgelernter | ||||||
| ipsec-nat-t | 4500 | tcp | IPsec NAT-Traversal | 2022-09-15 | RFC 9329 | ||||||
| ipsec-nat-t | 4500 | udp | IPsec NAT-Traversal | 2017-07-07 | RFC 3948; RFC 7296 | ||||||
| commplex-main | 5000 | tcp | |||||||||
| commplex-main | 5000 | udp | |||||||||
| commplex-link | 5001 | tcp | |||||||||
| commplex-link | 5001 | udp | |||||||||
| rfe | 5002 | tcp | radio free ethernet | ||||||||
| rfe | 5002 | udp | radio free ethernet | ||||||||
| fmpro-internal | 5003 | tcp | FileMaker, Inc. - Proprietary transport | Clay Maeckel | Clay Maeckel | ||||||
| fmpro-internal | 5003 | udp | FileMaker, Inc. - Proprietary name binding | Clay Maeckel | Clay Maeckel | ||||||
| avt-profile-1 | 5004 | tcp | RTP media data | RFC 3551; RFC 4571 | |||||||
| avt-profile-1 | 5004 | udp | RTP media data | RFC 3551 | |||||||
| avt-profile-1 | 5004 | dccp | RTP media data | RFC 3551; RFC 5762 | |||||||
| avt-profile-2 | 5005 | tcp | RTP control protocol | RFC 3551; RFC 4571 | |||||||
| avt-profile-2 | 5005 | udp | RTP control protocol | RFC 3551 | |||||||
| avt-profile-2 | 5005 | dccp | RTP control protocol | RFC 3551; RFC 5762 | |||||||
| wsm-server | 5006 | tcp | wsm server | Adam Berk | Adam Berk | ||||||
| wsm-server | 5006 | udp | wsm server | Adam Berk | Adam Berk | ||||||
| wsm-server-ssl | 5007 | tcp | wsm server ssl | Adam Berk | Adam Berk | ||||||
| wsm-server-ssl | 5007 | udp | wsm server ssl | Adam Berk | Adam Berk | ||||||
| synapsis-edge | 5008 | tcp | Synapsis EDGE | Paul Schilling | Paul Schilling | ||||||
| synapsis-edge | 5008 | udp | Synapsis EDGE | Paul Schilling | Paul Schilling | ||||||
| winfs | 5009 | tcp | Microsoft Windows Filesystem | Simon Skaria | Simon Skaria | 2006-01 | |||||
| winfs | 5009 | udp | Microsoft Windows Filesystem | Simon Skaria | Simon Skaria | 2006-01 | |||||
| fcp-addr-srvr1 | 5500 | tcp | fcp-addr-srvr1 | Ken Wittmer | Ken Wittmer | ||||||
| fcp-addr-srvr1 | 5500 | udp | fcp-addr-srvr1 | Ken Wittmer | Ken Wittmer | ||||||
| x500ms | 5757 | tcp | OpenMail X.500 Directory Server | OpenMail Encyclopedia; Don Loughry | OpenMail Encyclopedia; Don Loughry | ||||||
| x500ms | 5757 | udp | OpenMail X.500 Directory Server | OpenMail Encyclopedia; Don Loughry | OpenMail Encyclopedia; Don Loughry | ||||||
| boks | 6500 | tcp | BoKS Master | Magnus Nystrom | Magnus Nystrom | ||||||
| boks | 6500 | udp | BoKS Master | Magnus Nystrom | Magnus Nystrom | ||||||
| silhouette | 7500 | tcp | Silhouette User | Anthony Payne | Anthony Payne | 2004-02 | |||||
| silhouette | 7500 | udp | Silhouette User | Anthony Payne | Anthony Payne | 2004-02 | |||||
| fmtp | 8500 | tcp | Flight Message Transfer Protocol | Eivan Cerasi | Eivan Cerasi | 2003-12 | |||||
| fmtp | 8500 | udp | Flight Message Transfer Protocol | Eivan Cerasi | Eivan Cerasi | 2003-12 | |||||
| ismserver | 9500 | tcp | ismserver | Ian Gordon | Ian Gordon | ||||||
| ismserver | 9500 | udp | ismserver | Ian Gordon | Ian Gordon | ||||||
| 10500 | tcp | Reserved | |||||||||
| hip-nat-t | 10500 | udp | HIP NAT-Traversal | IESG | IETF Chair | 2020-08-12 | RFC 5770; RFC 9028 | ||||
| xpra | 14500 | tcp | xpra network protocol | Xpra | Antoine Martin | 2016-10-05 | |||||
| 14500 | udp | Reserved | |||||||||
| hydap | 15000 | tcp | Hypack Data Aquisition | HYPACK Inc. | Mircea Neacsu | 2011-10-27 | |||||
| hydap | 15000 | udp | Hypack Data Aquisition | HYPACK Inc. | Mircea Neacsu | 2011-10-27 | |||||
| 15001 | Unassigned | ||||||||||
| onep-tls | 15002 | tcp | Open Network Environment TLS | Cisco | Andrew Thurber | 2014-01-21 | |||||
| 15002 | udp | Reserved | |||||||||
| 15003-15117 | Unassigned | ||||||||||
| db-lsp | 17500 | tcp | Dropbox LanSync Protocol | Paul Bohm | Paul Bohm | 2010-01-21 | |||||
| db-lsp-disc | 17500 | udp | Dropbox LanSync Discovery | Paul Bohm | Paul Bohm | 2010-01-21 | |||||
| icl-twobase1 | 25000 | tcp | icl-twobase1 | J. A. (Tony) Sever | J. A. (Tony) Sever | ||||||
| icl-twobase1 | 25000 | udp | icl-twobase1 | J. A. (Tony) Sever | J. A. (Tony) Sever | ||||||
| icl-twobase2 | 25001 | tcp | icl-twobase2 | J. A. (Tony) Sever | J. A. (Tony) Sever | ||||||
| icl-twobase2 | 25001 | udp | icl-twobase2 | J. A. (Tony) Sever | J. A. (Tony) Sever | ||||||
| icl-twobase3 | 25002 | tcp | icl-twobase3 | J. A. (Tony) Sever | J. A. (Tony) Sever | ||||||
| icl-twobase3 | 25002 | udp | icl-twobase3 | J. A. (Tony) Sever | J. A. (Tony) Sever | ||||||
| icl-twobase4 | 25003 | tcp | icl-twobase4 | J. A. (Tony) Sever | J. A. (Tony) Sever | ||||||
| icl-twobase4 | 25003 | udp | icl-twobase4 | J. A. (Tony) Sever | J. A. (Tony) Sever | ||||||
| icl-twobase5 | 25004 | tcp | icl-twobase5 | J. A. (Tony) Sever | J. A. (Tony) Sever | ||||||
| icl-twobase5 | 25004 | udp | icl-twobase5 | J. A. (Tony) Sever | J. A. (Tony) Sever | ||||||
| icl-twobase6 | 25005 | tcp | icl-twobase6 | J. A. (Tony) Sever | J. A. (Tony) Sever | ||||||
| icl-twobase6 | 25005 | udp | icl-twobase6 | J. A. (Tony) Sever | J. A. (Tony) Sever | ||||||
| icl-twobase7 | 25006 | tcp | icl-twobase7 | J. A. (Tony) Sever | J. A. (Tony) Sever | ||||||
| icl-twobase7 | 25006 | udp | icl-twobase7 | J. A. (Tony) Sever | J. A. (Tony) Sever | ||||||
| icl-twobase8 | 25007 | tcp | icl-twobase8 | J. A. (Tony) Sever | J. A. (Tony) Sever | ||||||
| icl-twobase8 | 25007 | udp | icl-twobase8 | J. A. (Tony) Sever | J. A. (Tony) Sever | ||||||
| icl-twobase9 | 25008 | tcp | icl-twobase9 | J. A. (Tony) Sever | J. A. (Tony) Sever | ||||||
| icl-twobase9 | 25008 | udp | icl-twobase9 | J. A. (Tony) Sever | J. A. (Tony) Sever | ||||||
| icl-twobase10 | 25009 | tcp | icl-twobase10 | J. A. (Tony) Sever | J. A. (Tony) Sever | ||||||
| icl-twobase10 | 25009 | udp | icl-twobase10 | J. A. (Tony) Sever | J. A. (Tony) Sever | ||||||
| heathview | 35000 | tcp | HeathView | Heathwest Systems Limited | Andrew Porrer | 2013-03-21 | |||||
| 35000 | udp | Reserved | |||||||||
| rt-viewer | 35001 | tcp | ReadyTech Viewer | ReadyTech Corporation | Kevin Woodward | 2013-09-13 | |||||
| rt-viewer | 35001 | udp | ReadyTech Viewer | ReadyTech Corporation | Kevin Woodward | 2013-09-13 | |||||
| rt-sound | 35002 | tcp | ReadyTech Sound Server | ReadyTech Corporation | Kevin Woodward | 2013-09-13 | |||||
| 35002 | udp | Reserved | |||||||||
| rt-devicemapper | 35003 | tcp | ReadyTech DeviceMapper Server | ReadyTech Corporation | Kevin Woodward | 2013-09-13 | |||||
| 35003 | udp | Reserved | |||||||||
| rt-classmanager | 35004 | tcp | ReadyTech ClassManager | ReadyTech Corporation | Kevin Woodward | 2013-09-13 | |||||
| rt-classmanager | 35004 | udp | ReadyTech ClassManager | ReadyTech Corporation | Kevin Woodward | 2013-09-13 | |||||
| rt-labtracker | 35005 | tcp | ReadyTech LabTracker | ReadyTech Corporation | Kevin Woodward | 2013-09-13 | |||||
| 35005 | udp | Reserved | |||||||||
| rt-helper | 35006 | tcp | ReadyTech Helper Service | ReadyTech Corporation | Kevin Woodward | 2013-09-13 | |||||
| 35006 | udp | Reserved | |||||||||
| 35007-35099 | Unassigned | ||||||||||
| asmp | 45000 | tcp | Nuance AutoStore Status Monitoring Protocol (data transfer) | Nuance Communications, Inc. | Andrew Andrews | 2011-09-01 | 2017-04-26 | ||||
| asmp-mon | 45000 | udp | Nuance AutoStore Status Monitoring Protocol (device monitoring) | Nuance Communications, Inc. | Andrew Andrews | 2011-09-01 | 2017-04-26 | ||||
| asmps | 45001 | tcp | Nuance AutoStore Status Monitoring Protocol (secure data transfer) | Nuance Communications, Inc. | Andrew Andrews | 2011-09-01 | 2017-04-26 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Adam Berk | aberk&empirix.com | ||
| Andrew Andrews | Andrew.Andrews&Nuance.com | 2017-04-26 | |
| Andrew Porrer | Heathwest Systems Limited | Andrew.Porrer&heathwest.com | 2013-03-21 |
| Andrew Thurber | Cisco | anthurbe@cisco.com> | 2014-01-21 |
| Anthony Payne | opayne&pacbell.net | 2004-02 | |
| Antoine Martin | antoine&nagafix.co.uk | 2016-10-05 | |
| AstroNova, Inc. | ctate&astronovainc.com | 2020-03-03 | |
| Chris Tate | ctate&astronovainc.com | 2020-03-03 | |
| Cisco | anthurbe@cisco.com> | 2014-01-21 | |
| Clay Maeckel | clay&claris.com | 2023-09-12 | |
| Don Loughry | DON_LOUGHRY&hp-cupertino-om4.om.hp.com | ||
| Eivan Cerasi | eivan.cerasi&eurocontrol.int | 2022-08-08 | |
| Heathwest Systems Limited | info&heathwest.com | 2013-03-21 | |
| HYPACK Inc. | mircea&hypack.com | 2011-10-27 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Ian Gordon | iangµmuse.co.uk | ||
| J. A. (Tony) Sever | J.A.Sever&bra0119.wins.icl.co.uk | ||
| Ken Wittmer | kenneth.m.wittmer&accenture.com | ||
| Kevin Woodward | ReadyTech Corporation | kwoodward&readytech.com | 2013-09-13 |
| Magnus Nystrom | magnus&dynas.se | ||
| Mark Schertler | mjs&tycho.ncsc.mil | ||
| Mircea Neacsu | mircea&hypack.com | 2011-10-27 | |
| Miriam Wohlgelernter | miriamw&adirtech.com | ||
| Nuance Communications, Inc. | dev&nsius.com | 2017-04-26 | |
| OpenMail Encyclopedia | opencyc&hpopd.pwd.hp.com | ||
| Paul Bohm | paul&dropbox.com | 2010-01-21 | |
| Paul Schilling | PaulS&synapsis.com | ||
| ReadyTech Corporation | kwoodward&readytech.com | 2013-09-13 | |
| Robert Wright, Founder and Principal Engineer | Audio Precision Inc. | ianaports&ap.com | 2006-05 |
| Shue-Lin Kuo | shuelin&mdk.sanjose.vlsi.com | ||
| Simon Skaria | simonskµsoft.com | 2006-01 | |
| Xpra | xpra&xpra.org | 2016-10-05 |