Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-13

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
mbap 502 tcp Modbus Application Protocol modbus.org Dennis Dube 2014-06-10
mbap 502 udp Modbus Application Protocol modbus.org Dennis Dube 2014-06-10
shivadiscovery 1502 tcp Shiva Jonathan Wenocur Jonathan Wenocur
shivadiscovery 1502 udp Shiva Jonathan Wenocur Jonathan Wenocur
kentrox-prot 2502 tcp Kentrox Protocol Anil Lakhwara Anil Lakhwara
kentrox-prot 2502 udp Kentrox Protocol Anil Lakhwara Anil Lakhwara
odette-ftp 3305 tcp ODETTE-FTP David Nash David Nash RFC 5024
odette-ftp 3305 udp ODETTE-FTP David Nash David Nash RFC 5024
avinstalldisc 3502 tcp Avocent Install Discovery Brian S. Stewart Brian S. Stewart
avinstalldisc 3502 udp Avocent Install Discovery Brian S. Stewart Brian S. Stewart
a25-fap-fgw 4502 sctp A25 (FAP-FGW) 3GPP2 Zhiming Li 2012-01-11
zenginkyo-1 5020 tcp zenginkyo-1 Masashi Suzaki Masashi Suzaki
zenginkyo-1 5020 udp zenginkyo-1 Masashi Suzaki Masashi Suzaki
zenginkyo-2 5021 tcp zenginkyo-2 Masashi Suzaki Masashi Suzaki
zenginkyo-2 5021 udp zenginkyo-2 Masashi Suzaki Masashi Suzaki
mice 5022 tcp mice server Alan Clifford Alan Clifford
mice 5022 udp mice server Alan Clifford Alan Clifford
htuilsrv 5023 tcp Htuil Server for PLD2 Dennis Reinhardt Dennis Reinhardt
htuilsrv 5023 udp Htuil Server for PLD2 Dennis Reinhardt Dennis Reinhardt
scpi-telnet 5024 tcp SCPI-TELNET Interchangeable Virtual Instruments Foundation, Inc. Larry Ostheimer 2021-05-06
scpi-telnet 5024 udp SCPI-TELNET Interchangeable Virtual Instruments Foundation, Inc. Larry Ostheimer 2021-05-06
scpi-raw 5025 tcp SCPI-RAW Interchangeable Virtual Instruments Foundation, Inc. Larry Ostheimer 2021-05-06
scpi-raw 5025 udp SCPI-RAW Interchangeable Virtual Instruments Foundation, Inc. Larry Ostheimer 2021-05-06
strexec-d 5026 tcp Storix I/O daemon (data) Storix Inc. David Huffman 2005-08
strexec-d 5026 udp Storix I/O daemon (data) Storix Inc. David Huffman 2005-08
strexec-s 5027 tcp Storix I/O daemon (stat) Storix Inc. David Huffman 2005-08
strexec-s 5027 udp Storix I/O daemon (stat) Storix Inc. David Huffman 2005-08
qvr 5028 tcp Quiqum Virtual Relais Philipp Marcel Albrecht Philipp Marcel Albrecht 2009-07-06
5028 udp Reserved
infobright 5029 tcp Infobright Database Server Mark Windrim Mark Windrim 2009-07-23
infobright 5029 udp Infobright Database Server Mark Windrim Mark Windrim 2009-07-23
fcp-srvr-inst1 5502 tcp fcp-srvr-inst1 Ken Wittmer Ken Wittmer
fcp-srvr-inst1 5502 udp fcp-srvr-inst1 Ken Wittmer Ken Wittmer
boks-servm 6502 tcp BoKS Servm

IANA assigned this well-formed service name as a replacement for "boks_servm".
Magnus Nystrom Magnus Nystrom
boks_servm 6502 tcp BoKS Servm Magnus Nystrom Magnus Nystrom This entry is an alias to "boks-servm". This entry is now historic, not usable for use with many common service discovery mechanisms.
boks-servm 6502 udp BoKS Servm

IANA assigned this well-formed service name as a replacement for "boks_servm".
Magnus Nystrom Magnus Nystrom
boks_servm 6502 udp BoKS Servm Magnus Nystrom Magnus Nystrom This entry is an alias to "boks-servm". This entry is now historic, not usable for use with many common service discovery mechanisms.
odette-ftps 6619 tcp ODETTE-FTP over TLS/SSL Ieuan Friend Ieuan Friend 2006-03 RFC 5024
odette-ftps 6619 udp ODETTE-FTP over TLS/SSL Ieuan Friend Ieuan Friend 2006-03 RFC 5024
7502-7507 Unassigned
ftnmtp 8502 tcp FTN Message Transfer Protocol Yuri Myakotin Yuri Myakotin 2014-01-07
8502 udp Reserved

Contact Information

Name Organization Contact URI Last Updated
3GPP2 lizhiming&huawei.com 2012-01-11
Alan Clifford alan&clifford.ac
Anil Lakhwara anil_lakhwara&kentrox.com
Brian S. Stewart Brian.Stewart&avovent.com
David Huffman sba&storix.com 2016-03-22
David Nash dnash&ford.com
Dennis Dube dennis.dube&schneider-electric.com 2014-06-10
Dennis Reinhardt DennisR&dair.com
Ieuan Friend ieuan.friend&dip.co.uk 2006-03
Interchangeable Virtual Instruments Foundation, Inc. ivi.contact&ivifoundation.org 2021-05-06
Jonathan Wenocur jhw&shiva.com
Ken Wittmer kenneth.m.wittmer&accenture.com
Larry Ostheimer larry_ostheimer&keysight.com 2021-05-06
Magnus Nystrom magnus&dynas.se
Mark Windrim mark.windrim&infobright.com 2009-07-23
Masashi Suzaki susakim&noa.nttdata.jp
modbus.org rbelliardi&modbus.org 2014-06-10
Philipp Marcel Albrecht info&uisa.ch 2023-10-23
Storix Inc. sba&storix.com 2016-03-22
Yuri Myakotin yuri&ym-com.net 2014-01-07
Zhiming Li 3GPP2 lizhiming&huawei.com 2012-01-11