Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| fcp | 510 | tcp | FirstClass Protocol | Mike Marshburn | Mike Marshburn | ||||||
| fcp | 510 | udp | FirstClass Protocol | Mike Marshburn | Mike Marshburn | ||||||
| mvx-lm | 1510 | tcp | Midland Valley Exploration Ltd. Lic. Man. | Neil Salter | Neil Salter | ||||||
| mvx-lm | 1510 | udp | Midland Valley Exploration Ltd. Lic. Man. | Neil Salter | Neil Salter | ||||||
| fjappmgrbulk | 2510 | tcp | fjappmgrbulk | Hiroyuki Kawabuchi | Hiroyuki Kawabuchi | ||||||
| fjappmgrbulk | 2510 | udp | fjappmgrbulk | Hiroyuki Kawabuchi | Hiroyuki Kawabuchi | ||||||
| xss-port | 3510 | tcp | XSS Port | Joe Purcell | Joe Purcell | 2002-05 | |||||
| xss-port | 3510 | udp | XSS Port | Joe Purcell | Joe Purcell | 2002-05 | |||||
| socalia | 5100 | tcp | Socalia service mux | Alberto Raydan | Alberto Raydan | 2005-08 | |||||
| socalia | 5100 | udp | Socalia service mux | Alberto Raydan | Alberto Raydan | 2005-08 | |||||
| talarian-tcp | 5101 | tcp | Talarian_TCP | Leo Martins | Leo Martins | ||||||
| talarian-udp | 5101 | udp | Talarian_UDP | Leo Martins | Leo Martins | ||||||
| oms-nonsecure | 5102 | tcp | Oracle OMS non-secure | Todd Guay | Todd Guay | 2005-08 | |||||
| oms-nonsecure | 5102 | udp | Oracle OMS non-secure | Todd Guay | Todd Guay | 2005-08 | |||||
| actifio-c2c | 5103 | tcp | Actifio C2C | Ravi Kollipara | Ravi Kollipara | 2010-06-18 | |||||
| 5103 | udp | Reserved | |||||||||
| 5104 | tcp | Reserved | |||||||||
| tinymessage | 5104 | udp | TinyMessage | Josip Medved | Josip Medved | 2010-10-20 | |||||
| 5105 | tcp | Reserved | |||||||||
| hughes-ap | 5105 | udp | Hughes Association Protocol | Varun Santosh | Varun Santosh | 2010-10-20 | |||||
| actifioudsagent | 5106 | tcp | Actifio UDS Agent | Actifio | Madhav Mutalik | 2014-06-05 | |||||
| 5106 | udp | Reserved | |||||||||
| actifioreplic | 5107 | tcp | Disk to Disk replication between Actifio Clusters | Actifio | Madhav Mutalik | 2015-10-23 | |||||
| 5107 | udp | Reserved | |||||||||
| 5108-5110 | Unassigned | ||||||||||
| mcer-port | 6510 | tcp | MCER Port | Portnoy Boxman | Portnoy Boxman | ||||||
| mcer-port | 6510 | udp | MCER Port | Portnoy Boxman | Portnoy Boxman | ||||||
| mpls-udp | 6635 | udp | Encapsulate MPLS packets in UDP tunnels. | IESG | IETF Chair | 2015-02-10 | RFC 7510 | ||||
| mpls-udp-dtls | 6636 | udp | Encapsulate MPLS packets in UDP tunnels with DTLS. | IESG | IETF Chair | 2015-02-10 | RFC 7510 | ||||
| ovhpas | 7510 | tcp | HP OpenView Application Server | Jeff Conrad | Jeff Conrad | ||||||
| ovhpas | 7510 | udp | HP OpenView Application Server | Jeff Conrad | Jeff Conrad | ||||||
| x510 | 9877 | tcp | The X.510 wrapper protocol | ITU/TSB (ITU-T Study Group 17) | Erik Andersen | 2019-09-30 | ITU-T X.510 / ISO/IEC 9584-11 | ||||
| db2c-tls | 25100 | tcp | IBM Db2 Client Interface - Encrypted | IBM | Matthew Emmerton | 2024-03-05 | |||||
| 25100 | udp | Reserved | |||||||||
| 25101-25470 | Unassigned | ||||||||||
| axio-disc | 35100 | tcp | Axiomatic discovery protocol | Axiomatic Technologies Corporation | Oleksandr_Bogush | 2016-12-09 | |||||
| axio-disc | 35100 | udp | Axiomatic discovery protocol | Axiomatic Technologies Corporation | Oleksandr_Bogush | 2016-12-09 | |||||
| 35101-35353 | Unassigned | ||||||||||
| caerpc | 42510 | tcp | CA eTrust RPC | Jon Press | Jon Press | 2005-08 | |||||
| caerpc | 42510 | udp | CA eTrust RPC | Jon Press | Jon Press | 2005-08 | |||||
| x510 | tcp | Security service to protocols | ITU-T Study Group 17 | Erik Andersen | 2019-08-13 | Defined TXT keys: None |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Actifio | madhav.mutalik&actifio.com | 2015-10-23 | |
| Alberto Raydan | raydan_a&socalia.com | 2005-08 | |
| Axiomatic Technologies Corporation | obogush&axiomatic.com | 2016-12-09 | |
| Erik Andersen | era&x500.eu | 2019-08-13 | |
| Hiroyuki Kawabuchi | buchi&ael.fujitsu.co.jp | ||
| IBM | memmerto&ca.ibm.com | 2024-03-05 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| ITU-T Study Group 17 | era&x500.eu | 2019-08-13 | |
| ITU/TSB (ITU-T Study Group 17) | tsbsg17&itu.int | 2019-09-30 | |
| Jeff Conrad | jeff_conrad&hp.com | ||
| Joe Purcell | jpurcell&ensuretech.com | 2003-01 | |
| Jon Press | IANA.Registions&ca.com | 2005-09 | |
| Josip Medved | jmedved&jmedved.com | 2010-10-20 | |
| Leo Martins | leo&talarian.com | ||
| Madhav Mutalik | Actifio | madhav.mutalik&actifio.com | 2015-10-23 |
| Matthew Emmerton | IBM | memmerto&ca.ibm.com | 2024-03-05 |
| Mike Marshburn | paul&softarc.com | ||
| Neil Salter | neil&indigo2.mvel.demon.co.uk | ||
| Oleksandr_Bogush | obogush&axiomatic.com | 2016-12-09 | |
| Portnoy Boxman | portnoy_boxman&bmc.com | 2005-01 | |
| Ravi Kollipara | ravi.kollipara&actifio.com | 2010-06-18 | |
| Todd Guay | todd.guay&oracle.com | 2005-08 | |
| Varun Santosh | varun.santosh&hughes.com | 2010-10-20 |