Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-13
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| login | 513 | tcp | remote login a la telnet; automatic authentication performed based on priviledged port numbers and distributed data bases which identify "authentication domains" | ||||||||
| who | 513 | udp | maintains data bases showing who's logged in to machines on a local net and the load average of the machine | ||||||||
| fujitsu-dtc | 1513 | tcp | Fujitsu Systems Business of America, Inc | ||||||||
| fujitsu-dtc | 1513 | udp | Fujitsu Systems Business of America, Inc | ||||||||
| citrixadmin | 2513 | tcp | Citrix ADMIN | Myk Willis | Myk Willis | ||||||
| citrixadmin | 2513 | udp | Citrix ADMIN | Myk Willis | Myk Willis | ||||||
| mdtp | 3232 | tcp | MDT port | 2012-02-21 | RFC 6513 | ||||||
| mdtp | 3232 | udp | MDT port | 2012-02-21 | RFC 6513 | ||||||
| arcpd | 3513 | tcp | Adaptec Remote Protocol | Hardy Doelfel | Hardy Doelfel | 2002-05 | |||||
| arcpd | 3513 | udp | Adaptec Remote Protocol | Hardy Doelfel | Hardy Doelfel | 2002-05 | |||||
| 5121-5132 | Unassigned | ||||||||||
| nbt-pc | 5133 | tcp | Policy Commander | Emily Harris | Emily Harris | 2004-11 | |||||
| nbt-pc | 5133 | udp | Policy Commander | Emily Harris | Emily Harris | 2004-11 | |||||
| ppactivation | 5134 | tcp | PP ActivationServer | Ian Bradley | Ian Bradley | 2009-10-14 | |||||
| 5134 | udp | Reserved | |||||||||
| erp-scale | 5135 | tcp | ERP-Scale | Ian Bradley | Ian Bradley | 2009-10-14 | Defined TXT keys: RFC=<RFC destination and status> Device=<Scale device and status> |
||||
| 5135 | udp | Reserved | |||||||||
| 5136 | tcp | Reserved | |||||||||
| minotaur-sa | 5136 | udp | Minotaur SA | Kenneth Flynn | Kenneth Flynn | 2009-10-14 | |||||
| ctsd | 5137 | tcp | MyCTS server port | Jilles Oldenbeuving | Jilles Oldenbeuving | 2002-06 | |||||
| ctsd | 5137 | udp | MyCTS server port | Jilles Oldenbeuving | Jilles Oldenbeuving | 2002-06 | |||||
| 5138-5144 | Unassigned | ||||||||||
| netconf-tls | 6513 | tcp | NETCONF over TLS | IESG | IETF Chair | 2024-01-24 | RFC 7589; RFC 9918 | ||||
| 6513 | udp | Reserved | |||||||||
| 45186-45513 | Unassigned |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Emily Harris | eharris&newboundary.com | 2004-11 | |
| Hardy Doelfel | hardy_doelfel&adaptec.com | 2002-05 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Ian Bradley | ian.bradley&pocketprograms.com
development&pocketprograms.com |
2009-10-14 | |
| Jilles Oldenbeuving | ojilles&gmail.com | 2020-11-18 | |
| Kenneth Flynn | flynnk&darkcornersoftware.com | 2009-10-14 | |
| Myk Willis | myk.willis&citrix.com |