Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
xns-time 52 tcp XNS Time Protocol Susie Armstrong Susie Armstrong
xns-time 52 udp XNS Time Protocol Susie Armstrong Susie Armstrong
bftp 152 tcp Background File Transfer Program Annette DeSchon Annette DeSchon
bftp 152 udp Background File Transfer Program Annette DeSchon Annette DeSchon
dtag-ste-sb 352 tcp DTAG Ruediger Wald Ruediger Wald (assigned long ago)
dtag-ste-sb 352 udp DTAG Ruediger Wald Ruediger Wald (assigned long ago)
bhoedap4 352 tcp bhoedap4 John Kelly John Kelly This entry records an unassigned but widespread use (added 5/21/97)
bhoedap4 352 udp bhoedap4 John Kelly John Kelly This entry records an unassigned but widespread use (added 5/21/97)
sfs-config 452 tcp Cray SFS config server Walter Poxon Walter Poxon
sfs-config 452 udp Cray SFS config server Walter Poxon Walter Poxon
efs 520 tcp extended file name server
router 520 udp local routing process (on site); uses variant of Xerox NS routing information protocol - RIP
ripng 521 tcp ripng Robert E. Minnear Robert E. Minnear
ripng 521 udp ripng Robert E. Minnear Robert E. Minnear
ulp 522 tcp ULP Max Morris Max Morris
ulp 522 udp ULP Max Morris Max Morris
ibm-db2 523 tcp IBM-DB2 Juliana Hsu Juliana Hsu
ibm-db2 523 udp IBM-DB2 Juliana Hsu Juliana Hsu
ncp 524 tcp NCP Don Provan Don Provan
ncp 524 udp NCP Don Provan Don Provan
timed 525 tcp timeserver
timed 525 udp timeserver
tempo 526 tcp newdate
tempo 526 udp newdate
stx 527 tcp Stock IXChange Ferdi Ladeira Ferdi Ladeira 2022-01-25
stx 527 udp Stock IXChange Ferdi Ladeira Ferdi Ladeira 2022-01-25
custix 528 tcp Customer IXChange Ferdi Ladeira Ferdi Ladeira 2022-01-25
custix 528 udp Customer IXChange Ferdi Ladeira Ferdi Ladeira 2022-01-25
irc-serv 529 tcp IRC-SERV Brian Tackett Brian Tackett
irc-serv 529 udp IRC-SERV Brian Tackett Brian Tackett
devshr-nts 552 tcp DeviceShare Benjamin Rosenberg Benjamin Rosenberg
devshr-nts 552 udp DeviceShare Benjamin Rosenberg Benjamin Rosenberg
xmlrpc-beep 602 tcp XML-RPC over BEEP RFC 3529
xmlrpc-beep 602 udp XML-RPC over BEEP RFC 3529
hello-port 652 tcp HELLO_PORT Patrick Cipiere Patrick Cipiere
hello-port 652 udp HELLO_PORT Patrick Cipiere Patrick Cipiere
qrh 752 tcp
qrh 752 udp
849-852 Unassigned
916-952 Unassigned
ddt 1052 tcp Dynamic DNS Tools Remi Lefebvre Remi Lefebvre
ddt 1052 udp Dynamic DNS Tools Remi Lefebvre Remi Lefebvre
winpoplanmess 1152 tcp Winpopup LAN Messenger Vitali Fomine Vitali Fomine 2005-11
winpoplanmess 1152 udp Winpopup LAN Messenger Vitali Fomine Vitali Fomine 2005-11
bspne-pcc 1252 tcp bspne-pcc
bspne-pcc 1252 udp bspne-pcc
lotusnote 1352 tcp Lotus Note Greg Pflaum Greg Pflaum 1992-07
lotusnote 1352 udp Lotus Note Greg Pflaum Greg Pflaum 1992-07
gtegsc-lm 1452 tcp GTE Government Systems License Man Mike Gregory Mike Gregory
gtegsc-lm 1452 udp GTE Government Systems License Man Mike Gregory Mike Gregory
atm-zip-office 1520 tcp atm zip office Wilson Kwan Wilson Kwan
atm-zip-office 1520 udp atm zip office Wilson Kwan Wilson Kwan
ncube-lm 1521 tcp nCube License Manager Maxine Yuen Maxine Yuen 2022-02-14 Unauthorized Use Known on port 1521
ncube-lm 1521 udp nCube License Manager Maxine Yuen Maxine Yuen 2022-02-14 Unauthorized Use Known on port 1521
ricardo-lm 1522 tcp Ricardo North America License Manager Mike Flemming Mike Flemming
ricardo-lm 1522 udp Ricardo North America License Manager Mike Flemming Mike Flemming
cichild-lm 1523 tcp cichild Andy Burgess Andy Burgess
cichild-lm 1523 udp cichild Andy Burgess Andy Burgess
ingreslock 1524 tcp ingres
ingreslock 1524 udp ingres
orasrv 1525 tcp oracle
orasrv 1525 udp oracle
prospero-np 1525 tcp Prospero Directory Service non-priv
prospero-np 1525 udp Prospero Directory Service non-priv
pdap-np 1526 tcp Prospero Data Access Prot non-priv B. Clifford Neuman B. Clifford Neuman
pdap-np 1526 udp Prospero Data Access Prot non-priv B. Clifford Neuman B. Clifford Neuman
tlisrv 1527 tcp oracle
tlisrv 1527 udp oracle
norp 1528 tcp Not Only a Routeing Protocol nyantec Mikael Voss 2021-04-07
norp 1528 udp Not Only a Routeing Protocol nyantec Mikael Voss 2016-09-13 2021-04-07
norp 1528 sctp Not Only a Routeing Protocol nyantec Mikael Voss 2021-04-07
coauthor 1529 tcp oracle
coauthor 1529 udp oracle
pciarray 1552 tcp pciarray Ron Folk Ron Folk
pciarray 1552 udp pciarray Ron Folk Ron Folk
xnmp 1652 tcp xnmp Ali Saleh Ali Saleh
xnmp 1652 udp xnmp Ali Saleh Ali Saleh
lofr-lm 1752 tcp Leap of Faith Research License Manager
lofr-lm 1752 udp Leap of Faith Research License Manager
virtual-time 1852 tcp Virtual Time Angie S. Morner Angie S. Morner
virtual-time 1852 udp Virtual Time Angie S. Morner Angie S. Morner
mpnjsc 1952 tcp mpnjsc Takenori Miyahara Takenori Miyahara
mpnjsc 1952 udp mpnjsc Takenori Miyahara Takenori Miyahara
clearvisn 2052 tcp clearVisn Services Port Dave Lyons Dave Lyons
clearvisn 2052 udp clearVisn Services Port Dave Lyons Dave Lyons
gtp-user 2152 tcp GTP-User Plane (3GPP) Alessio Casati Alessio Casati
gtp-user 2152 udp GTP-User Plane (3GPP) Alessio Casati Alessio Casati
njenet-ssl 2252 tcp NJENET using SSL Hans U Schmidt Hans U Schmidt
njenet-ssl 2252 udp NJENET using SSL Hans U Schmidt Hans U Schmidt
pslserver 2352 tcp pslserver
pslserver 2352 udp pslserver
snifferclient 2452 tcp SnifferClient Amy Weaver Amy Weaver
snifferclient 2452 udp SnifferClient Amy Weaver Amy Weaver
pvsw 2520 tcp Pervasive Listener Chuck Talk Chuck Talk
pvsw 2520 udp Pervasive Listener Chuck Talk Chuck Talk
adaptecmgr 2521 tcp Adaptec Manager Mark Parenti Mark Parenti
adaptecmgr 2521 udp Adaptec Manager Mark Parenti Mark Parenti
windb 2522 tcp WinDb Larry Traylor Larry Traylor
windb 2522 udp WinDb Larry Traylor Larry Traylor
qke-llc-v3 2523 tcp Qke LLC V.3 Joerg Niehoff Joerg Niehoff

Contact Information

Name Organization Contact URI Last Updated
Alessio Casati a.casati&computer.org
Ali Saleh scomm&cerf.net
Amy Weaver amy_weaver&nai.com
Andy Burgess aab&cichlid.com
Angie S. Morner webmaster&dsbcpas.com
Annette DeSchon DESCHON&isi.edu
B. Clifford Neuman bcn&isi.edu 2022-02-18
Benjamin Rosenberg brosenberg&advsyscon.com
Brian Tackett cym&acrux.net
Chuck Talk ctalk&pervasive.com
Dave Lyons dlyons&dnpg.com
Don Provan donp&sjf.novell.com
Ferdi Ladeira f.lad.mail&gmail.com 2022-01-25
Greg Pflaum iris.com!Greg_Pflaum&uunet.uu.net 1992-07
Hans U Schmidt schmidth&de.ibm.com
Joerg Niehoff joerg.niehoff&alcatel-ke.de
John Kelly johnk&bellhow.com
Juliana Hsu jhsu&ca.ibm.com
Larry Traylor larry&arium.com
Mark Parenti map&ntc.adaptec.com
Max Morris maxm&microsoft.com
Maxine Yuen maxine&hq.ncube.com
Mike Flemming mf&xnet.com
Mike Gregory Gregory_Mike&msmail.iipo.gtegsc.com
Mikael Voss mvs&nyantec.com 2017-04-18
nyantec info&nyantec.com 2017-04-18
Patrick Cipiere Patrick.Cipiere&udcast.com
Remi Lefebvre remi&debian.org
Robert E. Minnear minnear&ipsilon.com
Ron Folk rfolkes&avl.com
Ruediger Wald wald&ez-darmstadt.telekom.de
Susie Armstrong Armstrong.wbst128@xerox
Takenori Miyahara miyahara&pfu.co.jp
Vitali Fomine info&winpopup-lan-messenger.com 2005-11
Walter Poxon wdp&ironwood.cray.com
Wilson Kwan wilsonk%25toronto@zip.atm.com