Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
smtp 25 tcp Simple Mail Transfer IESG IETF Chair 2017-06-05 RFC-ietf-emailcore-rfc5321bis-43
smtp 25 udp Simple Mail Transfer IESG IETF Chair 2017-06-05 RFC-ietf-emailcore-rfc5321bis-43
domain 53 tcp Domain Name Server Paul Mockapetris Paul Mockapetris
domain 53 udp Domain Name Server Paul Mockapetris Paul Mockapetris
sgmp 153 tcp SGMP Marty Schoffstahl Marty Schoffstahl
sgmp 153 udp SGMP Marty Schoffstahl Marty Schoffstahl
ndsauth 353 tcp NDSAUTH Jayakumar Ramalingam Jayakumar Ramalingam
ndsauth 353 udp NDSAUTH Jayakumar Ramalingam Jayakumar Ramalingam
creativeserver 453 tcp CreativeServer
creativeserver 453 udp CreativeServer
courier 530 tcp rpc
courier 530 udp rpc
conference 531 tcp chat
conference 531 udp chat
netnews 532 tcp readnews
netnews 532 udp readnews
netwall 533 tcp for emergency broadcasts Andreas Heidemann Andreas Heidemann
netwall 533 udp for emergency broadcasts Andreas Heidemann Andreas Heidemann
windream 534 tcp windream Admin Uwe Honermann Uwe Honermann
windream 534 udp windream Admin Uwe Honermann Uwe Honermann
iiop 535 tcp iiop Jeff M.Michaud Jeff M.Michaud
iiop 535 udp iiop Jeff M.Michaud Jeff M.Michaud
opalis-rdv 536 tcp opalis-rdv Laurent Domenech Laurent Domenech
opalis-rdv 536 udp opalis-rdv Laurent Domenech Laurent Domenech
nmsp 537 tcp Networked Media Streaming Protocol Paul Santinelli Jr. Paul Santinelli Jr.
nmsp 537 udp Networked Media Streaming Protocol Paul Santinelli Jr. Paul Santinelli Jr.
gdomap 538 tcp gdomap Richard Frith-Macdonald Richard Frith-Macdonald
gdomap 538 udp gdomap Richard Frith-Macdonald Richard Frith-Macdonald
apertus-ldp 539 tcp Apertus Technologies Load Determination
apertus-ldp 539 udp Apertus Technologies Load Determination
pirp 553 tcp pirp D. J. Bernstein D. J. Bernstein
pirp 553 udp pirp D. J. Bernstein D. J. Bernstein
repscmd 653 tcp RepCmd Scott Dale Scott Dale
repscmd 653 udp RepCmd Scott Dale Scott Dale
rrh 753 tcp
rrh 753 udp
domain-s 853 tcp DNS query-response protocol run over TLS IESG IETF Chair 2015-10-08 2022-04-11 RFC 7858
domain-s 853 udp DNS query-response protocol run over DTLS or QUIC IESG IETF Chair 2015-10-08 2022-04-01 RFC 7858; RFC 8094; RFC 9250
twamp-control 862 tcp TWAMP-Control IESG IETF Chair RFC 5357
rndc 953 tcp BIND9 remote name daemon controller Internet Systems Consortium, Inc. Ray Bellis 2017-06-08
953 udp Reserved
remote-as 1053 tcp Remote Assistant (RA) Roman Kriis Roman Kriis Unauthorized Use Known on port 1053
remote-as 1053 udp Remote Assistant (RA) Roman Kriis Roman Kriis
ltp-deepspace 1113 tcp Licklider Transmission Protocol RFC 5326
ltp-deepspace 1113 udp Licklider Transmission Protocol 2014-02-21 RFC 5326; RFC 7122
c1222-acse 1153 tcp ANSI C12.22 Port RFC 6142
c1222-acse 1153 udp ANSI C12.22 Port RFC 6142
q55-pcc 1253 tcp q55-pcc Prem Tirilok Prem Tirilok
q55-pcc 1253 udp q55-pcc Prem Tirilok Prem Tirilok
relief 1353 tcp Relief Consulting John Feiler John Feiler
relief 1353 udp Relief Consulting John Feiler John Feiler
genie-lm 1453 tcp Genie License Manager Paul Applegate Paul Applegate
genie-lm 1453 udp Genie License Manager Paul Applegate Paul Applegate
rap-service 1530 tcp rap-service
rap-service 1530 udp rap-service
rap-listen 1531 tcp rap-listen Phil Servita Phil Servita
rap-listen 1531 udp rap-listen Phil Servita Phil Servita
miroconnect 1532 tcp miroconnect Michael Fischer Michael Fischer
miroconnect 1532 udp miroconnect Michael Fischer Michael Fischer
virtual-places 1533 tcp Virtual Places Software Avshalom Houri Avshalom Houri
virtual-places 1533 udp Virtual Places Software Avshalom Houri Avshalom Houri
micromuse-lm 1534 tcp micromuse-lm Adam Kerrison Adam Kerrison
micromuse-lm 1534 udp micromuse-lm Adam Kerrison Adam Kerrison
ampr-info 1535 tcp ampr-info
ampr-info 1535 udp ampr-info
ampr-inter 1536 tcp ampr-inter Rob Janssen Rob Janssen
ampr-inter 1536 udp ampr-inter Rob Janssen Rob Janssen
sdsc-lm 1537 tcp isi-lm Len Wanger Len Wanger
sdsc-lm 1537 udp isi-lm Len Wanger Len Wanger
3ds-lm 1538 tcp 3ds-lm Keith Trummel Keith Trummel
3ds-lm 1538 udp 3ds-lm Keith Trummel Keith Trummel
intellistor-lm 1539 tcp Intellistor License Manager Ron Vaughn Ron Vaughn
intellistor-lm 1539 udp Intellistor License Manager Ron Vaughn Ron Vaughn
sna-cs 1553 tcp sna-cs Tony Sowter Tony Sowter
sna-cs 1553 udp sna-cs Tony Sowter Tony Sowter
alphatech-lm 1653 tcp alphatech-lm Joseph Hauk Joseph Hauk
alphatech-lm 1653 udp alphatech-lm Joseph Hauk Joseph Hauk
predatar-comms 1753 tcp Predatar Comms Service Silverstring Ltd. Ronnie De Giorgio 2011-09-15
1753 udp Reserved
vids-avtp 1853 tcp VIDS-AVTP Sascha Kuemmel Sascha Kuemmel
vids-avtp 1853 udp VIDS-AVTP Sascha Kuemmel Sascha Kuemmel
rapidbase 1953 tcp Rapid Base Antoni Wolski Antoni Wolski
rapidbase 1953 udp Rapid Base Antoni Wolski Antoni Wolski
lot105-ds-upd 2053 tcp Lot105 DSuper Updates Piers Scannell Piers Scannell
lot105-ds-upd 2053 udp Lot105 DSuper Updates Piers Scannell Piers Scannell
ctlptc 2153 tcp Control Protocol
ctlptc 2153 udp Control Protocol
dtv-chan-req 2253 tcp DTV Channel Request Richard Hodges Richard Hodges
dtv-chan-req 2253 udp DTV Channel Request Richard Hodges Richard Hodges
pspserver 2353 tcp pspserver
pspserver 2353 udp pspserver
madge-ltd 2453 tcp madge ltd Mark Lyall Mark Lyall
madge-ltd 2453 udp madge ltd Mark Lyall Mark Lyall
vrcommerce 2530 tcp VR Commerce Yosi Mass Yosi Mass
vrcommerce 2530 udp VR Commerce Yosi Mass Yosi Mass
ito-e-gui 2531 tcp ITO-E GUI Michael Haeuptle Michael Haeuptle
ito-e-gui 2531 udp ITO-E GUI Michael Haeuptle Michael Haeuptle
ovtopmd 2532 tcp OVTOPMD Eric Pulsipher Eric Pulsipher
ovtopmd 2532 udp OVTOPMD Eric Pulsipher Eric Pulsipher
snifferserver 2533 tcp SnifferServer Amy Weaver Amy Weaver

Contact Information

Name Organization Contact URI Last Updated
Adam Kerrison adam&micromuse.co.uk
Amy Weaver Amy_Weaver&nai.com
Andreas Heidemann a.heidemann&ais-gmbh.de
Antoni Wolski antoni.wolski&vtt.fi
Avshalom Houri Avshalom&ubique.com
D. J. Bernstein ports&box.cr.yp.to 2018-04-05
Eric Pulsipher eric_pulsipher&hp.com
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Internet Systems Consortium, Inc. info&isc.org 2017-06-08
Jayakumar Ramalingam jayakumar&novell.com
Jeff M.Michaud michaud&zk3.dec.com
John Feiler relief!jjfeiler&uu2.psi.com
Joseph Hauk joseph.hauk&alphatech.com
Keith Trummel ktrummel&autodesk.com
Laurent Domenech Opalis ldomenech&opalis.com
Len Wanger lrw&sdsc.edu
Mark Lyall mark.lyall&madge.com
Marty Schoffstahl schoff&nisc.nyser.net
Michael Fischer tel:+49-531-21-13-0
Michael Haeuptle Michael_Haeuptle&hp.com
Paul Applegate p.applegate2&genie.geis.com
Paul Mockapetris PVM&isi.edu
Paul Santinelli Jr. psantinelli&narrative.com
Phil Servita meister&ftp.com
Piers Scannell iana-form&lot105.com
Prem Tirilok Prem.Tirilok&tellabs.com
Ray Bellis ray&isc.org 2017-06-08
Richard Frith-Macdonald richard&brainstorm.co.uk
Richard Hodges rh&matriplex.com
Rob Janssen rob&sys3.pe1chl.ampr.org
Roman Kriis roman&previo.ee
Ron Vaughn rv&intellistor.com
Ronnie De Giorgio Silverstring Ltd. rdegiorgio&silverstring.com 2011-09-15
Sascha Kuemmel kuemmel&vidsoft.de
Scott Dale scott&tioga.com
Silverstring Ltd. rdegiorgio&silverstring.com 2011-09-15
Tony Sowter ts&datcon.co.uk
Uwe Honermann u.honermann&windream.com
Yosi Mass yosimass&haifa.vnet.ibm.com