Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
smtp 25 tcp Simple Mail Transfer IESG IETF Chair 2017-06-05 RFC-ietf-emailcore-rfc5321bis-43
smtp 25 udp Simple Mail Transfer IESG IETF Chair 2017-06-05 RFC-ietf-emailcore-rfc5321bis-43
netnews 532 tcp readnews
netnews 532 udp readnews
ltp-deepspace 1113 tcp Licklider Transmission Protocol RFC 5326
ltp-deepspace 1113 udp Licklider Transmission Protocol 2014-02-21 RFC 5326; RFC 7122
miroconnect 1532 tcp miroconnect Michael Fischer Michael Fischer
miroconnect 1532 udp miroconnect Michael Fischer Michael Fischer
ovtopmd 2532 tcp OVTOPMD Eric Pulsipher Eric Pulsipher
ovtopmd 2532 udp OVTOPMD Eric Pulsipher Eric Pulsipher
raven-rmp 3532 tcp Raven Remote Management Control
raven-rmp 3532 udp Raven Remote Management Control
bsfserver-zn 5320 tcp Webservices-based Zn interface of BSF Bert Paul Bert Paul 2008-05-01
5320 udp Reserved
bsfsvr-zn-ssl 5321 tcp Webservices-based Zn interface of BSF over SSL Bert Paul Bert Paul 2008-07-03
5321 udp Reserved
5322-5342 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Bert Paul bert.paul&apertio.com 2008-07-03
Eric Pulsipher eric_pulsipher&hp.com
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Michael Fischer tel:+49-531-21-13-0