Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-22
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| iiop | 535 | tcp | iiop | Jeff M.Michaud | Jeff M.Michaud | ||||||
| iiop | 535 | udp | iiop | Jeff M.Michaud | Jeff M.Michaud | ||||||
| twamp-control | 862 | tcp | TWAMP-Control | IESG | IETF Chair | RFC 5357 | |||||
| ampr-info | 1535 | tcp | ampr-info | ||||||||
| ampr-info | 1535 | udp | ampr-info | ||||||||
| madcap | 2535 | tcp | MADCAP | Stephen Hanna | Stephen Hanna | ||||||
| madcap | 2535 | udp | MADCAP | Stephen Hanna | Stephen Hanna | ||||||
| ms-la | 3535 | tcp | MS-LA | Eric Ledoux | Eric Ledoux | ||||||
| ms-la | 3535 | udp | MS-LA | Eric Ledoux | Eric Ledoux | ||||||
| gsakmp | 3761 | tcp | gsakmp port | RFC 4535 | |||||||
| gsakmp | 3761 | udp | gsakmp port | RFC 4535 | |||||||
| asap-udp | 3863 | udp | asap udp port | RFC 5352 | |||||||
| asap-sctp | 3863 | sctp | asap sctp | RFC 5352 | |||||||
| asap-tcp-tls | 3864 | tcp | asap/tls tcp port | RFC 5352 | |||||||
| asap-sctp-tls | 3864 | sctp | asap-sctp/tls | RFC 5352 | |||||||
| ehs | 4535 | tcp | Event Heap Server | ||||||||
| ehs | 4535 | udp | Event Heap Server | ||||||||
| dtn-bundle | 4556 | dccp | DTN Bundle DCCP CL Protocol | 2013-11-12 | 2014-02-21 | RFC 7122 | 1685351985 | ||||
| 5350 | tcp | Reserved | |||||||||
| pcp-multicast | 5350 | udp | Port Control Protocol Multicast | IESG | IETF Chair | RFC 6887 | |||||
| 5351 | tcp | Reserved | |||||||||
| pcp | 5351 | udp | Port Control Protocol | IESG | IETF Chair | RFC 6887 | |||||
| dns-llq | 5352 | tcp | DNS Long-Lived Queries | Stuart Cheshire | Stuart Cheshire | 2005-08 | 2019-08-26 | RFC 8764 | |||
| dns-llq | 5352 | udp | DNS Long-Lived Queries | Stuart Cheshire | Stuart Cheshire | 2005-08 | 2019-08-26 | RFC 8764 | |||
| mdns | 5353 | tcp | Multicast DNS | IESG | IETF Chair | RFC 6762 | |||||
| mdns | 5353 | udp | Multicast DNS | IESG | IETF Chair | RFC 6762 | |||||
| mdnsresponder | 5354 | tcp | Multicast DNS Responder IPC | Stuart Cheshire | Stuart Cheshire | 2004-06 | |||||
| mdnsresponder | 5354 | udp | Multicast DNS Responder IPC | Stuart Cheshire | Stuart Cheshire | 2004-06 | |||||
| llmnr | 5355 | tcp | LLMNR | Bernard Aboba | Bernard Aboba | 2004-06 | |||||
| llmnr | 5355 | udp | LLMNR | Bernard Aboba | Bernard Aboba | 2004-06 | |||||
| ms-smlbiz | 5356 | tcp | Microsoft Small Business | Gopikrishna Sandra | Gopikrishna Sandra | 2005-02 | |||||
| ms-smlbiz | 5356 | udp | Microsoft Small Business | Gopikrishna Sandra | Gopikrishna Sandra | 2005-02 | |||||
| wsdapi | 5357 | tcp | Web Services for Devices | Henry Rawas | Henry Rawas | 2005-08 | |||||
| wsdapi | 5357 | udp | Web Services for Devices | Henry Rawas | Henry Rawas | 2005-08 | |||||
| wsdapi-s | 5358 | tcp | WS for Devices Secured | Henry Rawas | Henry Rawas | 2005-08 | |||||
| wsdapi-s | 5358 | udp | WS for Devices Secured | Henry Rawas | Henry Rawas | 2005-08 | |||||
| ms-alerter | 5359 | tcp | Microsoft Alerter | Marc McClure | Marc McClure | 2007-08-07 | |||||
| ms-alerter | 5359 | udp | Microsoft Alerter | Marc McClure | Marc McClure | 2007-08-07 | |||||
| mngsuite | 9535 | tcp | Management Suite Remote Control | Trevor Perkes | Trevor Perkes | 2010-02-01 | |||||
| mngsuite | 9535 | udp | Management Suite Remote Control | Trevor Perkes | Trevor Perkes | 2010-02-01 | |||||
| enrp-sctp | 9901 | sctp | enrp server channel | RFC 5353 | |||||||
| enrp-sctp-tls | 9902 | sctp | enrp/tls server channel | RFC 5353 | |||||||
| 35101-35353 | Unassigned | ||||||||||
| kitim | 35354 | tcp | KIT Messenger | Rudi Visser | Rudi Visser | 2011-07-07 | |||||
| 35354 | udp | Reserved | |||||||||
| altova-lm | 35355 | tcp | Altova License Management | Alexander Falk | Alexander Falk | 2011-07-07 | |||||
| altova-lm-disc | 35355 | udp | Altova License Management Discovery | Alexander Falk | Alexander Falk | 2011-07-07 | |||||
| guttersnex | 35356 | tcp | Gutters Note Exchange | Squee! Application Development | Tristan Seifert | 2011-07-19 | |||||
| 35356 | udp | Reserved | |||||||||
| openstack-id | 35357 | tcp | OpenStack ID Service | Rackspace Hosting | Ziad Sawalha | 2011-08-15 | |||||
| 35357 | udp | Reserved | |||||||||
| 35358-36000 | Unassigned | ||||||||||
| 44323 | udp | Unassigned | "pcp" assignment withdrawn, moved to port 5351 per RFC 6887 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Alexander Falk | Altova, Inc. | al&altova.com | 2011-07-07 |
| Bernard Aboba | bernardaµsoft.com | 2004-06 | |
| Eric Ledoux | ericleµsoft.com | ||
| Gopikrishna Sandra | v-gosandµsoft.com | 2005-02 | |
| Henry Rawas | henryrµsoft.com | 2005-08 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Jeff M.Michaud | michaud&zk3.dec.com | ||
| Marc McClure | marcmccµsoft.com | 2007-08-07 | |
| Rackspace Hosting | ziad.sawalha&rackspace.com | 2011-08-15 | |
| Rudi Visser | rudi.visser&ljund.eu | 2011-07-07 | |
| Squee! Application Development | tristan&squee.co | 2011-07-19 | |
| Stephen Hanna | steve.hanna&sun.com | ||
| Stuart Cheshire | cheshire&apple.com | 2022-07-11 | |
| Stuart Cheshire | mdnsresponder-ipc&multicastdns.org | 2004-06 | |
| Trevor Perkes | trevor.perkes&landesk.com | 2010-02-01 | |
| Tristan Seifert | Squee! Application Development | tristan&squee.co | 2011-07-19 |
| Ziad Sawalha | Rackspace Hosting | ziad.sawalha&rackspace.com | 2011-08-15 |