Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
syslog 514 udp 2020-06-01 RFC 5426
commerce 542 tcp commerce Randy Epstein Randy Epstein
commerce 542 udp commerce Randy Epstein Randy Epstein
gridgen-elmd 1542 tcp gridgen-elmd John R. Chawner John R. Chawner
gridgen-elmd 1542 udp gridgen-elmd John R. Chawner John R. Chawner
udrawgraph 2542 tcp uDraw(Graph) University of Bremen, FB3 University of Bremen, FB3
udrawgraph 2542 udp uDraw(Graph) University of Bremen, FB3 University of Bremen, FB3
hacl-monitor 3542 tcp HA cluster monitor Jason Ko Jason Ko 2002-07
hacl-monitor 3542 udp HA cluster monitor Jason Ko Jason Ko 2002-07
cylink-c 5420 tcp Cylink-C John Jobe John Jobe
cylink-c 5420 udp Cylink-C John Jobe John Jobe
netsupport2 5421 tcp Net Support 2 Paul Sanders Paul Sanders
netsupport2 5421 udp Net Support 2 Paul Sanders Paul Sanders
salient-mux 5422 tcp Salient MUX Richard Farnham Richard Farnham
salient-mux 5422 udp Salient MUX Richard Farnham Richard Farnham
virtualuser 5423 tcp VIRTUALUSER Chad Williams Chad Williams
virtualuser 5423 udp VIRTUALUSER Chad Williams Chad Williams
beyond-remote 5424 tcp Beyond Remote Michael Berg Michael Berg 2004-11
beyond-remote 5424 udp Beyond Remote Michael Berg Michael Berg 2004-11
br-channel 5425 tcp Beyond Remote Command Channel Michael Berg Michael Berg 2005-08
br-channel 5425 udp Beyond Remote Command Channel Michael Berg Michael Berg 2005-08
devbasic 5426 tcp DEVBASIC Curtis Smith Curtis Smith
devbasic 5426 udp DEVBASIC Curtis Smith Curtis Smith
sco-peer-tta 5427 tcp SCO-PEER-TTA Andrew Shire Andrew Shire
sco-peer-tta 5427 udp SCO-PEER-TTA Andrew Shire Andrew Shire
telaconsole 5428 tcp TELACONSOLE Joseph M. Newcomer Joseph M. Newcomer
telaconsole 5428 udp TELACONSOLE Joseph M. Newcomer Joseph M. Newcomer
base 5429 tcp Billing and Accounting System Exchange Odo Maletzki Odo Maletzki
base 5429 udp Billing and Accounting System Exchange Odo Maletzki Odo Maletzki
5541-5542 Unassigned
syslog-tls 6514 tcp Syslog over TLS RFC 5425
6516-6542 Unassigned
saratoga 7542 tcp Saratoga Transfer Protocol Lloyd Wood Lloyd Wood 2007-05
saratoga 7542 udp Saratoga Transfer Protocol Lloyd Wood Lloyd Wood 2007-05
MOS-aux 10542 tcp MOS Low Priority Port Eric Thorniley Eric Thorniley 2007-09-17
MOS-aux 10542 udp MOS Low Priority Port Eric Thorniley Eric Thorniley 2007-09-17
19542-19787 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Andrew Shire sndrewsh&sco.com
University of Bremen, FB3 udrawgraph&informatik.uni-bremen.de
Chad Williams chad&apple.com
Curtis Smith curtis.smith&vsin.com
Eric Thorniley eric&etcomms.co.uk 2007-09-17
Jason Ko jason_ko&hp.com 2002-07
John Jobe jjobe&cylink.com
John R. Chawner tel:+1-817-354-1004
Joseph M. Newcomer newcomer&flounder.com
Lloyd Wood lwood&cisco.com 2007-05
Michael Berg mike&dataapples.com 2005-08
Odo Maletzki Odo.Maletzki&ioag.de
Paul Sanders p.sanders&dial.pipex.com
Randy Epstein randy&epstein.com 2023-10-18
Richard Farnham rfarnham&salient.com