Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
kshell 544 tcp krcmd
kshell 544 udp krcmd
aspeclmd 1544 tcp aspeclmd V. Balaji V. Balaji
aspeclmd 1544 udp aspeclmd V. Balaji V. Balaji
novell-zen 2544 tcp Management Daemon Refresh Ty Ellis Ty Ellis
novell-zen 2544 udp Management Daemon Refresh Ty Ellis Ty Ellis
teredo 3544 tcp Teredo Port RFC 4380
teredo 3544 udp Teredo Port RFC 4380
4189 udp Reserved RFC 5440
4539-4544 Unassigned
5438-5442 Unassigned
spss 5443 tcp Pearson HTTPS Pearson Pearson 2008-01-17
spss 5443 udp Pearson HTTPS Pearson Pearson 2008-01-17
5444 Unassigned Known UNAUTHORIZED USE: Port 5444
smbdirect 5445 tcp Server Message Block over Remote Direct Memory Access Microsoft Corporation Tom Talpey 2012-03-15
5445 udp Reserved
smbdirect 5445 sctp Server Message Block over Remote Direct Memory Access Microsoft Corporation Tom Talpey 2012-03-15
5446-5449 Unassigned
5544-5549 Unassigned
lds-dump 6544 tcp LDS Dump Service Jack Baker Jack Baker 2006-02
lds-dump 6544 udp LDS Dump Service Jack Baker Jack Baker 2006-02
nta-ds 7544 tcp FlowAnalyzer DisplayServer Fred Messinger Fred Messinger
nta-ds 7544 udp FlowAnalyzer DisplayServer Fred Messinger Fred Messinger
MOS-soap-opt 10544 tcp MOS SOAP Optional Port Eric Thorniley Eric Thorniley 2007-09-17
MOS-soap-opt 10544 udp MOS SOAP Optional Port Eric Thorniley Eric Thorniley 2007-09-17
44544 tcp Reserved
domiq 44544 udp DOMIQ Building Automation DOMIQ Sp. z o.o. Filip Zawadiak 2011-08-29

Contact Information

Name Organization Contact URI Last Updated
DOMIQ Sp. z o.o. registries&domiq.pl 2011-08-29
Eric Thorniley eric&etcomms.co.uk 2007-09-17
Filip Zawadiak DOMIQ Sp. z o.o. fzawadiak&domiq.pl 2011-08-29
Fred Messinger fredm&cisco.com
Jack Baker Jack.Baker&l-3com.com 2006-02
Microsoft Corporation stdsreq&microsoft.com 2012-03-15
Pearson chad.smith&pearson.com 2008-01-17
Tom Talpey Microsoft Corporation ttalpey&microsoft.com 2012-03-15
Ty Ellis tellis&novell.com 2006-05
V. Balaji balaji&aspec.com