Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
dhcpv6-server 547 tcp DHCPv6 Server IESG IETF Chair 2018-05-21 RFC 5460
dhcpv6-server 547 udp DHCPv6 Server IESG IETF Chair 2018-05-21 RFC 9915
gdoi 848 tcp GDOI RFC 3547
gdoi 848 udp GDOI RFC 3547
laplink 1547 tcp laplink Michael Crawford Michael Crawford
laplink 1547 udp laplink Michael Crawford Michael Crawford
vytalvaultvsmp 2547 tcp vytalvaultvsmp
vytalvaultvsmp 2547 udp vytalvaultvsmp
symantec-sim 3547 tcp Symantec SIM George Dzieciol George Dzieciol 2002-07
symantec-sim 3547 udp Symantec SIM George Dzieciol George Dzieciol 2002-07
lanner-lm 4547 tcp Lanner License Manager Les Enstone Les Enstone
lanner-lm 4547 udp Lanner License Manager Les Enstone Les Enstone
apsolab-col 5470 tcp The Apsolab company's data collection protocol (native api) Apsolab Inc. Jean-Francois Gauthier 2014-11-10
5470 udp Reserved
apsolab-cols 5471 tcp The Apsolab company's secure data collection protocol (native api) Apsolab Inc. Jean-Francois Gauthier 2014-11-10
5471 udp Reserved
apsolab-tag 5472 tcp The Apsolab company's dynamic tag protocol Apsolab Inc. Jean-Francois Gauthier 2014-11-10
5472 udp Reserved
apsolab-tags 5473 tcp The Apsolab company's secure dynamic tag protocol Apsolab Inc. Jean-Francois Gauthier 2014-11-10
5473 udp Reserved
apsolab-rpc 5474 udp The Apsolab company's status query protocol Apsolab Inc. Jean-Francois Gauthier 2014-11-10
5474 tcp Reserved
apsolab-data 5475 tcp The Apsolab company's data retrieval protocol Apsolab Inc. Jean-Francois Gauthier 2014-11-10
5475 udp Reserved
5476-5499 Unassigned
apc-6547 6547 tcp APC 6547 American Power Conversion American Power Conversion
apc-6547 6547 udp APC 6547 American Power Conversion American Power Conversion
cwmp 7547 tcp Broadband Forum CWMP Broadband Forum Broadband Forum 2006-01 2019-12-13
cwmp 7547 udp Broadband Forum CWMP Broadband Forum Broadband Forum 2006-01 2019-12-13
10545-10547 Unassigned
12547-12752 Unassigned
23547-23999 Unassigned
25101-25470 Unassigned
rna 25471 sctp RNSAP User Adaptation for Iurh Dario S. Tonesi Dario S. Tonesi 2011-02-07
25472-25575 Unassigned

Contact Information

Name Organization Contact URI Last Updated
American Power Conversion ports&apcc.com 2002-02
Apsolab Inc. admin&apsolab.com 2014-11-10
Broadband Forum help&broadband-forum.org 2020-03-17
Dario S. Tonesi dario.tonesi&nsn.com 2011-02-07
George Dzieciol gdzieciol&symantec.com 2002-07
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jean-Francois Gauthier Apsolab Inc. jfgauthier&apsolab.com 2014-11-10
Les Enstone lenstone&lanner.co.uk
Michael Crawford MichaelC&dev.travsoft.com