Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
isi-gl 55 tcp ISI Graphics Language
isi-gl 55 udp ISI Graphics Language
netsc-dev 155 tcp NETSC Sergio Heker Sergio Heker
netsc-dev 155 udp NETSC Sergio Heker Sergio Heker
249-255 Reserved 2024-12-20 RFC 1060
datex-asn 355 tcp DATEX-ASN Kenneth Vaughn Kenneth Vaughn
datex-asn 355 udp DATEX-ASN Kenneth Vaughn Kenneth Vaughn
creativepartnr 455 tcp CreativePartnr Jesus Ortiz Jesus Ortiz
creativepartnr 455 udp CreativePartnr Jesus Ortiz Jesus Ortiz
new-rwho 550 tcp new-who n/a
new-rwho 550 udp new-who n/a
cybercash 551 tcp cybercash Donald E. Eastlake 3rd Donald E. Eastlake 3rd RFC 1898
cybercash 551 udp cybercash Donald E. Eastlake 3rd Donald E. Eastlake 3rd RFC 1898
devshr-nts 552 tcp DeviceShare Benjamin Rosenberg Benjamin Rosenberg
devshr-nts 552 udp DeviceShare Benjamin Rosenberg Benjamin Rosenberg
pirp 553 tcp pirp D. J. Bernstein D. J. Bernstein
pirp 553 udp pirp D. J. Bernstein D. J. Bernstein
rtsp 554 tcp Real Time Streaming Protocol (RTSP) Rob Lanphier Rob Lanphier
rtsp 554 udp Real Time Streaming Protocol (RTSP) Rob Lanphier Rob Lanphier
dsf 555 tcp
dsf 555 udp
remotefs 556 tcp rfs server
remotefs 556 udp rfs server
openvms-sysipc 557 tcp openvms-sysipc Alan Potter Alan Potter
openvms-sysipc 557 udp openvms-sysipc Alan Potter Alan Potter
sdnskmp 558 tcp SDNSKMP
sdnskmp 558 udp SDNSKMP
teedtap 559 tcp TEEDTAP Charlie Limoges Charlie Limoges
teedtap 559 udp TEEDTAP Charlie Limoges Charlie Limoges
tinc 655 tcp TINC Ivo Timmermans Ivo Timmermans
tinc 655 udp TINC Ivo Timmermans Ivo Timmermans
755-757 Unassigned
855-859 Unassigned
ansyslmd 1055 tcp ANSYS - License Manager Suzanne Lorrin Suzanne Lorrin
ansyslmd 1055 udp ANSYS - License Manager Suzanne Lorrin Suzanne Lorrin
nfa 1155 tcp Network File Access James Powell James Powell
nfa 1155 udp Network File Access James Powell James Powell
q55-pcc 1253 tcp q55-pcc Prem Tirilok Prem Tirilok
q55-pcc 1253 udp q55-pcc Prem Tirilok Prem Tirilok
de-cache-query 1255 tcp de-cache-query
de-cache-query 1255 udp de-cache-query
intuitive-edge 1355 tcp Intuitive Edge Montgomery Zukowski Montgomery Zukowski
intuitive-edge 1355 udp Intuitive Edge Montgomery Zukowski Montgomery Zukowski
esl-lm 1455 tcp ESL License Manager Abel Chou Abel Chou
esl-lm 1455 udp ESL License Manager Abel Chou Abel Chou
3m-image-lm 1550 tcp Image Storage license manager 3M Company J. C. Canessa J. C. Canessa
3m-image-lm 1550 udp Image Storage license manager 3M Company J. C. Canessa J. C. Canessa
hecmtl-db 1551 tcp HECMTL-DB Maxime Belanger Maxime Belanger
hecmtl-db 1551 udp HECMTL-DB Maxime Belanger Maxime Belanger
pciarray 1552 tcp pciarray Ron Folk Ron Folk
pciarray 1552 udp pciarray Ron Folk Ron Folk
sna-cs 1553 tcp sna-cs Tony Sowter Tony Sowter
sna-cs 1553 udp sna-cs Tony Sowter Tony Sowter
caci-lm 1554 tcp CACI Products Company License Manager Erik Blume Erik Blume
caci-lm 1554 udp CACI Products Company License Manager Erik Blume Erik Blume
livelan 1555 tcp livelan Kaynam Hedayat Kaynam Hedayat
livelan 1555 udp livelan Kaynam Hedayat Kaynam Hedayat
veritas-pbx 1556 tcp VERITAS Private Branch Exchange

IANA assigned this well-formed service name as a replacement for "veritas_pbx".
Stefan Winkel Stefan Winkel 2004-04
veritas_pbx 1556 tcp VERITAS Private Branch Exchange Stefan Winkel Stefan Winkel 2004-04 This entry is an alias to "veritas-pbx". This entry is now historic, not usable for use with many common service discovery mechanisms.
veritas-pbx 1556 udp VERITAS Private Branch Exchange

IANA assigned this well-formed service name as a replacement for "veritas_pbx".
Stefan Winkel Stefan Winkel 2004-04
veritas_pbx 1556 udp VERITAS Private Branch Exchange Stefan Winkel Stefan Winkel 2004-04 This entry is an alias to "veritas-pbx". This entry is now historic, not usable for use with many common service discovery mechanisms.
arbortext-lm 1557 tcp ArborText License Manager David J. Wilson David J. Wilson
arbortext-lm 1557 udp ArborText License Manager David J. Wilson David J. Wilson
xingmpeg 1558 tcp xingmpeg Howard Gordon Howard Gordon
xingmpeg 1558 udp xingmpeg Howard Gordon Howard Gordon
web2host 1559 tcp web2host Stephen Johnson Stephen Johnson
web2host 1559 udp web2host Stephen Johnson Stephen Johnson
dec-mbadmin 1655 tcp dec-mbadmin
dec-mbadmin 1655 udp dec-mbadmin
ms-streaming 1755 tcp ms-streaming Bret O'Rourke Bret O'Rourke
ms-streaming 1755 udp ms-streaming Bret O'Rourke Bret O'Rourke
fiorano-rtrsvc 1855 tcp Fiorano RtrSvc
fiorano-rtrsvc 1855 udp Fiorano RtrSvc
abr-secure 1955 tcp ABR-Secure Data (diskbridge) Graham Wooden Graham Wooden
abr-secure 1955 udp ABR-Secure Data (diskbridge) Graham Wooden Graham Wooden
iop 2055 tcp Iliad-Odyssey Protocol Bruce Lueckenhoff Bruce Lueckenhoff
iop 2055 udp Iliad-Odyssey Protocol Bruce Lueckenhoff Bruce Lueckenhoff
brdptc 2155 tcp Bridge Protocol Hideki Hatta Hideki Hatta 2007-09-27
brdptc 2155 udp Bridge Protocol Hideki Hatta Hideki Hatta 2007-09-27
vrtp 2255 tcp VRTP - ViRtue Transfer Protocol Max Fudim Max Fudim
vrtp 2255 udp VRTP - ViRtue Transfer Protocol Max Fudim Max Fudim
psdbserver 2355 tcp psdbserver Paul Reddy Paul Reddy
psdbserver 2355 udp psdbserver Paul Reddy Paul Reddy
wago-io-system 2455 tcp WAGO-IO-SYSTEM Jörg Hoffmann Jörg Hoffmann
wago-io-system 2455 udp WAGO-IO-SYSTEM Jörg Hoffmann Jörg Hoffmann
ads 2550 tcp ADS Michael O'Connor Michael O'Connor
ads 2550 udp ADS Michael O'Connor Michael O'Connor
isg-uda-server 2551 tcp ISG UDA Server Dror Harari Dror Harari
isg-uda-server 2551 udp ISG UDA Server Dror Harari Dror Harari
call-logging 2552 tcp Call Logging Dean Webb Dean Webb
call-logging 2552 udp Call Logging Dean Webb Dean Webb
efidiningport 2553 tcp efidiningport Lynn Carter Lynn Carter
efidiningport 2553 udp efidiningport Lynn Carter Lynn Carter
vcnet-link-v10 2554 tcp VCnet-Link v10 Csaba Mate Csaba Mate
vcnet-link-v10 2554 udp VCnet-Link v10 Csaba Mate Csaba Mate
compaq-wcp 2555 tcp Compaq WCP Ferruccio Barletta Ferruccio Barletta
compaq-wcp 2555 udp Compaq WCP Ferruccio Barletta Ferruccio Barletta
nicetec-nmsvc 2556 tcp nicetec-nmsvc
nicetec-nmsvc 2556 udp nicetec-nmsvc
nicetec-mgmt 2557 tcp nicetec-mgmt Joerg Paulus Joerg Paulus

Contact Information

Name Contact URI Last Updated
Abel Chou abel&willy.esl.com
Alan Potter potter&movies.enet.dec.com
Benjamin Rosenberg brosenberg&advsyscon.com
Bret O'Rourke bretor&microsoft.com
Bruce Lueckenhoff brucelu&cisco.com
Charlie Limoges Charlie.Limoges&gdc4s.com
Csaba Mate mc36&freemail.c3.hu
D. J. Bernstein ports&box.cr.yp.to 2018-04-05
David J. Wilson djw&arbortext.com
Dean Webb dean.webb&ascend.com
Donald E. Eastlake 3rd d3e3e3&gmail.com
Dror Harari Dror.Harari&isgsoft.com
Erik Blume erikb&caciasl.com
Ferruccio Barletta ferruccio.barletta&compaq.com
Graham Wooden graham&g-rock.net
Hideki Hatta ponum&canon-is.co.jp 2007-09-27
Howard Gordon hgordon&system.xingtech.com
Ivo Timmermans itimmermans&bigfoot.com
J. C. Canessa jccanessa&mmm.com
James Powell james&mailhost.unidata.com
Jesus Ortiz jesus_ortiz&emotion.com
Joerg Paulus tech&nicetec.de
Jörg Hoffmann electronicc_rd&wago.com
Kaynam Hedayat khedayat&roadrunner.pictel.com
Kenneth Vaughn kvaughn&mail.viggen.com
Lynn Carter carterl&execpc.com
Max Fudim fudim&virtue3d.com
Maxime Belanger R173&hec.ca
Michael O'Connor moconnor&adobe.com
Montgomery Zukowski monty&nextnorth.acs.ohio-state.edu
Paul Reddy preddy&pharos.com
Prem Tirilok Prem.Tirilok&tellabs.com
Rob Lanphier robla&prognet.com
Ron Folk rfolkes&avl.com
Sergio Heker heker&jvncc.csc.org
Stefan Winkel stefan&veritas.com 2004-04
Stephen Johnson sjohnson&mindspring.com
Suzanne Lorrin suzanne.lorrin&ansys.com
Tony Sowter ts&datcon.co.uk