Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
remotefs 556 tcp rfs server
remotefs 556 udp rfs server
veritas-pbx 1556 tcp VERITAS Private Branch Exchange

IANA assigned this well-formed service name as a replacement for "veritas_pbx".
Stefan Winkel Stefan Winkel 2004-04
veritas_pbx 1556 tcp VERITAS Private Branch Exchange Stefan Winkel Stefan Winkel 2004-04 This entry is an alias to "veritas-pbx". This entry is now historic, not usable for use with many common service discovery mechanisms.
veritas-pbx 1556 udp VERITAS Private Branch Exchange

IANA assigned this well-formed service name as a replacement for "veritas_pbx".
Stefan Winkel Stefan Winkel 2004-04
veritas_pbx 1556 udp VERITAS Private Branch Exchange Stefan Winkel Stefan Winkel 2004-04 This entry is an alias to "veritas-pbx". This entry is now historic, not usable for use with many common service discovery mechanisms.
nicetec-nmsvc 2556 tcp nicetec-nmsvc
nicetec-nmsvc 2556 udp nicetec-nmsvc
sky-transport 3556 tcp Sky Transport Protocol Michael Paddon Michael Paddon 2002-07
sky-transport 3556 udp Sky Transport Protocol Michael Paddon Michael Paddon 2002-07
dtn-bundle 4556 tcp DTN Bundle TCP CL Protocol IESG IETF Chair 2021-02-22 RFC 9174
dtn-bundle 4556 udp DTN Bundle UDP CL Protocol 2006-11 2014-02-21 RFC 7122
dtn-bundle 4556 dccp DTN Bundle DCCP CL Protocol 2013-11-12 2014-02-21 RFC 7122 1685351985
freeciv 5556 tcp Freeciv gameplay Reinier Post and Paul Zastoupil Reinier Post and Paul Zastoupil 2006-01 Known Unauthorized Use on port 5556
freeciv 5556 udp Freeciv gameplay Reinier Post and Paul Zastoupil Reinier Post and Paul Zastoupil 2006-01 Known Unauthorized Use on port 5556
5558-5564 Unassigned
dp-bura 5565 tcp Data Protector BURA Micro Focus Shishir Misra 2016-01-13 2019-10-04
5565 udp Reserved
westec-connect 5566 tcp Westec Connect Jon Bolen Jon Bolen 2009-03-18
5566 udp Reserved
dof-dps-mc-sec 5567 tcp DOF Protocol Stack Multicast/Secure Transport OpenDOF Bryant Eastham 2004-11 2015-04-23
dof-dps-mc-sec 5567 udp DOF Protocol Stack Multicast/Secure Transport OpenDOF Bryant Eastham 2004-11 2015-04-23
sdt 5568 tcp Session Data Transport Multicast Daniel W. Antonuk Daniel W. Antonuk 2006-05
sdt 5568 udp Session Data Transport Multicast Daniel W. Antonuk Daniel W. Antonuk 2006-05
rdmnet-ctrl 5569 tcp PLASA E1.33, Remote Device Management (RDM) controller status notifications PLASA Simon Newton 2012-06-01
rdmnet-device 5569 udp PLASA E1.33, Remote Device Management (RDM) messages PLASA Simon Newton 2012-06-01
checkmk-agent 6556 tcp Checkmk Monitoring Agent Checkmk GmbH Alexander Wilms 2020-07-14 2024-08-06
6556 udp Reserved
8556-8566 Unassigned
9556-9558 Unassigned
15556-15659 Unassigned
17556-17728 Unassigned
22556-22762 Unassigned
47101-47556 Unassigned
com-bardac-dw 48556 tcp com-bardac-dw Nicholas J Howes Nicholas J Howes
com-bardac-dw 48556 udp com-bardac-dw Nicholas J Howes Nicholas J Howes

Contact Information

Name Organization Contact URI Last Updated
Alexander Wilms Checkmk GmbH alex.wilms&checkmk.com 2024-08-06
Bryant Eastham OenDOF protocol&opendof.org 2015-04-23
Checkmk GmbH alex.wilms&checkmk.com 2024-08-06
Daniel W. Antonuk dantonuk&etcconnect.com 2006-05
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jon Bolen jon.bolen&westec.net 2009-03-18
Michael Paddon michael.paddon&activesky.com 2002-07
Micro Focus swpdl.dp.rd&microfocus.com 2019-09-30
Nicholas J Howes nick&ghostwood.org
OpenDOF protocol&opendof.org 2015-04-23
PLASA standards.na&plasa.org 2012-06-01
Reinier Post and Paul Zastoupil freeciv&freeciv.org 2006-01
Shishir Misra shishir.misra&microfocus.com 2019-09-30
Simon Newton simon&nomis52.net 2012-06-01
Stefan Winkel stefan&veritas.com 2004-04