Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-13

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
discard 9 dccp Discard Eddie Kohler Eddie Kohler RFC 4340 1145656131
xns-auth 56 tcp XNS Authentication Susie Armstrong Susie Armstrong
xns-auth 56 udp XNS Authentication Susie Armstrong Susie Armstrong
sqlsrv 156 tcp SQL Service Craig Rogers Craig Rogers
sqlsrv 156 udp SQL Service Craig Rogers Craig Rogers
rap 256 tcp RAP J. S. Greenfield J. S. Greenfield
rap 256 udp RAP J. S. Greenfield J. S. Greenfield
cloanto-net-1 356 tcp Cloanto Net 1 Michael Battilana Michael Battilana 2010-04-30
cloanto-net-1 356 udp Cloanto Net 1 Michael Battilana Michael Battilana 2010-04-30
snpp 444 tcp Simple Network Paging Protocol RFC 1568
snpp 444 udp Simple Network Paging Protocol RFC 1568
macon-tcp 456 tcp macon-tcp Yoshinobu Inoue Yoshinobu Inoue
macon-udp 456 udp macon-udp Yoshinobu Inoue Yoshinobu Inoue
remotefs 556 tcp rfs server
remotefs 556 udp rfs server
rmonitor 560 tcp rmonitord
rmonitor 560 udp rmonitord
monitor 561 tcp
monitor 561 udp
chshell 562 tcp chcmd
chshell 562 udp chcmd
nntps 563 tcp nntp protocol over TLS/SSL (was snntp) IESG IETF Chair 2018-07-06 RFC 4642
nntps 563 udp nntp protocol over TLS/SSL (was snntp) IESG IETF Chair 2018-07-06 RFC 4642
9pfs 564 tcp plan 9 file service
9pfs 564 udp plan 9 file service
whoami 565 tcp whoami
whoami 565 udp whoami
streettalk 566 tcp streettalk
streettalk 566 udp streettalk
banyan-rpc 567 tcp banyan-rpc Tom Lemaire Tom Lemaire
banyan-rpc 567 udp banyan-rpc Tom Lemaire Tom Lemaire
ms-shuttle 568 tcp microsoft shuttle Rudolph Balaz Rudolph Balaz
ms-shuttle 568 udp microsoft shuttle Rudolph Balaz Rudolph Balaz
ms-rome 569 tcp microsoft rome Rudolph Balaz Rudolph Balaz
ms-rome 569 udp microsoft rome Rudolph Balaz Rudolph Balaz
dhcp-failover 647 tcp DHCP Failover IESG IETF Chair 2018-05-21 RFC 8156
spmp 656 tcp SPMP Jakob Kaivo Jakob Kaivo
spmp 656 udp SPMP Jakob Kaivo Jakob Kaivo
owamp-control 861 tcp OWAMP-Control IESG IETF Chair RFC 4656
vfo 1056 tcp VFO Anthony Gonzalez Anthony Gonzalez
vfo 1056 udp VFO Anthony Gonzalez Anthony Gonzalez
iascontrol-oms 1156 tcp iasControl OMS Todd Guay Todd Guay 2004-11
iascontrol-oms 1156 udp iasControl OMS Todd Guay Todd Guay 2004-11
de-server 1256 tcp de-server Jeff Burdette Jeff Burdette
de-server 1256 udp de-server Jeff Burdette Jeff Burdette
cuillamartin 1356 tcp CuillaMartin Company
cuillamartin 1356 udp CuillaMartin Company
dca 1456 tcp DCA Jeff Garbers Jeff Garbers
dca 1456 udp DCA Jeff Garbers Jeff Garbers
veritas-pbx 1556 tcp VERITAS Private Branch Exchange

IANA assigned this well-formed service name as a replacement for "veritas_pbx".
Stefan Winkel Stefan Winkel 2004-04
veritas_pbx 1556 tcp VERITAS Private Branch Exchange Stefan Winkel Stefan Winkel 2004-04 This entry is an alias to "veritas-pbx". This entry is now historic, not usable for use with many common service discovery mechanisms.
veritas-pbx 1556 udp VERITAS Private Branch Exchange

IANA assigned this well-formed service name as a replacement for "veritas_pbx".
Stefan Winkel Stefan Winkel 2004-04
veritas_pbx 1556 udp VERITAS Private Branch Exchange Stefan Winkel Stefan Winkel 2004-04 This entry is an alias to "veritas-pbx". This entry is now historic, not usable for use with many common service discovery mechanisms.
asci-val 1560 tcp ASCI-RemoteSHADOW Benjamin Rosenberg Benjamin Rosenberg
asci-val 1560 udp ASCI-RemoteSHADOW Benjamin Rosenberg Benjamin Rosenberg
facilityview 1561 tcp facilityview Ed Green Ed Green
facilityview 1561 udp facilityview Ed Green Ed Green
pconnectmgr 1562 tcp pconnectmgr Bob Kaiser Bob Kaiser
pconnectmgr 1562 udp pconnectmgr Bob Kaiser Bob Kaiser
cadabra-lm 1563 tcp Cadabra License Manager Arthur Castonguay Arthur Castonguay
cadabra-lm 1563 udp Cadabra License Manager Arthur Castonguay Arthur Castonguay
pay-per-view 1564 tcp Pay-Per-View Brian Tung Brian Tung
pay-per-view 1564 udp Pay-Per-View Brian Tung Brian Tung
winddlb 1565 tcp WinDD Kelly Sims Kelly Sims
winddlb 1565 udp WinDD Kelly Sims Kelly Sims
corelvideo 1566 tcp CORELVIDEO Ming Poon Ming Poon
corelvideo 1566 udp CORELVIDEO Ming Poon Ming Poon
jlicelmd 1567 tcp jlicelmd Christian Schormann Christian Schormann
jlicelmd 1567 udp jlicelmd Christian Schormann Christian Schormann
tsspmap 1568 tcp tsspmap Paul W. Nelson Paul W. Nelson
tsspmap 1568 udp tsspmap Paul W. Nelson Paul W. Nelson
ets 1569 tcp ets Carstein Seeberg Carstein Seeberg
ets 1569 udp ets Carstein Seeberg Carstein Seeberg
dec-mbadmin-h 1656 tcp dec-mbadmin-h Nick Shipman Nick Shipman
dec-mbadmin-h 1656 udp dec-mbadmin-h Nick Shipman Nick Shipman
capfast-lmd 1756 tcp capfast-lmd Chuck Neal Chuck Neal
capfast-lmd 1756 udp capfast-lmd Chuck Neal Chuck Neal
fiorano-msgsvc 1856 tcp Fiorano MsgSvc Albert Holt Albert Holt
fiorano-msgsvc 1856 udp Fiorano MsgSvc Albert Holt Albert Holt
vrtl-vmf-ds 1956 tcp Vertel VMF DS Alan Akahoshi Alan Akahoshi
vrtl-vmf-ds 1956 udp Vertel VMF DS Alan Akahoshi Alan Akahoshi
nfs 2049 sctp Network File System RFC 5665 Defined TXT keys: path=<path to mount point>
omnisky 2056 tcp OmniSky Port Oren Hurvitz Oren Hurvitz
omnisky 2056 udp OmniSky Port Oren Hurvitz Oren Hurvitz
trp 2156 tcp Talari Reliable Protocol John E. Dickey John E. Dickey 2007-09-27
trp 2156 udp Talari Reliable Protocol John E. Dickey John E. Dickey 2007-09-27
pcc-mfp 2256 tcp PCC MFP Kunihiko Morota Kunihiko Morota 2005-08
pcc-mfp 2256 udp PCC MFP Kunihiko Morota Kunihiko Morota 2005-08
gxtelmd 2356 tcp GXT License Managemant Robert Hodgson Robert Hodgson
gxtelmd 2356 udp GXT License Managemant Robert Hodgson Robert Hodgson
altav-remmgt 2456 tcp altav-remmgt Gary M. Allen Gary M. Allen
altav-remmgt 2456 udp altav-remmgt Gary M. Allen Gary M. Allen
nicetec-nmsvc 2556 tcp nicetec-nmsvc
nicetec-nmsvc 2556 udp nicetec-nmsvc
labrat 2560 tcp labrat John Harvey John Harvey
labrat 2560 udp labrat John Harvey John Harvey
mosaixcc 2561 tcp MosaixCC Steven Frare Steven Frare
mosaixcc 2561 udp MosaixCC Steven Frare Steven Frare
delibo 2562 tcp Delibo NovaWiz LTD NovaWiz LTD
delibo 2562 udp Delibo NovaWiz LTD NovaWiz LTD

Contact Information

Name Organization Contact URI Last Updated
Alan Akahoshi alan-akahoshi&vertel.com
Albert Holt alberth&fiorano.com
Anthony Gonzalez agonzal1&telcordia.com
Arthur Castonguay arthurc&doe.carleton.ca
Benjamin Rosenberg brosenberg&advsyscon.com
Bob Kaiser BKaiser&palindrome.com
Brian Tung brian&isi.edu
Carstein Seeberg case&boole.no
Christian Schormann 100410.3063&compuserve.com
Chuck Neal chuck&phase3.com
Craig Rogers Rogers&isi.edu
Ed Green egreen&pmeasuring.com
Eddie Kohler IETF dccp WG kohler&cs.ucla.edu
Gary M. Allen gallen&symantec.com
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
J. S. Greenfield greeny&raleigh.ibm.com
Jakob Kaivo jkaivo&nodomainname.net
Jeff Burdette support&digitalenvoy.net
Jeff Garbers jgarbers&netcom.com
John E. Dickey jdickey&talarinetworks.com 2007-09-27
John Harvey johnbob&austin.ibm.com
Kelly Sims kellys&garnet.wv.tek.com
Kunihiko Morota morota.kunihiko&jp.panasonic.com 2005-08
Michael Battilana mcb-iana&cloanto.net 2010-04-30
Ming Poon mingp&corel.ca
Nick Shipman Nick.Shipman&mrmog.reo.dec.com
NovaWiz LTD Moshe&novawiz.com
Oren Hurvitz oren&omnisky.com
Paul W. Nelson nelson&thursby.com
Robert Hodgson rrh&gxt.com
Rudolph Balaz rudolphb&microsoft.com
Stefan Winkel stefan&veritas.com 2004-04
Steven Frare stevefr&mosaix.com
Susie Armstrong Armstrong.wbst128@xerox
Todd Guay todd.guay&oracle.com 2005-08
Tom Lemaire toml&banyan.com
Yoshinobu Inoue