Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-11-10
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| streettalk | 566 | tcp | streettalk | ||||||||
| streettalk | 566 | udp | streettalk | ||||||||
| corelvideo | 1566 | tcp | CORELVIDEO | Ming Poon | Ming Poon | ||||||
| corelvideo | 1566 | udp | CORELVIDEO | Ming Poon | Ming Poon | ||||||
| nfs | 2049 | sctp | Network File System | RFC 5665 | Defined TXT keys: path=<path to mount point> | ||||||
| pcs-pcw | 2566 | tcp | pcs-pcw | W. Jordan Fitzhugh | W. Jordan Fitzhugh | ||||||
| pcs-pcw | 2566 | udp | pcs-pcw | W. Jordan Fitzhugh | W. Jordan Fitzhugh | ||||||
| quest-data-hub | 3566 | tcp | Quest Data Hub | Greg Cottman | Greg Cottman | 2010-10-18 | |||||
| 3566 | udp | Reserved | 2010-10-18 | ||||||||
| kwtc | 4566 | tcp | Kids Watch Time Control Service | Larry Zarou | Larry Zarou | 2006-10 | |||||
| kwtc | 4566 | udp | Kids Watch Time Control Service | Larry Zarou | Larry Zarou | 2006-10 | |||||
| westec-connect | 5566 | tcp | Westec Connect | Jon Bolen | Jon Bolen | 2009-03-18 | |||||
| 5566 | udp | Reserved | |||||||||
| 5647-5665 | Unassigned | ||||||||||
| nrpe | 5666 | tcp | Nagios Remote Plugin Executor | Nagios Enterprises, LLC | Bryan Heden | 2017-09-06 | |||||
| 5666 | udp | Reserved | |||||||||
| 5667-5669 | Unassigned | ||||||||||
| sane-port | 6566 | tcp | SANE Control Port | Henning Meier-Geinitz | Henning Meier-Geinitz | 2002-10 | |||||
| sane-port | 6566 | udp | SANE Control Port | Henning Meier-Geinitz | Henning Meier-Geinitz | 2002-10 | |||||
| vsi-omega | 7566 | tcp | VSI Omega | Curtis Smith | Curtis Smith | ||||||
| vsi-omega | 7566 | udp | VSI Omega | Curtis Smith | Curtis Smith | ||||||
| 8556-8566 | Unassigned | ||||||||||
| bex-xr | 15660 | tcp | Backup Express Restore Server | Catalogic Software, Inc. | Chi Shih Chang | 2008-03-19 | 2015-02-04 | ||||
| bex-xr | 15660 | udp | Backup Express Restore Server | Catalogic Software, Inc. | Chi Shih Chang | 2008-03-19 | 2015-02-04 | ||||
| 15661-15739 | Unassigned | ||||||||||
| 34380-34566 | Unassigned |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Bryan Heden | bheden&nagios.com | 2017-09-06 | |
| Catalogic Software, Inc. | cchang&catalogicsoftware.com | 2015-02-04 | |
| Chi Shih Chang | Catalogic Software, Inc. | cchang&catalogicsoftware.com | 2015-02-04 |
| Curtis Smith | curtis.smith&vsin.com | ||
| Greg Cottman | Greg.Cottman&quest.com | 2010-10-18 | |
| Henning Meier-Geinitz | henning&meier-geinitz.de | 2002-10 | |
| Jon Bolen | jon.bolen&westec.net | 2009-03-18 | |
| Larry Zarou | zarla01&cbsits.com | 2006-10 | |
| Ming Poon | mingp&corel.ca | ||
| Nagios Enterprises, LLC | techteam&nagios.com | 2017-09-06 | |
| W. Jordan Fitzhugh | jfitz&pcare.com |