Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
sonar 572 tcp sonar Keith Moore Keith Moore
sonar 572 udp sonar Keith Moore Keith Moore
chip-lm 1572 tcp Chipcom License Manager
chip-lm 1572 udp Chipcom License Manager
ibp 2572 tcp IBP Jonathan Downes Jonathan Downes
ibp 2572 udp IBP Jonathan Downes Jonathan Downes
megaregsvrport 3572 tcp Registration Server Port Sreenivas Bagalkote Sreenivas Bagalkote 2002-08
megaregsvrport 3572 udp Registration Server Port Sreenivas Bagalkote Sreenivas Bagalkote 2002-08
tsp 3653 tcp Tunnel Setup Protocol Marc Blanchet Marc Blanchet 2003-01 RFC 5572
tsp 3653 udp Tunnel Setup Protocol Marc Blanchet Marc Blanchet 2003-01 RFC 5572
4571-4572 Unassigned
5570-5572 Unassigned Known UNAUTHORIZED USE on Port 5570
ms-licensing 5720 tcp MS-Licensing Thomas Lindeman Thomas Lindeman 2002-11
ms-licensing 5720 udp MS-Licensing Thomas Lindeman Thomas Lindeman 2002-11
dtpt 5721 tcp Desktop Passthru Service Dan Leising Dan Leising 2005-01
dtpt 5721 udp Desktop Passthru Service Dan Leising Dan Leising 2005-01
msdfsr 5722 tcp Microsoft DFS Replication Service Guhan Suriyanarayanan Guhan Suriyanarayanan 2006-03
msdfsr 5722 udp Microsoft DFS Replication Service Guhan Suriyanarayanan Guhan Suriyanarayanan 2006-03
omhs 5723 tcp Operations Manager - Health Service Gerardo Dilillo Gerardo Dilillo 2006-08
omhs 5723 udp Operations Manager - Health Service Gerardo Dilillo Gerardo Dilillo 2006-08
omsdk 5724 tcp Operations Manager - SDK Service Gerardo Dilillo Gerardo Dilillo 2006-08
omsdk 5724 udp Operations Manager - SDK Service Gerardo Dilillo Gerardo Dilillo 2006-08
ms-ilm 5725 tcp Microsoft Identity Lifecycle Manager Rob Ward Rob Ward
5725 udp Reserved 2008-05-02
ms-ilm-sts 5726 tcp Microsoft Lifecycle Manager Secure Token Service Rob Ward Rob Ward
5726 udp Reserved 2008-05-02
asgenf 5727 tcp ASG Event Notification Framework Arman Bedonian Arman Bedonian 2009-07-15
5727 udp Reserved
io-dist-data 5728 tcp Dist. I/O Comm. Service Data and Control Harish Kuttan Harish Kuttan 2010-03-22
io-dist-group 5728 udp Dist. I/O Comm. Service Group Membership Harish Kuttan Harish Kuttan 2010-03-22
openmail 5729 tcp Openmail User Agent Layer OpenMail Encyclopedia; Don Loughry OpenMail Encyclopedia; Don Loughry
openmail 5729 udp Openmail User Agent Layer OpenMail Encyclopedia; Don Loughry OpenMail Encyclopedia; Don Loughry
sztp tcp This service name is used to construct the SRV service label "_sztp" for discovering SZTP bootstrap servers. IESG IETF Chair 2019-01-17 RFC 8572 This protocol uses HTTPS as a substrate.

Contact Information

Name Organization Contact URI Last Updated
Arman Bedonian Arman.Bedonian&asg.com 2009-07-15
Dan Leising dleising&microsoft.com 2005-01
Don Loughry DON_LOUGHRY&hp-cupertino-om4.om.hp.com
Gerardo Dilillo MOMIANA&microsoft.com 2006-08
Guhan Suriyanarayanan guhans&microsoft.com 2006-03
Harish Kuttan harish.k&hp.com 2010-03-22
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jonathan Downes jonno&activ.net.au
Keith Moore moore&cs.utk.edu
Marc Blanchet marc.blanchet&viagenie.ca 2003-01
OpenMail Encyclopedia opencyc&hpopd.pwd.hp.com
Rob Ward RobWard&microsoft.com 2008-05-02
Sreenivas Bagalkote sreenib&lsil.com 2002-08
Thomas Lindeman tlinde&microsoft.com 2002-11