Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
xns-mail 58 tcp XNS Mail Susie Armstrong Susie Armstrong
xns-mail 58 udp XNS Mail Susie Armstrong Susie Armstrong
pcmail-srv 158 tcp PCMail Server Mark L. Lambert Mark L. Lambert
pcmail-srv 158 udp PCMail Server Mark L. Lambert Mark L. Lambert
258 Unassigned 2006-09-13
shrinkwrap 358 tcp Shrinkwrap Bill Simpson Bill Simpson
shrinkwrap 358 udp Shrinkwrap Bill Simpson Bill Simpson
appleqtc 458 tcp apple quick time Murali Ranganathan Murali Ranganathan
appleqtc 458 udp apple quick time Murali Ranganathan Murali Ranganathan
sdnskmp 558 tcp SDNSKMP
sdnskmp 558 udp SDNSKMP
sntp-heartbeat 580 tcp SNTP HEARTBEAT Louis Mamakos Louis Mamakos
sntp-heartbeat 580 udp SNTP HEARTBEAT Louis Mamakos Louis Mamakos
bdp 581 tcp Bundle Discovery Protocol Gary Malkin Gary Malkin
bdp 581 udp Bundle Discovery Protocol Gary Malkin Gary Malkin
scc-security 582 tcp SCC Security Prashant Dholakia Prashant Dholakia
scc-security 582 udp SCC Security Prashant Dholakia Prashant Dholakia
philips-vc 583 tcp Philips Video-Conferencing Janna Chang Janna Chang
philips-vc 583 udp Philips Video-Conferencing Janna Chang Janna Chang
keyserver 584 tcp Key Server Gary Howland Gary Howland
keyserver 584 udp Key Server Gary Howland Gary Howland
585 De-registered 2006-04-25 Use of 585 is not recommended, use 993 instead
password-chg 586 tcp Password Change
password-chg 586 udp Password Change
submission 587 tcp Message Submission 2011-11-17 RFC 6409
submission 587 udp Message Submission 2011-11-17 RFC 6409
cal 588 tcp CAL Myron Hattig Myron Hattig
cal 588 udp CAL Myron Hattig Myron Hattig
eyelink 589 tcp EyeLink Dave Stampe Dave Stampe
eyelink 589 udp EyeLink Dave Stampe Dave Stampe
tenfold 658 tcp TenFold Louis Olszyk Louis Olszyk
tenfold 658 udp TenFold Louis Olszyk Louis Olszyk
nlogin 758 tcp
nlogin 758 udp
domain-s 853 tcp DNS query-response protocol run over TLS IESG IETF Chair 2015-10-08 2022-04-11 RFC 7858
domain-s 853 udp DNS query-response protocol run over DTLS or QUIC IESG IETF Chair 2015-10-08 2022-04-01 RFC 7858; RFC 8094; RFC 9250
nim 1058 tcp nim
nim 1058 udp nim
dbcontrol-oms 1158 tcp dbControl OMS Todd Guay Todd Guay 2004-11
dbcontrol-oms 1158 udp dbControl OMS Todd Guay Todd Guay 2004-11
opennl 1258 tcp Open Network Library Phil Frisbie Phil Frisbie
opennl 1258 udp Open Network Library Phil Frisbie Phil Frisbie
connlcli 1358 tcp CONNLCLI
connlcli 1358 udp CONNLCLI
nrcabq-lm 1458 tcp Nichols Research Corp. Howard Cole Howard Cole
nrcabq-lm 1458 udp Nichols Research Corp. Howard Cole Howard Cole
xingmpeg 1558 tcp xingmpeg Howard Gordon Howard Gordon
xingmpeg 1558 udp xingmpeg Howard Gordon Howard Gordon
tn-tl-r1 1580 tcp tn-tl-r1
tn-tl-r2 1580 udp tn-tl-r2 Ed Kress Ed Kress
mil-2045-47001 1581 tcp MIL-2045-47001 Eric Whitehill Eric Whitehill
mil-2045-47001 1581 udp MIL-2045-47001 Eric Whitehill Eric Whitehill
msims 1582 tcp MSIMS Glenn Olander Glenn Olander
msims 1582 udp MSIMS Glenn Olander Glenn Olander
simbaexpress 1583 tcp simbaexpress Betsy Alexander Betsy Alexander
simbaexpress 1583 udp simbaexpress Betsy Alexander Betsy Alexander
tn-tl-fd2 1584 tcp tn-tl-fd2 Ed Kress Ed Kress
tn-tl-fd2 1584 udp tn-tl-fd2 Ed Kress Ed Kress
intv 1585 tcp intv Dermot Tynand Dermot Tynand
intv 1585 udp intv Dermot Tynand Dermot Tynand
ibm-abtact 1586 tcp ibm-abtact Sandeep K. Singhal Sandeep K. Singhal
ibm-abtact 1586 udp ibm-abtact Sandeep K. Singhal Sandeep K. Singhal
pra-elmd 1587 tcp pra_elmd

IANA assigned this well-formed service name as a replacement for "pra_elmd".
Dennis Mastin Dennis Mastin
pra_elmd 1587 tcp pra_elmd Dennis Mastin Dennis Mastin This entry is an alias to "pra-elmd". This entry is now historic, not usable for use with many common service discovery mechanisms.
pra-elmd 1587 udp pra_elmd

IANA assigned this well-formed service name as a replacement for "pra_elmd".
Dennis Mastin Dennis Mastin
pra_elmd 1587 udp pra_elmd Dennis Mastin Dennis Mastin This entry is an alias to "pra-elmd". This entry is now historic, not usable for use with many common service discovery mechanisms.
triquest-lm 1588 tcp triquest-lm Nand Kumar Nand Kumar
triquest-lm 1588 udp triquest-lm Nand Kumar Nand Kumar
vqp 1589 tcp VQP Keith McCloghrie Keith McCloghrie
vqp 1589 udp VQP Keith McCloghrie Keith McCloghrie
sixnetudr 1658 tcp sixnetudr Red Lion Controls Denis Aull 2014-05-21
sixnetudr 1658 udp sixnetudr Red Lion Controls Denis Aull 2014-05-21
tftp-mcast 1758 tcp tftp-mcast Tom Emberson Tom Emberson
tftp-mcast 1758 udp tftp-mcast Tom Emberson Tom Emberson
privateark 1858 tcp PrivateArk Ronen Zoran Ronen Zoran
privateark 1858 udp PrivateArk Ronen Zoran Ronen Zoran
dxadmind 1958 tcp CA Administration Daemon John Birrell John Birrell
dxadmind 1958 udp CA Administration Daemon John Birrell John Birrell
newwavesearch 2058 tcp NewWaveSearchables RMI Thomas Kerkau Thomas Kerkau
newwavesearch 2058 udp NewWaveSearchables RMI Thomas Kerkau Thomas Kerkau
touchnetplus 2158 tcp TouchNetPlus Service Brian Toothill Brian Toothill 2008-03-06
touchnetplus 2158 udp TouchNetPlus Service Brian Toothill Brian Toothill 2008-03-06
rcts 2258 tcp Rotorcraft Communications Test System Terry Eldridge Terry Eldridge 2006-08
rcts 2258 udp Rotorcraft Communications Test System Terry Eldridge Terry Eldridge 2006-08
futrix 2358 tcp Futrix Peter Frankenberg Peter Frankenberg
futrix 2358 udp Futrix Peter Frankenberg Peter Frankenberg
griffin 2458 tcp griffin Tom Taylor Tom Taylor
griffin 2458 udp griffin Tom Taylor Tom Taylor
pclemultimedia 2558 tcp PCLE Multi Media Jacob Gsoedl Jacob Gsoedl
pclemultimedia 2558 udp PCLE Multi Media Jacob Gsoedl Jacob Gsoedl
tributary 2580 tcp Tributary Louis Lu Louis Lu
tributary 2580 udp Tributary Louis Lu Louis Lu
argis-te 2581 tcp ARGIS TE
argis-te 2581 udp ARGIS TE
argis-ds 2582 tcp ARGIS DS John Legh-Page John Legh-Page
argis-ds 2582 udp ARGIS DS John Legh-Page John Legh-Page
mon 2583 tcp MON Jim Trocki Jim Trocki
mon 2583 udp MON Jim Trocki Jim Trocki
cyaserv 2584 tcp cyaserv Morgan Jones Morgan Jones
cyaserv 2584 udp cyaserv Morgan Jones Morgan Jones

Contact Information

Name Organization Contact URI Last Updated
Betsy Alexander tel:+1-604-681-4549
Bill Simpson wsimpson&greendragon.com
Brian Toothill brian.toothill&touchstar.co.uk 2010-10-15
Dave Stampe dstampe&psych.toronto.edu
Denis Aull Red Lion Controls Engineering&RedLion.net 2014-05-21
Dennis Mastin dennis&tasmania.platte.com
Dermot Tynand dtynan&claddagh.ie
Ed Kress eskress&thinknet.com
Eric Whitehill Eric.Whitehill&itt.com
Gary Howland gary&systemics.com
Gary Malkin gmalkin&xylogics.com
Glenn Olander gjo&msi.com
Howard Cole hcole&tumbleweed.nrcabq.com
Howard Gordon hgordon&system.xingtech.com
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jacob Gsoedl jgsoedl&pinnaclesys.com
Janna Chang janna&pmc.philips.com
Jim Trocki trockij&transmeta.com
John Birrell birjo99&cai.com
John Legh-Page john.legh-page&argis.com
Keith McCloghrie kzm&cisco.com
Louis Lu LouisL&bristol.com
Louis Mamakos louie&uu.net
Louis Olszyk lolszyk&10fold.com
Mark L. Lambert markl&ptt.lcs.mit.edu
Morgan Jones mwj&cyasolutions.com
Murali Ranganathan murali_ranganathan&quickmail.apple.com
Myron Hattig Myron_Hattig&ccm.jf.intel.com
Nand Kumar nkumar&triquest-da.com
Peter Frankenberg pcfberg&ibm.net
Phil Frisbie phil.frisbie&gmail.com 2018-12-17
Prashant Dholakia prashant&semaphorecom.com
Red Lion Controls Engineering&RedLion.net 2014-05-21
Ronen Zoran ronenz&cyber-ark.com
Sandeep K. Singhal singhal&cs.stanford.edu
Susie Armstrong Armstrong.wbst128@xerox
Terry Eldridge Terry.Eldridge&6pointn.com 2006-08
Thomas Kerkau Thomas.Kerkau&io-software.com
Todd Guay todd.guay&oracle.com 2005-08
Tom Emberson tom&lanworks.com
Tom Taylor Tom.Taylor&unisys.com