Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
0 tcp Reserved 2024-12-20 RFC 6335
0 udp Reserved 2024-12-20 RFC 6335
6 tcp Unassigned
6 udp Unassigned
discard 9 sctp Discard Randall Stewart Randall Stewart 2022-02-07 RFC 9260
discard 9 dccp Discard Eddie Kohler Eddie Kohler RFC 4340 1145656131
daytime 13 tcp Daytime Jon Postel Jon Postel RFC 867
daytime 13 udp Daytime Jon Postel Jon Postel RFC 867
16 tcp Unassigned
16 udp Unassigned
ftp-data 20 sctp FTP Randall Stewart Randall Stewart 2022-02-07 RFC 9260
ftp 21 sctp FTP Randall Stewart Randall Stewart 2022-02-07 RFC 9260 Defined TXT keys: u=<username> p=<password> path=<path>
ssh 22 sctp SSH Randall Stewart Randall Stewart 2022-02-07 RFC 9260 Defined TXT keys: u=<username> p=<password>
26 tcp Unassigned
26 udp Unassigned
36 tcp Unassigned
36 udp Unassigned
mpm-snd 46 tcp MPM [default send] Jon Postel Jon Postel
mpm-snd 46 udp MPM [default send] Jon Postel Jon Postel
xns-auth 56 tcp XNS Authentication Susie Armstrong Susie Armstrong
xns-auth 56 udp XNS Authentication Susie Armstrong Susie Armstrong
60 tcp Unassigned
60 udp Unassigned
61 tcp Reserved 2017-05-18 This entry has been removed on 2017-05-18.
61 udp Reserved 2017-05-18 This entry has been removed on 2017-05-18.
acas 62 tcp ACA Services E. Wald E. Wald
acas 62 udp ACA Services E. Wald E. Wald
whoispp 63 tcp whois++

IANA assigned this well-formed service name as a replacement for "whois++".
Rickard Schoultz Rickard Schoultz
whois++ 63 tcp whois++ Rickard Schoultz Rickard Schoultz This entry is an alias to "whoispp". This entry is now historic, not usable for use with many common service discovery mechanisms.
whoispp 63 udp whois++

IANA assigned this well-formed service name as a replacement for "whois++".
Rickard Schoultz Rickard Schoultz
whois++ 63 udp whois++ Rickard Schoultz Rickard Schoultz This entry is an alias to "whoispp". This entry is now historic, not usable for use with many common service discovery mechanisms.
covia 64 tcp Communications Integrator (CI) Dan Smith Dan Smith
covia 64 udp Communications Integrator (CI) Dan Smith Dan Smith
tacacs-ds 65 tcp TACACS-Database Service Kathy Huber Kathy Huber
tacacs-ds 65 udp TACACS-Database Service Kathy Huber Kathy Huber
sql-net 66 tcp Oracle SQL*NET

IANA assigned this well-formed service name as a replacement for "sql*net".
Jack Haverty Jack Haverty
sql*net 66 tcp Oracle SQL*NET Jack Haverty Jack Haverty This entry is an alias to "sql-net". This entry is now historic, not usable for use with many common service discovery mechanisms.
sql-net 66 udp Oracle SQL*NET

IANA assigned this well-formed service name as a replacement for "sql*net".
Jack Haverty Jack Haverty
sql*net 66 udp Oracle SQL*NET Jack Haverty Jack Haverty This entry is an alias to "sql-net". This entry is now historic, not usable for use with many common service discovery mechanisms.
bootps 67 tcp Bootstrap Protocol Server Bill Croft Bill Croft RFC 951 Defined TXT keys: None
bootps 67 udp Bootstrap Protocol Server
bootpc 68 tcp Bootstrap Protocol Client Bill Croft Bill Croft
bootpc 68 udp Bootstrap Protocol Client Bill Croft Bill Croft
tftp 69 tcp Trivial File Transfer David Clark David Clark
tftp 69 udp Trivial File Transfer David Clark David Clark
deos 76 tcp Distributed External Object Store Robert Ullmann Robert Ullmann
deos 76 udp Distributed External Object Store Robert Ullmann Robert Ullmann
finger 79 tcp Finger David Zimmerman David Zimmerman Unauthorized use by some mail users (see [RFC4146] for details)
finger 79 udp Finger David Zimmerman David Zimmerman Unauthorized use by some mail users (see [RFC4146] for details)
http 80 sctp HTTP Randall Stewart Randall Stewart 2022-02-07 RFC 9260 Defined TXT keys: u=<username> p=<password> path=<path to document>
mfcobol 86 tcp Micro Focus Cobol Simon Edwards Simon Edwards
mfcobol 86 udp Micro Focus Cobol Simon Edwards Simon Edwards
dixie 96 tcp DIXIE Protocol Specification Tim Howes Tim Howes
dixie 96 udp DIXIE Protocol Specification Tim Howes Tim Howes
3com-tsmux 106 tcp 3COM-TSMUX Jeremy Siegel Jeremy Siegel Known Unauthorized Use on 106
3com-tsmux 106 udp 3COM-TSMUX Jeremy Siegel Jeremy Siegel Known Unauthorized Use on 106
ansanotify 116 tcp ANSA REX Notify Nicola J. Howarth Nicola J. Howarth
ansanotify 116 udp ANSA REX Notify Nicola J. Howarth Nicola J. Howarth
nxedit 126 tcp NXEdit Don Payette Don Payette Port 126 Previously assigned to application below unitary 126/tcp Unisys Unitary Login unitary 126/udp Unisys Unitary Login <feil&kronos.nisd.cam.unisys.com> Port 126 Previously assigned to application above
nxedit 126 udp NXEdit Don Payette Don Payette Port 126 Previously assigned to application below unitary 126/tcp Unisys Unitary Login unitary 126/udp Unisys Unitary Login <feil&kronos.nisd.cam.unisys.com> Port 126 Previously assigned to application above
profile 136 tcp PROFILE Naming System Larry Peterson Larry Peterson
profile 136 udp PROFILE Naming System Larry Peterson Larry Peterson
iso-tp0 146 tcp ISO-IP0
iso-tp0 146 udp ISO-IP0
sqlsrv 156 tcp SQL Service Craig Rogers Craig Rogers
sqlsrv 156 udp SQL Service Craig Rogers Craig Rogers
sgmp-traps 160 tcp SGMP-TRAPS Marty Schoffstahl Marty Schoffstahl
sgmp-traps 160 udp SGMP-TRAPS Marty Schoffstahl Marty Schoffstahl
snmp 161 tcp SNMP
snmp 161 udp SNMP
snmptrap 162 tcp SNMPTRAP Marshall Rose Marshall Rose
snmptrap 162 udp SNMPTRAP Marshall Rose Marshall Rose
cmip-man 163 tcp CMIP/TCP Manager
cmip-man 163 udp CMIP/TCP Manager
cmip-agent 164 tcp CMIP/TCP Agent Amatzia Ben-Artzi Amatzia Ben-Artzi
cmip-agent 164 udp CMIP/TCP Agent Amatzia Ben-Artzi Amatzia Ben-Artzi
xns-courier 165 tcp Xerox Susie Armstrong Susie Armstrong
xns-courier 165 udp Xerox Susie Armstrong Susie Armstrong
s-net 166 tcp Sirius Systems Brian Lloyd Brian Lloyd
s-net 166 udp Sirius Systems Brian Lloyd Brian Lloyd
namp 167 tcp NAMP Marty Schoffstahl Marty Schoffstahl
namp 167 udp NAMP Marty Schoffstahl Marty Schoffstahl
rsvd 168 tcp RSVD Alan Sandell Alan Sandell 2008-05-01
rsvd 168 udp RSVD Alan Sandell Alan Sandell 2008-05-01
send 169 tcp SEND William Oldwin William Oldwin 2019-04-22
send 169 udp SEND William Oldwin William Oldwin 2019-04-22
genrad-mux 176 tcp GENRAD-MUX Ron Thornton Ron Thornton
genrad-mux 176 udp GENRAD-MUX Ron Thornton Ron Thornton
bgp 179 sctp BGP Randall Stewart Randall Stewart 2022-02-07 RFC 9260
kis 186 tcp KIS Protocol Ralph Droms Ralph Droms
kis 186 udp KIS Protocol Ralph Droms Ralph Droms
dn6-nlm-aud 195 tcp DNSIX Network Level Module Audit
dn6-nlm-aud 195 udp DNSIX Network Level Module Audit
dn6-smm-red 196 tcp DNSIX Session Mgt Module Audit Redir Lawrence Lebahn Lawrence Lebahn
dn6-smm-red 196 udp DNSIX Session Mgt Module Audit Redir Lawrence Lebahn Lawrence Lebahn
at-zis 206 tcp AppleTalk Zone Information
at-zis 206 udp AppleTalk Zone Information
CAIlic 216 tcp Computer Associates Int'l License Server Chuck Spitz Chuck Spitz
CAIlic 216 udp Computer Associates Int'l License Server Chuck Spitz Chuck Spitz
225-241 Reserved 2024-12-20 RFC 1060

Contact Information

Name Organization Contact URI Last Updated
Alan Sandell alan.sandell&ist.co.uk 2008-05-01
Amatzia Ben-Artzi
Bill Croft Croft&sumex-aim.stanford.edu
Brian Lloyd brian&lloyd.com
Chuck Spitz spich04&cai.com
Craig Rogers Rogers&isi.edu
Dan Smith dan.smith&den.galileo.com
David Clark ddc&lcs.mit.edu
David Zimmerman dpz&rutgers.edu
Don Payette Don.Payette&unisys.com
E. Wald ewald&via.enet.dec.com
Eddie Kohler IETF dccp WG kohler&cs.ucla.edu
Jack Haverty jhaverty&oracle.com
Jeremy Siegel jzs&nsd.3com.com
Jon Postel postel&isi.edu
Kathy Huber khuber&bbn.com
Larry Peterson llp&arizona.edu
Lawrence Lebahn DIA3&paxrv-nes.navy.mil
Marshall Rose mrose17&gmail.com 2024-07-29
Marty Schoffstahl schoff&nisc.nyser.net
Nicola J. Howarth njh&ansa.co.uk
Ralph Droms rdroms&nri.reston.va.us
Randall Stewart IETF TSVWG rrs&lakerest.net
Rickard Schoultz schoultz&sunet.se
Robert Ullmann ariel&world.std.com
Ron Thornton thornton&aerostation.org 2020-09-01
Simon Edwards sedwards&rocketsoftware.com 2024-10-11
Susie Armstrong Armstrong.wbst128@xerox
Susie Armstrong Armstrong.wbst128&xerox.com
Tim Howes Tim.Howes&terminator.cc.umich.edu
William Oldwin william&bitsome.ie 2022-01-28