Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
syslog-conn 601 tcp Reliable Syslog Service RFC 3195
syslog-conn 601 udp Reliable Syslog Service RFC 3195
aas 1601 tcp aas Bob Beard Bob Beard
aas 1601 udp aas Bob Beard Bob Beard
discp-client 2601 tcp discp client
discp-client 2601 udp discp client
visinet-gui 3601 tcp Visinet Gui Jeff Douglass Jeff Douglass 2002-09
visinet-gui 3601 udp Visinet Gui Jeff Douglass Jeff Douglass 2002-09
piranha2 4601 tcp Piranha2 Primark Corporation Primark Corporation
piranha2 4601 udp Piranha2 Primark Corporation Primark Corporation
esmagent 5601 tcp Enterprise Security Agent Kimberly Gibbs Kimberly Gibbs
esmagent 5601 udp Enterprise Security Agent Kimberly Gibbs Kimberly Gibbs
syslog-tls 6514 udp syslog over DTLS RFC 6012
syslog-tls 6514 dccp syslog over DTLS RFC 6012
mstmg-sstp 6601 tcp Microsoft Threat Management Gateway SSTP Ori Yosefi Ori Yosefi 2009-05-04
6601 udp Reserved
8601-8608 Unassigned
9601-9611 Unassigned
11601-11622 Unassigned
16004-16019 Unassigned
udpstp 24601 udp UDP-based IP-Layer Capacity and Performance Measurement protocol IESG IETF Chair 2025-09-26 RFC 9946
24601 tcp Reserved
36525-36601 Unassigned
eftp 37601 tcp Epipole File Transfer Protocol Epipole Limited Colin Buchanan 2014-11-13
37601 udp Reserved
44601-44817 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Bob Beard bobb&lachman.com
Colin Buchanan Epipole Limited colin&epipole.com 2014-11-13
Epipole Limited info&epipole.com 2014-11-13
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jeff Douglass ist&att.net 2002-09
Kimberly Gibbs kimgib&ccgate-ut.axent.com
Ori Yosefi Ori.Yosefi&microsoft.com 2009-05-04
Primark Corporation joe.boone&primark.com