Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
xmlrpc-beep 602 tcp XML-RPC over BEEP RFC 3529
xmlrpc-beep 602 udp XML-RPC over BEEP RFC 3529
inspect 1602 tcp inspect Frank O'Neill Frank O'Neill
inspect 1602 udp inspect Frank O'Neill Frank O'Neill
discp-server 2602 tcp discp server Peter White Peter White
discp-server 2602 udp discp server Peter White Peter White
infiniswitchcl 3602 tcp InfiniSwitch Mgr Client Lee VanTine Lee VanTine 2002-09
infiniswitchcl 3602 udp InfiniSwitch Mgr Client Lee VanTine Lee VanTine 2002-09
mtsserver 4602 tcp EAX MTS Server Pedro A Rodriguez Pedro A Rodriguez 2008-08-06
4602 udp Reserved
a1-msc 5602 tcp A1-MSC Mike Dolan Mike Dolan
a1-msc 5602 udp A1-MSC Mike Dolan Mike Dolan
wsscomfrmwk 6602 tcp Windows WSS Communication Framework Rong Yu Rong Yu 2010-08-10
6602 udp Reserved
jwpc 16020 tcp Filemaker Java Web Publishing Core Robert Parks Robert Parks 2010-05-12
16020 udp Reserved
jwpc-bin 16021 tcp Filemaker Java Web Publishing Core Binary Robert Parks Robert Parks 2010-05-12
16021 udp Reserved
16022-16160 Unassigned
24602-24665 Unassigned
observium-agent 36602 tcp Observium statistics collection agent Observium Adam Armstrong 2013-05-10
36602 udp Reserved
37602-37653 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Adam Armstrong Observium adama&observium.org 2013-05-10
Frank O'Neill frank&morse.ilo.dec.com
Lee VanTine lvantine&infiniswitc.com 2002-09
Mike Dolan MDolan&ihcmail.ih.lucent.com
Observium adama&observium.org 2013-05-10
Pedro A Rodriguez pedro.rdz&eaxtechnologies.com.mx 2008-08-06
Peter White peter_white&3com.com 2004-11
Robert Parks robert_parks&filemaker.com 2010-05-12
Rong Yu rongyu&microsoft.com 2010-08-10