Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| discard | 9 | dccp | Discard | Eddie Kohler | Eddie Kohler | RFC 4340 | 1145656131 | ||||
| hmmp-op | 613 | tcp | HMMP Operation | Andrew Sinclair | Andrew Sinclair | ||||||
| hmmp-op | 613 | udp | HMMP Operation | Andrew Sinclair | Andrew Sinclair | ||||||
| netbill-keyrep | 1613 | tcp | NetBill Key Repository | ||||||||
| netbill-keyrep | 1613 | udp | NetBill Key Repository | ||||||||
| smntubootstrap | 2613 | tcp | SMNTUBootstrap | Matt Cecile | Matt Cecile | ||||||
| smntubootstrap | 2613 | udp | SMNTUBootstrap | Matt Cecile | Matt Cecile | ||||||
| alaris-disc | 3613 | tcp | Alaris Device Discovery | Chris Dern | Chris Dern | 2004-06 | |||||
| alaris-disc | 3613 | udp | Alaris Device Discovery | Chris Dern | Chris Dern | 2004-06 | |||||
| damewaremobgtwy | 6130 | tcp | The DameWare Mobile Gateway Service | SolarWinds | David Gayler | 2013-05-29 | |||||
| 6130 | udp | Reserved | |||||||||
| 6131-6132 | Unassigned | ||||||||||
| nbt-wol | 6133 | tcp | New Boundary Tech WOL | Elizabeth Zilen | Elizabeth Zilen | 2004-11 | |||||
| nbt-wol | 6133 | udp | New Boundary Tech WOL | Elizabeth Zilen | Elizabeth Zilen | 2004-11 | |||||
| 6134-6139 | Unassigned | ||||||||||
| canon-bjnp3 | 8613 | tcp | Canon BJNP Port 3 | Atsushi Nakamura | Atsushi Nakamura | 2003-11 | |||||
| canon-bjnp3 | 8613 | udp | Canon BJNP Port 3 | Atsushi Nakamura | Atsushi Nakamura | 2003-11 | |||||
| 9613 | Unassigned | ||||||||||
| 26001-26132 | Unassigned | ||||||||||
| scscp | 26133 | tcp | Symbolic Computation Software Composability Protocol | Alexander Konovalov | Alexander Konovalov | 2007-11-27 | |||||
| scscp | 26133 | udp | Symbolic Computation Software Composability Protocol | Alexander Konovalov | Alexander Konovalov | 2007-11-27 | |||||
| 26134-26207 | Unassigned |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Alexander Konovalov | konovalov&member.ams.org | 2007-11-27 | |
| Andrew Sinclair | andrsinµsoft.com | ||
| Atsushi Nakamura | nakamura.atsushi318&canon.co.jp | 2003-11 | |
| Chris Dern | cdern&nospam.alarismed.com | 2004-06 | |
| David Gayler | SolarWinds | david.gayler&solarwinds.com | 2013-05-29 |
| Eddie Kohler | IETF dccp WG | kohler&cs.ucla.edu | |
| Elizabeth Zilen | ezilen&newboundary.com | 2004-11 | |
| Matt Cecile | mattc&metrics.com | ||
| SolarWinds | david.gayler&solarwinds.com | 2013-05-29 |