Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| tunnel | 604 | tcp | TUNNEL | RFC 3620 | |||||||
| tunnel | 604 | udp | TUNNEL | RFC 3620 | |||||||
| sco-websrvrmgr | 620 | tcp | SCO WebServer Manager | Christopher Durham | Christopher Durham | ||||||
| sco-websrvrmgr | 620 | udp | SCO WebServer Manager | Christopher Durham | Christopher Durham | ||||||
| faxportwinport | 1620 | tcp | faxportwinport | Chris Wells | Chris Wells | ||||||
| faxportwinport | 1620 | udp | faxportwinport | Chris Wells | Chris Wells | ||||||
| lpsrecommender | 2620 | tcp | LPSRecommender | Pritham Shetty | Pritham Shetty | ||||||
| lpsrecommender | 2620 | udp | LPSRecommender | Pritham Shetty | Pritham Shetty | ||||||
| ep-pcp | 3620 | tcp | EPSON Projector Control Port | ||||||||
| ep-pcp | 3620 | udp | EPSON Projector Control Port | ||||||||
| 4607-4620 | Unassigned | ||||||||||
| lm-x | 6200 | tcp | LM-X License Manager by X-Formation | Henrik Goldman | Henrik Goldman | 2006-10 | Known Unauthorized Use on port 6200 | ||||
| lm-x | 6200 | udp | LM-X License Manager by X-Formation | Henrik Goldman | Henrik Goldman | 2006-10 | Known Unauthorized Use on port 6200 | ||||
| 6201 | tcp | Reserved | |||||||||
| thermo-calc | 6201 | udp | Management of service nodes in a processing grid for thermodynamic calculations | Thermo-Calc Software AB | Thomas Revesz | 2012-06-28 | |||||
| 6202-6208 | Unassigned | ||||||||||
| qmtps | 6209 | tcp | QMTP over TLS | FEHCom | Erwin Hoffmann | 2015-01-09 | |||||
| qmtps | 6209 | udp | QMTP over TLS | FEHCom | Erwin Hoffmann | 2015-01-09 | |||||
| kftp-data | 6620 | tcp | Kerberos V5 FTP Data | Robert J. Scott | Robert J. Scott | 2005-08 | |||||
| kftp-data | 6620 | udp | Kerberos V5 FTP Data | Robert J. Scott | Robert J. Scott | 2005-08 | |||||
| 16620-16664 | Unassigned | ||||||||||
| 26134-26207 | Unassigned | ||||||||||
| wnn6-ds | 26208 | tcp | wnn6-ds | Yasunari Gon Yamasita | Yasunari Gon Yamasita | ||||||
| wnn6-ds | 26208 | udp | wnn6-ds | Yasunari Gon Yamasita | Yasunari Gon Yamasita | ||||||
| 26209-26256 | Unassigned | ||||||||||
| lm-mon | 31620 | tcp | lm mon | System Administrator | System Administrator | 2003-06 | |||||
| lm-mon | 31620 | udp | lm mon | System Administrator | System Administrator | 2003-06 | |||||
| 48620-48652 | Unassigned | ||||||||||
| jmap | tcp | JSON Meta Application Protocol | IESG | IETF Chair | 2016-01-22 | 2019-07-16 | RFC 8620 | This service name was previously assigned under the name "JSON Mail Access Protocol". This has been de-assigned and re-assigned with the approval of the previous assignee. |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Chris Wells | chris_wells&lansource.com | ||
| Christopher Durham | chrisdu&sco.com | ||
| Erwin Hoffmann | FEHCom | feh&fehcom.de | 2015-01-09 |
| FEHCom | feh&fehcom.de | 2015-01-09 | |
| Henrik Goldman | hg&x-formation.com | 2006-10 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Pritham Shetty | pritham&andromedia.com | ||
| Robert J. Scott | rob&hpcmo.hpc.mil | 2005-08 | |
| System Administrator | sysadmin&silvaco.com | 2003-06 | |
| Thermo-Calc Software AB | thomasr&thermocalc.se | 2012-06-28 | |
| Thomas Revesz | Thermo-Calc Software AB | thomasr&thermocalc.se | 2012-06-28 |
| Yasunari Gon Yamasita | yamasita&omronsoft.co.jp |