Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
ldaps 636 tcp ldap protocol over TLS/SSL (was sldap) Pat Richard Pat Richard
ldaps 636 udp ldap protocol over TLS/SSL (was sldap) Pat Richard Pat Richard
isdc 1636 tcp ISP shared public data control
isdc 1636 udp ISP shared public data control
solve 2636 tcp Solve Peter Morrison Peter Morrison
solve 2636 udp Solve Peter Morrison Peter Morrison
servistaitsm 3636 tcp SerVistaITSM Ralph Campbell Ralph Campbell 2002-11
servistaitsm 3636 udp SerVistaITSM Ralph Campbell Ralph Campbell 2002-11
sfm-db-server 5636 tcp SFMdb - SFM DB server De-Chih Chien De-Chih Chien 2008-10-06
5636 udp Reserved
metaedit-mu 6360 tcp MetaEdit+ Multi-User Steven Kelly Steven Kelly 2007-11-12
metaedit-mu 6360 udp MetaEdit+ Multi-User Steven Kelly Steven Kelly 2007-11-12
6361-6362 Unassigned
ndn 6363 udp Named Data Networking Regents of the University of California Jeff Burke 2013-10-30
6363 tcp Reserved
6364-6369 Unassigned
6636 tcp Reserved
mpls-udp-dtls 6636 udp Encapsulate MPLS packets in UDP tunnels with DTLS. IESG IETF Chair 2015-02-10 RFC 7510
netserialext1 16360 tcp Network Serial Extension Ports One Michael J Hoy Michael J Hoy
netserialext1 16360 udp Network Serial Extension Ports One Michael J Hoy Michael J Hoy
netserialext2 16361 tcp Network Serial Extension Ports Two Michael J Hoy Michael J Hoy
netserialext2 16361 udp Network Serial Extension Ports Two Michael J Hoy Michael J Hoy
16362-16366 Unassigned
netserialext3 16367 tcp Network Serial Extension Ports Three Michael J Hoy Michael J Hoy
netserialext3 16367 udp Network Serial Extension Ports Three Michael J Hoy Michael J Hoy
netserialext4 16368 tcp Network Serial Extension Ports Four Michael J Hoy Michael J Hoy
netserialext4 16368 udp Network Serial Extension Ports Four Michael J Hoy Michael J Hoy
16369-16383 Unassigned
18636-18667 Unassigned
DMExpress 32636 tcp DMExpress Arnie Farrelly Arnie Farrelly
DMExpress 32636 udp DMExpress Arnie Farrelly Arnie Farrelly

Contact Information

Name Organization Contact URI Last Updated
Arnie Farrelly afarrelly&syncsort.com
De-Chih Chien de-chih_chien&symantec.com 2008-10-06
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jeff Burke Regents of the University of California jburke&remap.ucla.edu 2013-10-30
Michael J Hoy mhoy&canberra-abq.com
Pat Richard patr&xcert.com
Peter Morrison peter_morrison&sydney.sterling.com
Ralph Campbell ralph.campbell&xasystems.com 2002-11
Regents of the University of California jburke&remap.ucla.edu 2013-10-30
Steven Kelly stevek&metacase.com 2007-11-12