Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-11-10

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
submission 587 tcp Message Submission 2011-11-17 RFC 6409
submission 587 udp Message Submission 2011-11-17 RFC 6409
entrust-sps 640 tcp entrust-sps Marek Buchler Marek Buchler
entrust-sps 640 udp entrust-sps Marek Buchler Marek Buchler
cert-responder 1640 tcp cert-responder Tom Markson Tom Markson
cert-responder 1640 udp cert-responder Tom Markson Tom Markson
ami-control 2640 tcp Alcorn McBride Inc protocol used for device control Alcorn McBride Inc. Alcorn McBride Inc. 2020-03-12
ami-control 2640 udp Alcorn McBride Inc protocol used for device control Alcorn McBride Inc. Alcorn McBride Inc. 2020-03-12
netplay-port1 3640 tcp Netplay Port 1
netplay-port1 3640 udp Netplay Port 1
5640-5645 Unassigned
boe-cms 6400 Business Objects CMS contact port SAP Giriraj Harapanahalli 2008-05-05 2026-05-27
boe-was 6401 boe-was SAP Giriraj Harapanahalli 2008-05-05 2026-05-27
boe-eventsrv 6402 boe-eventsrv SAP Giriraj Harapanahalli 2008-05-05 2026-05-27
boe-cachesvr 6403 boe-cachesvr SAP Giriraj Harapanahalli 2008-05-05 2026-05-27
boe-filesvr 6404 Business Objects Enterprise internal server SAP Giriraj Harapanahalli 2008-05-05 2026-05-27
boe-pagesvr 6405 Business Objects Enterprise internal server SAP Giriraj Harapanahalli 2008-05-05 2026-05-27
boe-processsvr 6406 Business Objects Enterprise internal server SAP Giriraj Harapanahalli 2008-05-05 2026-05-27
boe-resssvr1 6407 Business Objects Enterprise internal server SAP Giriraj Harapanahalli 2008-05-05 2026-05-27
boe-resssvr2 6408 Business Objects Enterprise internal server SAP Giriraj Harapanahalli 2008-05-05 2026-05-27
boe-resssvr3 6409 Business Objects Enterprise internal server SAP Giriraj Harapanahalli 2008-05-05 2026-05-27
ovsdb 6640 tcp Open vSwitch Database protocol Bruce Davie Bruce Davie 2013-07-31 RFC 7047
6640 udp Reserved
pqsflows 9640 tcp ProQueSys Flows Service Sarene Caiazza Sarene Caiazza 2010-04-27
9640 udp Reserved

Contact Information

Name Organization Contact URI Last Updated
Alcorn McBride Inc. support&alcorn.com
Bruce Davie bdavie&vmware.com 2013-07-31
Giriraj Harapanahalli giriraj.harapanahalli&sap.com 2026-05-27
Marek Buchler Marek.Buchler&entrust.com
SAP giriraj.harapanahalli&sap.com 2026-05-27
Sarene Caiazza scaiazza&proquesys.com 2010-04-27
Tom Markson markson&osmosys.incog.com