Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
dhcp-failover 647 tcp DHCP Failover IESG IETF Chair 2018-05-21 RFC 8156
dhcp-failover 647 udp DHCP Failover Bernard Volz Bernard Volz
rsap 1647 tcp rsap Holger Reif Holger Reif
rsap 1647 udp rsap Holger Reif Holger Reif
syncserver 2647 tcp SyncServer Shawn Casey Shawn Casey
syncserver 2647 udp SyncServer Shawn Casey Shawn Casey
splitlock-gw 3647 tcp Splitlock Gateway Andrew Tune Andrew Tune 2003-01
splitlock-gw 3647 udp Splitlock Gateway Andrew Tune Andrew Tune 2003-01
4647-4657 Unassigned
5647-5665 Unassigned
6465-6470 Unassigned
lvision-lm 6471 tcp LVision License Manager Brian McKinnon Brian McKinnon
lvision-lm 6471 udp LVision License Manager Brian McKinnon Brian McKinnon
6472-6479 Unassigned
7634-7647 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Andrew Tune Andrew.Tune&splitlock.com 2003-01
Bernard Volz bevolz&gmail.com 2022-08-03
Brian McKinnon bmk&lvision.com
Holger Reif Holger.Reif&prakinf.tu-ilmenau.de
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Shawn Casey Shawn.Casey&matrixone.com