Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-11-10

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
purenoise 663 tcp PureNoise Sam Osa Sam Osa
purenoise 663 udp PureNoise Sam Osa Sam Osa
netview-aix-3 1663 tcp netview-aix-3
netview-aix-3 1663 udp netview-aix-3
bintec-tapi 2663 tcp BinTec-TAPI
bintec-tapi 2663 udp BinTec-TAPI
dtp 3663 tcp DIRECWAY Tunnel Protocol John Border John Border 2003-01
dtp 3663 udp DIRECWAY Tunnel Protocol John Border John Border 2003-01
noteit 4663 tcp Note It! Message Service Pedro Alpedrinha Pedro Alpedrinha 2006-02
noteit 4663 udp Note It! Message Service Pedro Alpedrinha Pedro Alpedrinha 2006-02
6630 Unassigned
6631 Unassigned 2004-05-28
mxodbc-connect 6632 tcp eGenix mxODBC Connect Marc-Andre Lemburg Marc-Andre Lemburg 2009-11-13 Unauthorized Use Known on port 6632
6632 udp Reserved
6633 tcp Reserved
cisco-vpath-tun 6633 udp Cisco vPath Services Overlay Cisco Surendra Kumar 2012-06-11
mpls-pm 6634 udp MPLS Performance Measurement out-of-band response Cisco Systems Sagar Soni 2014-02-20
6634 tcp Reserved
6635 tcp Reserved
mpls-udp 6635 udp Encapsulate MPLS packets in UDP tunnels. IESG IETF Chair 2015-02-10 RFC 7510
6636 tcp Reserved
mpls-udp-dtls 6636 udp Encapsulate MPLS packets in UDP tunnels with DTLS. IESG IETF Chair 2015-02-10 RFC 7510
6637-6639 Unassigned
rome 7663 tcp Proprietary immutable distributed data storage TFOR David von Vistauxx 2018-02-07
rome 7663 udp Proprietary immutable distributed data storage TFOR David von Vistauxx 2018-02-07

Contact Information

Name Organization Contact URI Last Updated
Cisco smkumar&cisco.com 2012-06-11
Cisco Systems sagsoni&cisco.com 2014-02-20
David von Vistauxx vistauxx&tfor.infrastructuresecurity.com 2018-02-07
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
John Border border&hns.com 2003-01
Marc-Andre Lemburg mal&egenix.com 2009-11-13
Pedro Alpedrinha pedro.alpedrinha&redevirtual.com 2006-02
Sagar Soni Cisco Systems sagsoni&cisco.com 2014-02-20
Sam Osa pristine&mailcity.com
Surendra Kumar Cisco smkumar&cisco.com 2012-06-11
TFOR vistauxx&tfor.infrastructuresecurity.com 2018-02-07