Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| sun-dr | 665 | tcp | Sun DR | Harinder Bhasin | Harinder Bhasin | ||||||
| sun-dr | 665 | udp | Sun DR | Harinder Bhasin | Harinder Bhasin | ||||||
| netview-aix-5 | 1665 | tcp | netview-aix-5 | ||||||||
| netview-aix-5 | 1665 | udp | netview-aix-5 | ||||||||
| nfs | 2049 | sctp | Network File System | RFC 5665 | Defined TXT keys: path=<path to mount point> | ||||||
| patrol-mq-nm | 2665 | tcp | Patrol for MQ NM | Portnoy Boxman | Portnoy Boxman | ||||||
| patrol-mq-nm | 2665 | udp | Patrol for MQ NM | Portnoy Boxman | Portnoy Boxman | ||||||
| ent-engine | 3665 | tcp | Enterprise Engine Port | Mike Delgrosso | Mike Delgrosso | 2003-01 | |||||
| ent-engine | 3665 | udp | Enterprise Engine Port | Mike Delgrosso | Mike Delgrosso | 2003-01 | |||||
| contclientms | 4665 | tcp | Container Client Message Service | Bruce Thompson | Bruce Thompson | 2006-02 | |||||
| contclientms | 4665 | udp | Container Client Message Service | Bruce Thompson | Bruce Thompson | 2006-02 | |||||
| 5647-5665 | Unassigned | ||||||||||
| 6641-6652 | Unassigned | ||||||||||
| openflow | 6653 | tcp | OpenFlow | Open Networking Foundation | Puneet Agarwal | 2013-07-18 | |||||
| openflow | 6653 | udp | OpenFlow | Open Networking Foundation | Puneet Agarwal | 2013-07-18 | |||||
| 6654 | Unassigned | ||||||||||
| pcs-sf-ui-man | 6655 | tcp | PC SOFT - Software factory UI/manager | Jerome AERTS | Jerome AERTS | 2010-11-30 | |||||
| 6655 | udp | Reserved | |||||||||
| emgmsg | 6656 | tcp | Emergency Message Control Service | Gerry Gorman | Gerry Gorman | 2010-12-06 | |||||
| 6656 | udp | Reserved | |||||||||
| 6657 | tcp | Reserved | |||||||||
| palcom-disc | 6657 | udp | PalCom Discovery | Boris Magnusson | Boris Magnusson | 2010-12-06 | |||||
| 6658-6664 | Unassigned | Unauthorized Use Known on Port 6659 | |||||||||
| ircu | 6665-6669 | tcp | IRCU | Brian Tackett | Brian Tackett | ||||||
| 6665-6669 | udp | Reserved | |||||||||
| monetra | 8665 | tcp | Monetra | Main Street Softworks Inc | Brad House | 2013-04-02 | |||||
| 8665 | udp | Reserved | |||||||||
| 9641-9665 | Unassigned | ||||||||||
| axon-tunnel | 16665 | tcp | Reliable multipath data transport for high latencies | Bridgeworks | Mihai Popa | 2014-09-26 | 2026-09-11 | ||||
| 16665 | udp | Reserved | |||||||||
| 24602-24665 | Unassigned | ||||||||||
| dnssd-srp | tcp | DNS-Based Service Discovery | IESG | IETF Chair | 2024-04-12 | 2024-09-05 | RFC 9665 | Defined TXT keys: None | |||
| dnssd-srp-tls | tcp | DNS-Based Service Discovery (TLS) | IESG | IETF Chair | 2024-04-12 | 2024-09-05 | RFC 9665 | Defined TXT keys: None |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Boris Magnusson | boris&cs.lth.se | 2010-12-06 | |
| Brad House | Main Street Softworks Inc | brad&mainstreetsoftworks.com | 2013-04-02 |
| Brian Tackett | cym&acrux.net | ||
| Bridgeworks | mihai.popa&4bridgeworks.com | 2026-09-11 | |
| Bruce Thompson | brucet&actioninformationsystems.com | 2006-02 | |
| Gerry Gorman | gerry.gorman&emclock.com | 2010-12-06 | |
| Harinder Bhasin | Harinder.Bhasin&sun.com | ||
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Jerome AERTS | info&pcsoft.fr | 2010-11-30 | |
| Main Street Softworks Inc | info&mainstreetsoftworks.com | 2013-04-02 | |
| Mihai Popa | mihai.popa&4bridgeworks.com | 2026-09-11 | |
| Mike Delgrosso | mdelgros&tripplite.com | 2003-01 | |
| Open Networking Foundation | iana&opennetworking.org | 2013-07-18 | |
| Portnoy Boxman | portnoy_boxman&bmc.com | 2005-01 | |
| Puneet Agarwal | pagarwal&broadcom.com | 2013-07-18 |