Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
meregister 669 tcp MeRegister Armin Sawusch Armin Sawusch
meregister 669 udp MeRegister Armin Sawusch Armin Sawusch
netview-aix-9 1669 tcp netview-aix-9
netview-aix-9 1669 udp netview-aix-9
toad 2669 tcp TOAD Michael Marking Michael Marking
toad 2669 udp TOAD Michael Marking Michael Marking
casanswmgmt 3669 tcp CA SAN Switch Management Emre Tunar Emre Tunar 2003-01
casanswmgmt 3669 udp CA SAN Switch Management Emre Tunar Emre Tunar 2003-01
eportcommdata 4669 tcp E-Port Data Service Robert Shaffer Robert Shaffer 2006-02
eportcommdata 4669 udp E-Port Data Service Robert Shaffer Robert Shaffer 2006-02
5667-5669 Unassigned
ircu 6665-6669 tcp IRCU Brian Tackett Brian Tackett
6665-6669 udp Reserved
cleverdetect 6690 tcp CLEVERDetect Message Service Applied Expert Systems, Inc. David Cheng 2014-12-03
6690 udp Reserved
6691-6695 Unassigned
6696 tcp Reserved
babel 6696 udp Babel Routing Protocol 2011-08-15 RFC 8966
ircs-u 6697 tcp Internet Relay Chat via TLS/SSL 2014-02-11 RFC 7194
6697 udp Reserved 2014-02-11
6698 Unassigned
6699 tcp Reserved
babel-dtls 6699 udp Babel Routing Protocol over DTLS IESG IETF Chair 2020-09-04 RFC 8968
7669-7671 Unassigned
8669-8674 Unassigned
9669-9693 Unassigned
18669-18768 Unassigned
20481-20669 Unassigned
36603-36699 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Applied Expert Systems, Inc. davec&aesclever.com 2014-12-03
Armin Sawusch armin&esd1.esd.de
Brian Tackett cym&acrux.net
David Cheng davec&aesclever.com 2010-02-01
Emre Tunar emre.tunar&ca.com 2004-11
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Michael Marking marking&tatanka.com
Robert Shaffer bob.shaffer&micmod.com 2006-02