Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-11-10
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| cimplex | 673 | tcp | CIMPLEX | Ulysses G. Smith Jr. | Ulysses G. Smith Jr. | ||||||
| cimplex | 673 | udp | CIMPLEX | Ulysses G. Smith Jr. | Ulysses G. Smith Jr. | ||||||
| proshare-mc-1 | 1673 | tcp | Intel Proshare Multicast | ||||||||
| proshare-mc-1 | 1673 | udp | Intel Proshare Multicast | ||||||||
| firstcall42 | 2673 | tcp | First Call 42 | Luke Bowen | Luke Bowen | ||||||
| firstcall42 | 2673 | udp | First Call 42 | Luke Bowen | Luke Bowen | ||||||
| mediavault-gui | 3673 | tcp | Openview Media Vault GUI | Stephen Gold | Stephen Gold | 2003-01 | |||||
| mediavault-gui | 3673 | udp | Openview Media Vault GUI | Stephen Gold | Stephen Gold | 2003-01 | |||||
| cxws | 4673 | tcp | CXWS Operations | Phil Abercrombie | Phil Abercrombie | 2005-08 | |||||
| cxws | 4673 | udp | CXWS Operations | Phil Abercrombie | Phil Abercrombie | 2005-08 | |||||
| jms | 5673 | tcp | JACL Message Server | Stuart Allen | Stuart Allen | 2002-02 | |||||
| jms | 5673 | udp | JACL Message Server | Stuart Allen | Stuart Allen | 2002-02 | |||||
| diameters | 5868 | tcp | Diameter over TLS/TCP | IESG | IETF Chair | RFC 6733 | |||||
| diameters | 5868 | sctp | Diameter over DTLS/SCTP | IESG | IETF Chair | RFC 6733 | |||||
| vision-elmd | 6673 | tcp | vision_elmd IANA assigned this well-formed service name as a replacement for "vision_elmd". |
Chris Kramer | Chris Kramer | ||||||
| vision_elmd | 6673 | tcp | vision_elmd | Chris Kramer | Chris Kramer | This entry is an alias to "vision-elmd". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| vision-elmd | 6673 | udp | vision_elmd IANA assigned this well-formed service name as a replacement for "vision_elmd". |
Chris Kramer | Chris Kramer | ||||||
| vision_elmd | 6673 | udp | vision_elmd | Chris Kramer | Chris Kramer | This entry is an alias to "vision-elmd". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| imqstomps | 7673 | tcp | iMQ STOMP Server over SSL | Amy Kang | Amy Kang | 2009-03-10 | |||||
| 7673 | udp | Reserved |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Amy Kang | amy.kang&sun.com | 2009-03-10 | |
| Chris Kramer | CKramer&gis.shl.com | ||
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Luke Bowen | leb&tfn.com | ||
| Phil Abercrombie | phil.abercrombie&appiq.com | 2005-08 | |
| Stephen Gold | 2003-01 | ||
| Stuart Allen | stuart&jacl.animats.net | 2002-02 | |
| Ulysses G. Smith Jr. | ugsmith&cesi.com |