Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-11-10

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
vpp 677 tcp Virtual Presence Protocol Klaus Wolf Klaus Wolf
vpp 677 udp Virtual Presence Protocol Klaus Wolf Klaus Wolf
groupwise 1677 tcp groupwise Brent Bradshaw Brent Bradshaw
groupwise 1677 udp groupwise Brent Bradshaw Brent Bradshaw
gadgetgate1way 2677 tcp Gadget Gate 1 Way
gadgetgate1way 2677 udp Gadget Gate 1 Way
roverlog 3677 tcp RoverLog IPC Tom Mayo Tom Mayo 2003-01
roverlog 3677 udp RoverLog IPC Tom Mayo Tom Mayo 2003-01
ieee-mih 4551 tcp MIH Services RFC 5677
ieee-mih 4551 udp MIH Services RFC 5677
bcs 4677 tcp Business Continuity Servi Siew Sim Siew Sim 2005-08
bcs 4677 udp Business Continuity Servi Siew Sim Siew Sim 2005-08
questdb2-lnchr 5677 tcp Quest Central DB2 Launchr Robert M. Mackowiak Robert M. Mackowiak 2002-02
questdb2-lnchr 5677 udp Quest Central DB2 Launchr Robert M. Mackowiak Robert M. Mackowiak 2002-02
dccp-udp 6511 udp Datagram Congestion Control Protocol Encapsulation for NAT Traversal IESG IETF Chair RFC 6773
6674-6677 Unassigned
plysrv-http 6770 tcp PolyServe http Mike Spitzer Mike Spitzer 2005-08
plysrv-http 6770 udp PolyServe http Mike Spitzer Mike Spitzer 2005-08
plysrv-https 6771 tcp PolyServe https Mike Spitzer Mike Spitzer 2005-08
plysrv-https 6771 udp PolyServe https Mike Spitzer Mike Spitzer 2005-08
6772-6776 Unassigned
ntz-tracker 6777 tcp netTsunami Tracker Tomahawk Holdings Ltd Sagara Wijetunga 2013-05-01
6777 udp Reserved
ntz-p2p-storage 6778 tcp netTsunami p2p storage system Tomahawk Holdings Ltd Sagara Wijetunga 2013-05-01
6778 udp Reserved
6779-6783 Unassigned
sun-user-https 7677 tcp Sun App Server - HTTPS Abhijit Kumar Abhijit Kumar 2005-11
sun-user-https 7677 udp Sun App Server - HTTPS Abhijit Kumar Abhijit Kumar 2005-11
flashfiler 24677 tcp FlashFiler Ben Oram Ben Oram
flashfiler 24677 udp FlashFiler Ben Oram Ben Oram
45515-45677 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Abhijit Kumar as-iana-ports&sun.com 2005-11
Ben Oram beno&turbopower.com
Brent Bradshaw bbradshaw&novell.com
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Klaus Wolf wolf&cobrow.com
Mike Spitzer mjs&polyserve.com 2005-08
Robert M. Mackowiak rmackowiak&quest.com 2002-02
Sagara Wijetunga Tomahawk Holdings Ltd sagara&tomahawk.lk 2013-05-01
Siew Sim ssim&asempra.com 2005-08
Tom Mayo tmayo1&rochester.rr.com 2003-01
Tomahawk Holdings Ltd sagara&tomahawk.lk 2013-05-01