Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-11-10

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
ggf-ncp 678 tcp GNU Generation Foundation NCP Noah Paul Noah Paul
ggf-ncp 678 udp GNU Generation Foundation NCP Noah Paul Noah Paul
prolink 1678 tcp prolink Brian Abramson Brian Abramson
prolink 1678 udp prolink Brian Abramson Brian Abramson
gadgetgate2way 2678 tcp Gadget Gate 2 Way Matt Rollins Matt Rollins
gadgetgate2way 2678 udp Gadget Gate 2 Way Matt Rollins Matt Rollins
ipr-dglt 3678 tcp DataGuardianLT Bruce Carlson Bruce Carlson 2003-01
ipr-dglt 3678 udp DataGuardianLT Bruce Carlson Bruce Carlson 2003-01
traversal 4678 tcp boundary traversal Kevin Lu Kevin Lu 2005-08
traversal 4678 udp boundary traversal Kevin Lu Kevin Lu 2005-08
rrac 5678 tcp Remote Replication Agent Connection
rrac 5678 udp Remote Replication Agent Connection
vfbp 6678 tcp Viscount Freedom Bridge Protocol Chris MacDonald Chris MacDonald 2011-03-16
vfbp-disc 6678 udp Viscount Freedom Bridge Discovery Chris MacDonald Chris MacDonald 2011-03-16
6779-6783 Unassigned
6784 tcp Reserved
bfd-lag 6784 udp Bidirectional Forwarding Detection (BFD) on Link Aggregation Group (LAG) Interfaces IESG IETF BFD Working Group Chairs 2012-11-08 2014-01-09 RFC 7130
dgpf-exchg 6785 tcp DGPF Individual Exchange Thomas Weise Thomas Weise 2006-04
dgpf-exchg 6785 udp DGPF Individual Exchange Thomas Weise Thomas Weise 2006-04
smc-jmx 6786 tcp Sun Java Web Console JMX Bill Edwards Bill Edwards 2005-08
smc-jmx 6786 udp Sun Java Web Console JMX Bill Edwards Bill Edwards 2005-08
smc-admin 6787 tcp Sun Web Console Admin Bill Edwards Bill Edwards 2005-08
smc-admin 6787 udp Sun Web Console Admin Bill Edwards Bill Edwards 2005-08
smc-http 6788 tcp SMC-HTTP Ratnadeep Bhattacharjee Ratnadeep Bhattacharjee 2002-11
smc-http 6788 udp SMC-HTTP Ratnadeep Bhattacharjee Ratnadeep Bhattacharjee 2002-11
radg 6789 tcp GSS-API for the Oracle Remote Administration Daemon Oracle Shawn Emery 2002-08 2016-09-15
6789 udp Reserved 2002-08 2016-09-15
7678-7679 Unassigned
16667-16788 Unassigned
cadsisvr 16789 tcp This server provides callable services to mainframe External Security Managers from any TCP/IP platform Broadcom Thomas Sakowski 2015-06-02 2023-03-29
16789 udp Reserved
proactivate 24678 tcp Turbopower Proactivate Ben Oram Ben Oram
proactivate 24678 udp Turbopower Proactivate Ben Oram Ben Oram
eba 45678 tcp EBA PRISE Patrick Kara Patrick Kara
eba 45678 udp EBA PRISE Patrick Kara Patrick Kara

Contact Information

Name Organization Contact URI Last Updated
Ben Oram beno&turbopower.com
IETF BFD Working Group Chairs bfd-chairs&tools.ietf.org 2014-01-09
Bill Edwards bill.edwards&sun.com 2005-08
Brian Abramson brianab&soul.tv.tek.com
Broadcom thomas.sakowski&broadcom.com 2023-03-29
Bruce Carlson bruce.carlson&iprintl.com 2003-01
Chris MacDonald chris&viscount.com 2011-03-16
IESG iesg&ietf.org
Kevin Lu kevinlu&micromethod.com 2005-08
Matt Rollins matt&anybusiness.com
Noah Paul noahp&altavista.net
Oracle shawn.emery&oracle.com 2016-09-15
Patrick Kara Patrick&eba.net
Ratnadeep Bhattacharjee ratnadeep.bhattacharjee&sun.com 2002-11
Shawn Emery shawn.emery&oracle.com 2016-09-15
Thomas Sakowski Broadcom thomas.sakowski&broadcom.com 2023-03-29
Thomas Weise weise&vs.uni-kassel.de 2006-04