Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
hyperwave-isp 692 tcp Hyperwave-ISP Gerald Mesaric Gerald Mesaric
hyperwave-isp 692 udp Hyperwave-ISP Gerald Mesaric Gerald Mesaric
rift-lies 914 udp Routing in Fat Trees Link Information Element IESG IETF Chair 2023-02-17 2024-06-07 RFC 9692
rift-ties 915 udp Routing in Fat Trees Topology Information Element IESG IETF Chair 2023-02-17 2024-06-07 RFC 9692
exp1 1021 tcp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp1 1021 udp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp1 1021 sctp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp1 1021 dccp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp2 1022 tcp RFC3692-style Experiment 2 IESG IETF Chair [1]RFC 4727; RFC 6335
exp2 1022 udp RFC3692-style Experiment 2 IESG IETF Chair [1]RFC 4727; RFC 6335
exp2 1022 sctp RFC3692-style Experiment 2 IESG IETF Chair [1]RFC 4727; RFC 6335
exp2 1022 dccp RFC3692-style Experiment 2 IESG IETF Chair [1]RFC 4727; RFC 6335
sstsys-lm 1692 tcp sstsys-lm Yih-Wu Wang Yih-Wu Wang
sstsys-lm 1692 udp sstsys-lm Yih-Wu Wang Yih-Wu Wang
admins-lms 2692 tcp Admins LMS Dagfinn Saether Dagfinn Saether
admins-lms 2692 udp Admins LMS Dagfinn Saether Dagfinn Saether
intelsync 3692 tcp Brimstone IntelSync Davey Taylor Davey Taylor 2003-02
intelsync 3692 udp Brimstone IntelSync Davey Taylor Davey Taylor 2003-02
conspiracy 4692 tcp Conspiracy messaging Jens Edlund Jens Edlund 2005-08
conspiracy 4692 udp Conspiracy messaging Jens Edlund Jens Edlund 2005-08
5690-5692 Unassigned
6902-6923 Unassigned
split-ping 6924 tcp Ping with RX/TX latency/loss split Ben Cartwright-Cox Ben Cartwright-Cox 2020-02-12
split-ping 6924 udp Ping with RX/TX latency/loss split Ben Cartwright-Cox Ben Cartwright-Cox 2020-02-12
6925-6934 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Ben Cartwright-Cox ben&benjojo.co.uk 2020-02-12
Dagfinn Saether Dagfinn&admins.com
Davey Taylor davey.taylor&brimstone.net 2003-02
Gerald Mesaric gmesaric&hyperwave.com
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jens Edlund edlund&speech.kth.se 2005-08
Yih-Wu Wang sstsys&ix.netcom.com