Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
ieee-mms-ssl 695 tcp IEEE-MMS-SSL Curtis Anderson Curtis Anderson
ieee-mms-ssl 695 udp IEEE-MMS-SSL Curtis Anderson Curtis Anderson
rrilwm 1695 tcp rrilwm
rrilwm 1695 udp rrilwm
vspread 2695 tcp VSPREAD Sumitake kobayashi Sumitake kobayashi
vspread 2695 udp VSPREAD Sumitake kobayashi Sumitake kobayashi
bmc-data-coll 3695 tcp BMC Data Collection Portnoy Boxman Portnoy Boxman 2003-02
bmc-data-coll 3695 udp BMC Data Collection Portnoy Boxman Portnoy Boxman 2003-02
5694-5695 Unassigned
6691-6695 Unassigned
6947-6950 Unassigned
otlp 6951 tcp OTLP Brent Foster Brent Foster 2006-04
otlp 6951 udp OTLP Brent Foster Brent Foster 2006-04
6952-6960 Unassigned
ccnx 9695 tcp Content Centric Networking Van Jacobson; Simon Barber Van Jacobson; Simon Barber 2009-09-29
ccnx 9695 udp Content Centric Networking Van Jacobson; Simon Barber Van Jacobson; Simon Barber 2009-09-29
sctp-tunneling 9899 udp SCTP TUNNELING IESG IETF Chair 2013-04-10 RFC 6951
sgcip 16950 tcp Simple Generic Client Interface Protocol John Aquilino John Aquilino
sgcip 16950 udp Simple Generic Client Interface Protocol John Aquilino John Aquilino
16951-16990 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Brent Foster brent.foster&onstreamsystems.com 2006-04
Curtis Anderson ecanderson&turbolinux.com
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
John Aquilino john.aquilino&maryville.com
Portnoy Boxman portnoy_boxman&bmc.com 2005-01
Simon Barber simon.barber&parc.com 2009-09-29
Sumitake kobayashi kobayashi&np.lps.cs.fujitsu.co.jp
Van Jacobson van&parc.com 2009-09-29