Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
epp 700 tcp Extensible Provisioning Protocol RFC 5734
epp 700 udp EPP running over QUIC IESG IETF Chair 2026-07-23 RFC 5734; RFC-ietf-regext-epp-quic-12
mil-2045-47001 1581 tcp MIL-2045-47001 Eric Whitehill Eric Whitehill
mil-2045-47001 1581 udp MIL-2045-47001 Eric Whitehill Eric Whitehill
mps-raft 1700 tcp mps-raft Jason Leupen Jason Leupen
mps-raft 1700 udp mps-raft Jason Leupen Jason Leupen
tqdata 2700 tcp tqdata Al Guetzlaff Al Guetzlaff
tqdata 2700 udp tqdata Al Guetzlaff Al Guetzlaff
lrs-paging 3700 tcp LRS NetPage Geoffrey Wossum Geoffrey Wossum 2003-02
lrs-paging 3700 udp LRS NetPage Geoffrey Wossum Geoffrey Wossum 2003-02
netxms-agent 4700 tcp NetXMS Agent
netxms-agent 4700 udp NetXMS Agent
supportassist 5700 tcp Dell SupportAssist data center management Dell Technologies Rohitdev Kulshrestha 2016-07-05
5700 udp Reserved
6700 Unassigned 2010-01-26
afs3-fileserver 7000 tcp file server itself
afs3-fileserver 7000 udp file server itself
afs3-callback 7001 tcp callbacks to cache managers Known Unauthorized Use on port 7001
afs3-callback 7001 udp callbacks to cache managers Known Unauthorized Use on port 7001
afs3-prserver 7002 tcp users & groups database Known Unauthorized Use on port 7002
afs3-prserver 7002 udp users & groups database Known Unauthorized Use on port 7002
afs3-vlserver 7003 tcp volume location database
afs3-vlserver 7003 udp volume location database
afs3-kaserver 7004 tcp AFS/Kerberos authentication service
afs3-kaserver 7004 udp AFS/Kerberos authentication service
afs3-volser 7005 tcp volume managment server Known Unauthorized Use on port 7005
afs3-volser 7005 udp volume managment server Known Unauthorized Use on port 7005
afs3-errors 7006 tcp error interpretation service
afs3-errors 7006 udp error interpretation service
afs3-bos 7007 tcp basic overseer process
afs3-bos 7007 udp basic overseer process
afs3-update 7008 tcp server-to-server updater
afs3-update 7008 udp server-to-server updater
afs3-rmtsys 7009 tcp remote cache manager service
afs3-rmtsys 7009 udp remote cache manager service
em7-secom 7700 tcp EM7 Secure Communications Christopher Cordray Christopher Cordray 2008-06-05
7700 udp Reserved
8700-8709 Unassigned
board-roar 9700 tcp Board M.I.T. Service Francesco Rosi Francesco Rosi 2006-01
board-roar 9700 udp Board M.I.T. Service Francesco Rosi Francesco Rosi 2006-01
16996-17006 Unassigned
isode-dua 17007 tcp
isode-dua 17007 udp
17008-17009 Unassigned
flex-lm 27000-27009 FLEX LM (1-10) Flexera Software Paul Bland 2018-02-15
mapx 36700 tcp MapX communication MicroTechniX Yarochkin Michail 2014-10-13
36700 udp Reserved
mbus 47000 tcp Message Bus Dirk Kutscher Dirk Kutscher
mbus 47000 udp Message Bus Dirk Kutscher Dirk Kutscher
winrm 47001 tcp Windows Remote Management Service Ryan Mack Ryan Mack 2009-04-29
47001 udp Reserved
47002-47099 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Al Guetzlaff aeg&teamquest.com
Christopher Cordray ccordray&sciencelogic.com 2008-06-05
Dell Technologies rohitdev_kulshrestha&dell.com 2016-07-05
Dirk Kutscher dku&informatik.uni-bremen.de
Eric Whitehill Eric.Whitehill&itt.com
Flexera Software security&flexerasoftware.com 2016-07-19
Francesco Rosi frosi&orenburg.com 2006-01
Geoffrey Wossum geoffrey&pager.net 2003-02
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jason Leupen Jleupen&aol.com
MicroTechniX Info&microtechnix.com 2014-10-13
Paul Bland pbland&flexera.com 2018-08-22
Rohitdev Kulshrestha rohitdev_kulshrestha&dell.com 2016-07-05
Ryan Mack rmack&microsoft.com 2009-04-29
Yarochkin Michail MicroTechniX Michail.Yarochkin&microtechnix.com 2014-10-13