Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| entrust-ash | 710 | tcp | Entrust Administration Service Handler | Peter Whittaker | Peter Whittaker | ||||||
| entrust-ash | 710 | udp | Entrust Administration Service Handler | Peter Whittaker | Peter Whittaker | ||||||
| ltp-deepspace | 1113 | dccp | Licklider Transmission Protocol | 2013-11-12 | 2014-02-21 | RFC 7122 | 7107696 | ||||
| impera | 1710 | tcp | impera | Stepehen Campbell | Stepehen Campbell | ||||||
| impera | 1710 | udp | impera | Stepehen Campbell | Stepehen Campbell | ||||||
| sso-service | 2710 | tcp | SSO Service | ||||||||
| sso-service | 2710 | udp | SSO Service | ||||||||
| portgate-auth | 3710 | tcp | PortGate Authentication | Scott Harris | Scott Harris | 2003-02 | |||||
| portgate-auth | 3710 | udp | PortGate Authentication | Scott Harris | Scott Harris | 2003-02 | |||||
| 4705-4710 | Unassigned | ||||||||||
| font-service | 7100 | tcp | X Font Service | Stephen Gildea | Stephen Gildea | ||||||
| font-service | 7100 | udp | X Font Service | Stephen Gildea | Stephen Gildea | ||||||
| elcn | 7101 | tcp | Embedded Light Control Network | Michael Scarito | Michael Scarito | 2007-02 | |||||
| elcn | 7101 | udp | Embedded Light Control Network | Michael Scarito | Michael Scarito | 2007-02 | |||||
| 7102-7106 | Unassigned | ||||||||||
| 7107 | tcp | Reserved | |||||||||
| aes-x170 | 7107 | udp | AES-X170 | Richard Foss | Richard Foss | 2011-02-10 | |||||
| 7108-7116 | Unassigned | ||||||||||
| semi-grpc | 8710 | tcp | gRPC for SEMI Standards implementations | SEMI | Albert Fuchigami | 2020-01-10 | |||||
| 8710 | udp | Reserved | |||||||||
| jvl-mactalk | 47100 | udp | Configuration of motors connected to Industrial Ethernet | JVL Industri Elektronik | Kim Berthelsen | 2012-12-21 | |||||
| 47100 | tcp | Reserved | |||||||||
| 47101-47556 | Unassigned |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Albert Fuchigami | albert.fuchigami&peergroup.com | 2020-01-10 | |
| JVL Industri Elektronik | jvl&jvl.dk | 2012-12-21 | |
| Kim Berthelsen | JVL Industri Elektronik | kb&jvl.dk | 2012-12-21 |
| Michael Scarito | ms&mit.edu | 2007-02 | |
| Peter Whittaker | pww&entrust.com | ||
| Richard Foss | r.foss&ru.ac.za | 2011-02-10 | |
| Scott Harris | Scott&xramp.com | 2003-02 | |
| SEMI | jamano&semi.org | 2020-01-10 | |
| Stepehen Campbell | campbell&uniprise.com | ||
| Stephen Gildea | gildea&lcs.mit.edu |