Service Name and Transport Protocol Port Number Registry

Last Updated
2026-10-09
Expert(s)
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell,
and Michael Scharf
SCTP: Michael Tuexen
DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
[RFC 6335]
Note
Service names and port numbers are used to distinguish between different
services that run over transport protocols such as TCP, UDP, DCCP, and
SCTP.

Service names are assigned on a first-come, first-served process, as
documented in [RFC 6335].

Port numbers are assigned in various ways, based on three ranges: System
Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private
Ports (49152-65535); the different uses of these ranges are described in
[RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are 
assigned by the "IETF Review" or "IESG Approval" procedures described in 
[RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, 
the "IESG Approval" process, or the "Expert Review" process, as per 
[RFC 6335]. Dynamic Ports are not assigned.

The registration procedures for service names and port numbers are
described in [RFC 6335].

Assigned ports both System and User ports SHOULD NOT be used without
or prior to IANA registration.

************************************************************************
* PLEASE NOTE THE FOLLOWING:                                           *
*                                                                      *
* ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN             *
* ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK  *
* TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT   *
* IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE     *
* ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD          *
* CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF    *
* THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER          *
* REGISTERED OR NOT.                                                   *
************************************************************************

Request an Assignment
  [https://www.iana.org/protocols/apply]

Available Formats

CSV

XML

HTML

TXT
Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
con 759 tcp
con 759 udp
spss-lm 1759 tcp SPSS License Manager [Tex_Hull] [Tex_Hull]
spss-lm 1759 udp SPSS License Manager [Tex_Hull] [Tex_Hull]
apollo-gms 2759 tcp APOLLO GMS [Simon_Hovell] [Simon_Hovell]
apollo-gms 2759 udp APOLLO GMS [Simon_Hovell] [Simon_Hovell]
exapt-lmgr 3759 tcp Exapt License Manager [Christoph_Kukulies] [Christoph_Kukulies] 2003-04
exapt-lmgr 3759 udp Exapt License Manager [Christoph_Kukulies] [Christoph_Kukulies] 2003-04
wot tcp W3C WoT Thing Description or Directory [W3C_Web_of_Things_Working_Group] [Kazuyuki_Ashimura] 2022-11-22 2022-12-15

Defined TXT keys:

td: Absolute pathname of the Thing Description of the Thing or Thing Description of the Thing Description Directory.

type: Type of the Thing Description, i.e. "Thing" or "Directory". If omitted, the type is assumed to be Thing.

scheme: Scheme part of URL. One of the following values can be specified, with the standard registered URI interpretations [RFC7595]: http (HTTP over TCP),https (HTTP over TLS/TCP), coap+tcp (CoAP over TCP), or coaps+tcp (CoAP over TLS/TCP). If omitted, the scheme is assumed to be http.

wot udp W3C WoT Thing Description or Directory [W3C_Web_of_Things_Working_Group] [Kazuyuki_Ashimura] 2022-11-22 2022-12-15

Defined TXT keys:

td: Absolute pathname of the Thing Description of the Thing or Thing Description of the Thing Description Directory.

type: Type of the Thing Description, i.e. "Thing" or "Directory". If omitted, the type is assumed to be Thing.

scheme: Scheme part of URL. One of the following values can be specified, with the standard registered URI interpretations [RFC7595]: coap (CoAP over UDP), coaps CoAP over DTLS/UDP. If omitted, the scheme is assumed to be coap.

Contact Information

ID Name Organization Contact URI Last Updated
[Christoph_Kukulies] Christoph Kukulies mailto:info&exapt.de 2003-04
[Kazuyuki_Ashimura] Kazuyuki Ashimura mailto:ashimura&w3.org 2022-11-22
[Simon_Hovell] Simon Hovell mailto:simonh&brandcomms.com
[Tex_Hull] Tex Hull mailto:tex&spss.com
[W3C_Web_of_Things_Working_Group] W3C Web of Things Working Group mailto:team-wot&w3.org 2022-11-22