Service Name and Transport Protocol Port Number Registry

Last Updated
2026-10-09
Expert(s)
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell,
and Michael Scharf
SCTP: Michael Tuexen
DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
[RFC 6335]
Note
Service names and port numbers are used to distinguish between different
services that run over transport protocols such as TCP, UDP, DCCP, and
SCTP.

Service names are assigned on a first-come, first-served process, as
documented in [RFC 6335].

Port numbers are assigned in various ways, based on three ranges: System
Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private
Ports (49152-65535); the different uses of these ranges are described in
[RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are 
assigned by the "IETF Review" or "IESG Approval" procedures described in 
[RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, 
the "IESG Approval" process, or the "Expert Review" process, as per 
[RFC 6335]. Dynamic Ports are not assigned.

The registration procedures for service names and port numbers are
described in [RFC 6335].

Assigned ports both System and User ports SHOULD NOT be used without
or prior to IANA registration.

************************************************************************
* PLEASE NOTE THE FOLLOWING:                                           *
*                                                                      *
* ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN             *
* ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK  *
* TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT   *
* IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE     *
* ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD          *
* CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF    *
* THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER          *
* REGISTERED OR NOT.                                                   *
************************************************************************

Request an Assignment
  [https://www.iana.org/protocols/apply]

Available Formats

CSV

XML

HTML

TXT
Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
quotad 762 tcp
quotad 762 udp
cft-1 1762 tcp cft-1 [Martine_Marchand] [Martine_Marchand]
cft-1 1762 udp cft-1 [Martine_Marchand] [Martine_Marchand]
dicom-tls 2762 tcp DICOM TLS [Lawrence_Tarbox] [Lawrence_Tarbox]
dicom-tls 2762 udp DICOM TLS [Lawrence_Tarbox] [Lawrence_Tarbox]
gbs-smp 3762 tcp GBS SnapMail Protocol [Eric_Harris_Braun] [Eric_Harris_Braun] 2003-06
gbs-smp 3762 udp GBS SnapMail Protocol [Eric_Harris_Braun] [Eric_Harris_Braun] 2003-06
avt-profile-1 5004 dccp RTP media data [RFC 3551][RFC 5762]
avt-profile-2 5005 dccp RTP control protocol [RFC 3551][RFC 5762]
mdns 5353 tcp Multicast DNS [IESG] [IETF_Chair] [RFC 6762]
mdns 5353 udp Multicast DNS [IESG] [IETF_Chair] [RFC 6762]
7607-7623 Unassigned
indi 7624 tcp Instrument Neutral Distributed Interface [Elwood_Downey] [Elwood_Downey] 2002-04
indi 7624 udp Instrument Neutral Distributed Interface [Elwood_Downey] [Elwood_Downey] 2002-04
7625 Unassigned
simco 7626 tcp SImple Middlebox COnfiguration (SIMCO) Server [RFC 4540]
7626 udp De-registered 2006-01-30
simco 7626 sctp SImple Middlebox COnfiguration (SIMCO) [Sebastian_Kiesel] [Sebastian_Kiesel] 2006-01
soap-http 7627 tcp SOAP Service Port [Donald_Dylla] [Donald_Dylla] 2004-12
soap-http 7627 udp SOAP Service Port [Donald_Dylla] [Donald_Dylla] 2004-12
zen-pawn 7628 tcp Primary Agent Work Notification [Ty_Ellis] [Ty_Ellis] 2006-05
zen-pawn 7628 udp Primary Agent Work Notification [Ty_Ellis] [Ty_Ellis] 2006-05
xdas 7629 tcp OpenXDAS Wire Protocol [John_Calcote_2] [John_Calcote_2] 2006-10
xdas 7629 udp OpenXDAS Wire Protocol [John_Calcote_2] [John_Calcote_2] 2006-10
8751-8762 Unassigned
tungsten-http 9762 tcp WSO2 Tungsten HTTP [Afkham_Azeez] [Afkham_Azeez] 2006-06
tungsten-http 9762 udp WSO2 Tungsten HTTP [Afkham_Azeez] [Afkham_Azeez] 2006-06
22556-22762 Unassigned
47558-47623 Unassigned
directplaysrvr 47624 tcp Direct Play Server [Ajay_Jindal] [Ajay_Jindal]
directplaysrvr 47624 udp Direct Play Server [Ajay_Jindal] [Ajay_Jindal]
47625-47805 Unassigned

Contact Information

ID Name Organization Contact URI Last Updated
[Afkham_Azeez] Afkham Azeez mailto:azeez&wso2.com 2006-06
[Ajay_Jindal] Ajay Jindal mailto:ajayj&microsoft.com
[Donald_Dylla] Donald Dylla mailto:donald.dylla&hp.com 2004-12
[Elwood_Downey] Elwood Downey mailto:ecdowney&clearskyinstitute.com 2002-04
[Eric_Harris_Braun] Eric Harris-Braun mailto:eric&glassbead.com 2003-06
[IESG] IESG mailto:iesg&ietf.org
[IETF_Chair] IETF Chair IETF mailto:chair&ietf.org
[John_Calcote_2] John Calcote mailto:jcalcote&novell.com 2006-10
[Lawrence_Tarbox] Lawrence Tarbox mailto:ltarbox&scr.siemens.com
[Martine_Marchand] Martine Marchand tel:+16-1-46-59-24-84
[Sebastian_Kiesel] Sebastian Kiesel mailto:kiesel&ikr.uni-stuttgart.de 2006-01
[Ty_Ellis] Ty Ellis mailto:tellis&novell.com 2006-05