Service Name and Transport Protocol Port Number Registry
- Last Updated
- 2026-10-09
- Expert(s)
-
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf SCTP: Michael Tuexen DCCP: Eddie Kohler and Yoshifumi Nishida
- Reference
- [RFC 6335]
- Note
-
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP. Service names are assigned on a first-come, first-served process, as documented in [RFC 6335]. Port numbers are assigned in various ways, based on three ranges: System Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private Ports (49152-65535); the different uses of these ranges are described in [RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are assigned by the "IETF Review" or "IESG Approval" procedures described in [RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, the "IESG Approval" process, or the "Expert Review" process, as per [RFC 6335]. Dynamic Ports are not assigned. The registration procedures for service names and port numbers are described in [RFC 6335]. Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration. ************************************************************************ * PLEASE NOTE THE FOLLOWING: * * * * ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN * * ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK * * TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT * * IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE * * ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD * * CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF * * THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER * * REGISTERED OR NOT. * ************************************************************************
- Request an Assignment
-
[https://www.iana.org/protocols/apply]
- Available Formats
-

CSV
XML
HTML
TXT
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| omserv | 764 | tcp | |||||||||
| omserv | 764 | udp | |||||||||
| cft-3 | 1764 | tcp | cft-3 | [Martine_Marchand] | [Martine_Marchand] | ||||||
| cft-3 | 1764 | udp | cft-3 | [Martine_Marchand] | [Martine_Marchand] | ||||||
| data-insurance | 2764 | tcp | Data Insurance | [Brent_Irwin] | [Brent_Irwin] | ||||||
| data-insurance | 2764 | udp | Data Insurance | [Brent_Irwin] | [Brent_Irwin] | ||||||
| mni-prot-rout | 3764 | tcp | MNI Protected Routing | [Tim_Behne] | [Tim_Behne] | 2003-06 | |||||
| mni-prot-rout | 3764 | udp | MNI Protected Routing | [Tim_Behne] | [Tim_Behne] | 2003-06 | |||||
| dns-llq | 5352 | tcp | DNS Long-Lived Queries | [Stuart_Cheshire] | [Stuart_Cheshire] | 2005-08 | 2019-08-26 | [RFC 8764] | |||
| dns-llq | 5352 | udp | DNS Long-Lived Queries | [Stuart_Cheshire] | [Stuart_Cheshire] | 2005-08 | 2019-08-26 | [RFC 8764] | |||
| 7634-7647 | Unassigned | ||||||||||
| cuseeme | 7648 | tcp | bonjour-cuseeme | [Marc_Manthey] | [Marc_Manthey] | 2006-07 | |||||
| cuseeme | 7648 | udp | bonjour-cuseeme | [Marc_Manthey] | [Marc_Manthey] | 2006-07 | |||||
| 7649-7662 | Unassigned | ||||||||||
| openqueue | 8764 | tcp | OPENQUEUE | [Matt_Jensen] | [Matt_Jensen] | ||||||
| openqueue | 8764 | udp | OPENQUEUE | [Matt_Jensen] | [Matt_Jensen] | ||||||
| 22764-22799 | Unassigned | ||||||||||
| 31686-31764 | Unassigned | ||||||||||
| caldav | tcp | Calendaring Extensions to WebDAV (CalDAV) - non-TLS | [IESG] | [IETF_Chair] | 2012-02-17 | [RFC 6764] | This is an extension of the http service. Defined TXT keys: path=<context path> | ||||
| caldavs | tcp | Calendaring Extensions to WebDAV (CalDAV) - over TLS | [IESG] | [IETF_Chair] | 2012-02-17 | [RFC 6764] | This is an extension of the https service. Defined TXT keys: path=<context path> |
Contact Information
| ID | Name | Organization | Contact URI | Last Updated |
|---|---|---|---|---|
| [Brent_Irwin] | Brent Irwin | mailto:birwin&standard.com | ||
| [IESG] | IESG | mailto:iesg&ietf.org | ||
| [IETF_Chair] | IETF Chair | IETF | mailto:chair&ietf.org | |
| [Marc_Manthey] | Marc Manthey | mailto:codewarrior&cuseeme.de | 2006-07 | |
| [Martine_Marchand] | Martine Marchand | tel:+16-1-46-59-24-84 | ||
| [Matt_Jensen] | Matt Jensen | mailto:mattj&newsblip.com | ||
| [Stuart_Cheshire] | Stuart Cheshire | mailto:cheshire&apple.com | 2022-07-11 | |
| [Tim_Behne] | Tim Behne | mailto:timothybµwavenetworks.com | 2003-06 |