Service Name and Transport Protocol Port Number Registry

Last Updated
2026-10-09
Expert(s)
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell,
and Michael Scharf
SCTP: Michael Tuexen
DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
[RFC 6335]
Note
Service names and port numbers are used to distinguish between different
services that run over transport protocols such as TCP, UDP, DCCP, and
SCTP.

Service names are assigned on a first-come, first-served process, as
documented in [RFC 6335].

Port numbers are assigned in various ways, based on three ranges: System
Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private
Ports (49152-65535); the different uses of these ranges are described in
[RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are 
assigned by the "IETF Review" or "IESG Approval" procedures described in 
[RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, 
the "IESG Approval" process, or the "Expert Review" process, as per 
[RFC 6335]. Dynamic Ports are not assigned.

The registration procedures for service names and port numbers are
described in [RFC 6335].

Assigned ports both System and User ports SHOULD NOT be used without
or prior to IANA registration.

************************************************************************
* PLEASE NOTE THE FOLLOWING:                                           *
*                                                                      *
* ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN             *
* ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK  *
* TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT   *
* IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE     *
* ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD          *
* CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF    *
* THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER          *
* REGISTERED OR NOT.                                                   *
************************************************************************

Request an Assignment
  [https://www.iana.org/protocols/apply]

Available Formats

CSV

XML

HTML

TXT
Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
vid 769 tcp
vid 769 udp
ltp-deepspace 1113 dccp Licklider Transmission Protocol 2013-11-12 2014-02-21 [RFC 7122] 7107696
bmc-net-adm 1769 tcp bmc-net-adm [Portnoy_Boxman] [Portnoy_Boxman]
bmc-net-adm 1769 udp bmc-net-adm [Portnoy_Boxman] [Portnoy_Boxman]
exce 2769 tcp eXcE [Norm_Freedman] [Norm_Freedman]
exce 2769 udp eXcE [Norm_Freedman] [Norm_Freedman]
haipe-otnk 3769 tcp HAIPE Network Keying [Mike_Irani_2] [Mike_Irani_2] 2003-06
haipe-otnk 3769 udp HAIPE Network Keying [Mike_Irani_2] [Mike_Irani_2] 2003-06
spramsca 5769 tcp x509solutions Internal CA [Brendan_Fay] [Brendan_Fay] 2006-02
spramsca 5769 udp x509solutions Internal CA [Brendan_Fay] [Brendan_Fay] 2006-02
adi-gxp-srvprt 6769 tcp ADInstruments GxP Server [Mathew_Pitchforth] [Mathew_Pitchforth] 2005-08
adi-gxp-srvprt 6769 udp ADInstruments GxP Server [Mathew_Pitchforth] [Mathew_Pitchforth] 2005-08
sovd 7690 tcp Service-Oriented Vehicle Diagnostics [ASAM_e_V] [Bernd_Wenzel] 2022-07-01
7690 udp Reserved
7691-7696 Unassigned
klio 7697 tcp KLIO communications [Helmut_Giritzer_2] [Helmut_Giritzer_2] 2005-08
klio 7697 udp KLIO communications [Helmut_Giritzer_2] [Helmut_Giritzer_2] 2005-08
7698-7699 Unassigned
oktaauthenticat 8769 tcp Okta MultiPlatform Access Mgmt for Cloud Svcs [Okta_Inc] [Tom_Belote] 2019-12-19
8769 udp Reserved
ique 18769 tcp IQue Protocol [Avi_Drissman] [Avi_Drissman] 2002-07
ique 18769 udp IQue Protocol [Avi_Drissman] [Avi_Drissman] 2002-07
filenet-rpc 32769 tcp Filenet RPC [Daniel_Whelan] [Daniel_Whelan]
filenet-rpc 32769 udp Filenet RPC [Daniel_Whelan] [Daniel_Whelan]

Contact Information

ID Name Organization Contact URI Last Updated
[ASAM_e_V] ASAM e.V. mailto:marius.dupuis&asam.net 2022-07-01
[Avi_Drissman] Avi Drissman mailto:ique-protocol&harrisbaseview.com 2002-07
[Bernd_Wenzel] Bernd Wenzel ASAM e.V. mailto:bernd.wenzel&asam.net 2022-07-01
[Brendan_Fay] Brendan Fay mailto:brendan.fay&x509solutions.com 2006-02
[Daniel_Whelan] Daniel Whelan mailto:dwhelan&filenet.com
[Helmut_Giritzer_2] Helmut Giritzer mailto:helmut.giritzer&o.roteskreuz.at 2005-08
[Mathew_Pitchforth] Mathew Pitchforth mailto:mathew&adinstruments.co.nz 2005-08
[Mike_Irani_2] Mike Irani mailto:irani&spawar.navy.mil 2003-06
[Norm_Freedman] Norm Freedman mailto:normfree&san.rr.com 2003-08
[Okta_Inc] Okta Inc mailto:tbelote&okta.com 2019-12-19
[Portnoy_Boxman] Portnoy Boxman mailto:portnoy_boxman&bmc.com 2005-01
[Tom_Belote] Tom Belote mailto:tbelote&okta.com 2019-12-19