Service Name and Transport Protocol Port Number Registry
- Last Updated
- 2026-10-09
- Expert(s)
-
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf SCTP: Michael Tuexen DCCP: Eddie Kohler and Yoshifumi Nishida
- Reference
- [RFC 6335]
- Note
-
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP. Service names are assigned on a first-come, first-served process, as documented in [RFC 6335]. Port numbers are assigned in various ways, based on three ranges: System Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private Ports (49152-65535); the different uses of these ranges are described in [RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are assigned by the "IETF Review" or "IESG Approval" procedures described in [RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, the "IESG Approval" process, or the "Expert Review" process, as per [RFC 6335]. Dynamic Ports are not assigned. The registration procedures for service names and port numbers are described in [RFC 6335]. Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration. ************************************************************************ * PLEASE NOTE THE FOLLOWING: * * * * ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN * * ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK * * TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT * * IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE * * ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD * * CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF * * THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER * * REGISTERED OR NOT. * ************************************************************************
- Request an Assignment
-
[https://www.iana.org/protocols/apply]
- Available Formats
-

CSV
XML
HTML
TXT
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| submit | 773 | tcp | |||||||||
| notify | 773 | udp | |||||||||
| kmscontrol | 1773 | tcp | KMSControl | [Roy_Chastain] | [Roy_Chastain] | ||||||
| kmscontrol | 1773 | udp | KMSControl | [Roy_Chastain] | [Roy_Chastain] | ||||||
| rbakcup1 | 2773 | tcp | RBackup Remote Backup | ||||||||
| rbakcup1 | 2773 | udp | RBackup Remote Backup | ||||||||
| ctdhercules | 3773 | tcp | ctdhercules | [Carl_Banzhof] | [Carl_Banzhof] | 2003-06 | |||||
| ctdhercules | 3773 | udp | ctdhercules | [Carl_Banzhof] | [Carl_Banzhof] | 2003-06 | |||||
| 4757-4773 | Unassigned | ||||||||||
| dccp-udp | 6511 | udp | Datagram Congestion Control Protocol Encapsulation for NAT Traversal | [IESG] | [IETF_Chair] | [RFC 6773] | |||||
| 7729-7733 | Unassigned | ||||||||||
| smip | 7734 | tcp | Smith Protocol over IP | [Guidant_Measurement] | [Jim_Pettinato] | 2007-04 | 2024-10-08 | ||||
| smip | 7734 | udp | Smith Protocol over IP | [Guidant_Measurement] | [Jim_Pettinato] | 2007-04 | 2024-10-08 | ||||
| 7735-7737 | Unassigned | ||||||||||
| aiagent | 7738 | tcp | HP Enterprise Discovery Agent | [Matthew_Darwin] | [Matthew_Darwin] | 2005-08 | |||||
| aiagent | 7738 | udp | HP Enterprise Discovery Agent | [Matthew_Darwin] | [Matthew_Darwin] | 2005-08 | |||||
| 7739-7740 | Unassigned | ||||||||||
| 17730-17753 | Unassigned | ||||||||||
| filenet-cm | 32773 | tcp | FileNET Component Manager | [Chris_Adkins] | [Chris_Adkins] | 2003-08 | |||||
| filenet-cm | 32773 | udp | FileNET Component Manager | [Chris_Adkins] | [Chris_Adkins] | 2003-08 | |||||
| dccp-ping | dccp | ping/traceroute using DCCP | [Samuel_Jero] | [Samuel_Jero] | 2012-11-14 | 1885957735 | Defined TXT keys: None |
Contact Information
| ID | Name | Organization | Contact URI | Last Updated |
|---|---|---|---|---|
| [Carl_Banzhof] | Carl Banzhof | mailto:cbanzhof&citadel.com | 2003-06 | |
| [Chris_Adkins] | Chris Adkins | mailto:cadkins&filenet.com | 2006-10 | |
| [Guidant_Measurement] | Guidant Measurement | mailto:james.pettinato&guidantmeasurement.com | 2024-10-08 | |
| [IESG] | IESG | mailto:iesg&ietf.org | ||
| [IETF_Chair] | IETF Chair | IETF | mailto:chair&ietf.org | |
| [Jim_Pettinato] | Jim Pettinato | mailto:james.pettinato&guidantmeasurement.com | 2024-10-08 | |
| [Matthew_Darwin] | Matthew Darwin | mailto:matthew.darwin&hp.com | 2005-08 | |
| [Roy_Chastain] | Roy Chastain | mailto:roy&kmsys.com | ||
| [Samuel_Jero] | Samuel Jero | mailto:sj323707&ohio.edu | 2012-11-14 |