Service Name and Transport Protocol Port Number Registry

Last Updated
2026-10-09
Expert(s)
TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell,
and Michael Scharf
SCTP: Michael Tuexen
DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
[RFC 6335]
Note
Service names and port numbers are used to distinguish between different
services that run over transport protocols such as TCP, UDP, DCCP, and
SCTP.

Service names are assigned on a first-come, first-served process, as
documented in [RFC 6335].

Port numbers are assigned in various ways, based on three ranges: System
Ports (0-1023), User Ports (1024-49151), and the Dynamic and/or Private
Ports (49152-65535); the different uses of these ranges are described in
[RFC 6335]. According to Section 8.1.2 of [RFC 6335], System Ports are 
assigned by the "IETF Review" or "IESG Approval" procedures described in 
[RFC 8126]. User Ports are assigned by IANA using the "IETF Review" process, 
the "IESG Approval" process, or the "Expert Review" process, as per 
[RFC 6335]. Dynamic Ports are not assigned.

The registration procedures for service names and port numbers are
described in [RFC 6335].

Assigned ports both System and User ports SHOULD NOT be used without
or prior to IANA registration.

************************************************************************
* PLEASE NOTE THE FOLLOWING:                                           *
*                                                                      *
* ASSIGNMENT OF A PORT NUMBER DOES NOT IN ANY WAY IMPLY AN             *
* ENDORSEMENT OF AN APPLICATION OR PRODUCT, AND THE FACT THAT NETWORK  *
* TRAFFIC IS FLOWING TO OR FROM A REGISTERED PORT DOES NOT MEAN THAT   *
* IT IS "GOOD" TRAFFIC, NOR THAT IT NECESSARILY CORRESPONDS TO THE     *
* ASSIGNED SERVICE. FIREWALL AND SYSTEM ADMINISTRATORS SHOULD          *
* CHOOSE HOW TO CONFIGURE THEIR SYSTEMS BASED ON THEIR KNOWLEDGE OF    *
* THE TRAFFIC IN QUESTION, NOT WHETHER THERE IS A PORT NUMBER          *
* REGISTERED OR NOT.                                                   *
************************************************************************

Request an Assignment
  [https://www.iana.org/protocols/apply]

Available Formats

CSV

XML

HTML

TXT
Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
wpgs 780 tcp [Josyula_R_Rao] [Josyula_R_Rao]
wpgs 780 udp [Josyula_R_Rao] [Josyula_R_Rao]
dpkeyserv 1780 tcp dpkeyserv [Yasunari_Gon_Yamasit] [Yasunari_Gon_Yamasit]
dpkeyserv 1780 udp dpkeyserv [Yasunari_Gon_Yamasit] [Yasunari_Gon_Yamasit]
lbc-control 2780 tcp LBC Control [Keiji_Michine] [Keiji_Michine]
lbc-control 2780 udp LBC Control [Keiji_Michine] [Keiji_Michine]
stun-behavior 3478 tcp STUN Behavior Discovery over TCP [RFC 5780]
stun-behavior 3478 udp STUN Behavior Discovery over UDP [RFC 5780]
nnp 3780 tcp Nuzzler Network Protocol [Andreas_Schwarz_2] [Andreas_Schwarz_2] 2003-06
nnp 3780 udp Nuzzler Network Protocol [Andreas_Schwarz_2] [Andreas_Schwarz_2] 2003-06
stun-behaviors 5349 tcp STUN Behavior Discovery over TLS [RFC 5780]
stun-behaviors 5349 udp Reserved for a future enhancement of STUN-BEHAVIOR [RFC 5780]
vts-rpc 5780 tcp Visual Tag System RPC [Graham_Bloice] [Graham_Bloice] 2009-09-17
5780 udp Reserved
7780 Unassigned
asr 7800 tcp Apple Software Restore [Jim_Kateley][Shantonu_Sen] [Jim_Kateley][Shantonu_Sen] 2006-01 Defined TXT keys: image=<HTTP URL of disk image>
asr 7800 udp Apple Software Restore [Jim_Kateley][Shantonu_Sen] [Jim_Kateley][Shantonu_Sen] 2006-01 Defined TXT keys: image=<HTTP URL of disk image>
ssp-client 7801 tcp Secure Server Protocol - client [Rick_Macchio] [Rick_Macchio] 2006-11
ssp-client 7801 udp Secure Server Protocol - client [Rick_Macchio] [Rick_Macchio] 2006-11
vns-tp 7802 udp Virtualized Network Services Tunnel Protocol [Juniper_Networks] [Bruno_Rijsman] 2013-02-01
7802 tcp Reserved
7803-7809 Unassigned
47625-47805 Unassigned
ap 47806 tcp ALC Protocol [Dave_Robin] [Dave_Robin]
ap 47806 udp ALC Protocol [Dave_Robin] [Dave_Robin]
47807 Unassigned
bacnet 47808 tcp Building Automation and Control Networks [Coleman_Brumley] [Coleman_Brumley] 2011-02-10
bacnet 47808 udp Building Automation and Control Networks [Coleman_Brumley] [Coleman_Brumley] 2011-02-10
presonus-ucnet 47809 udp PreSonus Universal Control Network Protocol [PreSonus_Audio_Electronics_Inc] [Matthias_Juwan] 2013-07-12
47809 tcp Reserved
timezone tcp Time Zone Data Distribution Service - non-TLS [IESG] [IETF_Chair] 2015-08-03 [RFC 7808] This is an extension of the http service. Defined TXT keys: path=<context path> (as per Section 6 of [RFC 6763]).
timezones tcp Time Zone Data Distribution Service - over TLS [IESG] [IETF_Chair] 2015-08-03 [RFC 7808] This is an extension of the https service. Defined TXT keys: path=<context path> (as per Section 6 of [RFC 6763]).

Contact Information

ID Name Organization Contact URI Last Updated
[Andreas_Schwarz_2] Andreas Schwarz mailto:andreas.schwarz&securepoint.de 2003-06
[Bruno_Rijsman] Bruno Rijsman Juniper Networks mailto:brijsman&juniper.net 2013-02-01
[Coleman_Brumley] Coleman Brumley mailto:cbrumley&polarsoft.biz 2011-02-10
[Dave_Robin] Dave Robin mailto:iana_ports&daverobin.com
[Graham_Bloice] Graham Bloice mailto:graham.bloice&trihedral.com 2009-09-17
[IESG] IESG mailto:iesg&ietf.org
[IETF_Chair] IETF Chair IETF mailto:chair&ietf.org
[Jim_Kateley] Jim Kateley mailto:asr-dev&group.apple.com 2006-01
[Josyula_R_Rao] Josyula R. Rao mailto:jrrao&watson.ibm.com
[Juniper_Networks] Juniper Networks mailto:brijsman&juniper.net 2013-02-01
[Keiji_Michine] Keiji Michine mailto:michine&net.paso.fujitsu.co.jp
[Matthias_Juwan] Matthias Juwan PreSonus Audio Electronics, Inc mailto:mjuwan&presonus.com 2013-07-12
[PreSonus_Audio_Electronics_Inc] PreSonus Audio Electronics, Inc mailto:mjuwan&presonus.com 2013-07-12
[Rick_Macchio] Rick Macchio mailto:rmacchio&juniper.net 2006-11
[Shantonu_Sen] Shantonu Sen mailto:ssen&apple.com
[Yasunari_Gon_Yamasit] Yasunari Gon Yamasita mailto:yamasita&omronsoft.co.jp