Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-27

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
hp-hcip 1782 tcp hp-hcip Allen Baker Allen Baker
hp-hcip 1782 udp hp-hcip Allen Baker Allen Baker
everydayrc 2782 tcp everydayrc Ahti Heinla Ahti Heinla
everydayrc 2782 udp everydayrc Ahti Heinla Ahti Heinla
iso-tp0s 3782 tcp Secure ISO TP0 port Herbert Falk Herbert Falk 2003-06
iso-tp0s 3782 udp Secure ISO TP0 port Herbert Falk Herbert Falk 2003-06
3par-mgmt 5782 tcp 3PAR Management Service Don Marselle Don Marselle 2008-04-09
3par-mgmt 5782 udp 3PAR Management Service Don Marselle Don Marselle 2008-04-09
7782-7783 Unassigned
pdl-datastream 9100 tcp Printer PDL Data Stream Stuart Cheshire Stuart Cheshire 2002-09 The protocol name "pdl-datastream" is primarily registered for use in DNS SRV records (RFC 2782). DNS SRV records allow a protocol to run on any port number, but the default port for this protocol is 9100.
pdl-datastream 9100 udp Printer PDL Data Stream Stuart Cheshire Stuart Cheshire 2002-09 The protocol name "pdl-datastream" is primarily registered for use in DNS SRV records (RFC 2782). DNS SRV records allow a protocol to run on any port number, but the default port for this protocol is 9100.
bpcd 13782 tcp VERITAS NetBackup Jeff Holmbeck Jeff Holmbeck
bpcd 13782 udp VERITAS NetBackup Jeff Holmbeck Jeff Holmbeck
ars-vista 27782 tcp ARS VISTA Application Spencer Teran Spencer Teran 2004-11
ars-vista 27782 udp ARS VISTA Application Spencer Teran Spencer Teran 2004-11

Contact Information

Name Contact URI Last Updated
Ahti Heinla ahti&ahti.bluemoon.ee 2002-06
Allen Baker abaker&boi.hp.com
Don Marselle don.marselle&3par.com 2008-04-09
Herbert Falk herb&sisconet.com 2003-06
Jeff Holmbeck Jeff.Holmbeck&veritas.com
Spencer Teran steran&ars.com 2004-11
Stuart Cheshire pdl-datastream&apple.com 2002-09