Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
mit-ml-dev 83 tcp MIT ML Device David Reed David Reed
mit-ml-dev 83 udp MIT ML Device David Reed David Reed
ocbinder 183 tcp OCBinder
ocbinder 183 udp OCBinder
rescap 283 tcp rescap Paul Hoffman Paul Hoffman
rescap 283 udp rescap Paul Hoffman Paul Hoffman
hp-alarm-mgr 383 tcp hp performance data alarm manager Frank Blakely Frank Blakely
hp-alarm-mgr 383 udp hp performance data alarm manager Frank Blakely Frank Blakely
submissions 465 tcp Message Submission over TLS protocol IESG IETF Chair 2017-12-12 RFC 8314
ulpnet 483 tcp ulpnet Kevin Mooney Kevin Mooney
ulpnet 483 udp ulpnet Kevin Mooney Kevin Mooney
philips-vc 583 tcp Philips Video-Conferencing Janna Chang Janna Chang
philips-vc 583 udp Philips Video-Conferencing Janna Chang Janna Chang
corba-iiop 683 tcp CORBA IIOP
corba-iiop 683 udp CORBA IIOP
iris-beep 702 tcp IRIS over BEEP RFC 3983
iris-beep 702 udp IRIS over BEEP RFC 3983
netconf-ssh 830 tcp NETCONF over SSH RFC 6242
netconf-ssh 830 udp NETCONF over SSH RFC 6242
831 tcp Reserved 2025-09-29 Previously assigned to NETCONF over BEEP but released by RFC 9900
831 udp Reserved 2025-09-29 Previously assigned to NETCONF over BEEP but released by RFC 9900
832 tcp Reserved 2025-09-29 Previously assigned to NETCONF over SOAP but released by RFC 9900
832 udp Reserved 2025-09-29 Previously assigned to NETCONF over SOAP but released by RFC 9900
833 tcp Reserved 2025-09-29 Previously assigned to NETCONF over SOAP but released by RFC 9900
833 udp Reserved 2025-09-29 Previously assigned to NETCONF over SOAP but released by RFC 9900
834-846 Unassigned
imaps 993 tcp IMAP over TLS protocol IESG IETF Chair 2021-02-22 RFC 3501; RFC 8314; RFC 9051
pop3s 995 tcp POP3 over TLS protocol IESG IETF Chair 2017-12-12 RFC 8314
ansoft-lm-1 1083 tcp Anasoft License Manager
ansoft-lm-1 1083 udp Anasoft License Manager
llsurfup-http 1183 tcp LL Surfup HTTP
llsurfup-http 1183 udp LL Surfup HTTP
productinfo 1283 tcp Product Information
productinfo 1283 udp Product Information
gwha 1383 tcp GW Hannaway Network License Manager J. Gabriel Foster J. Gabriel Foster
gwha 1383 udp GW Hannaway Network License Manager J. Gabriel Foster J. Gabriel Foster
afs 1483 tcp AFS License Manager Michael R. Pizolato Michael R. Pizolato
afs 1483 udp AFS License Manager Michael R. Pizolato Michael R. Pizolato
simbaexpress 1583 tcp simbaexpress Betsy Alexander Betsy Alexander
simbaexpress 1583 udp simbaexpress Betsy Alexander Betsy Alexander
ncpm-hip 1683 tcp ncpm-hip Ken Hearn Ken Hearn
ncpm-hip 1683 udp ncpm-hip Ken Hearn Ken Hearn
1783 Decomissioned Port 04/14/00, ms naonao naonao
net8-cman 1830 tcp Oracle Net8 CMan Admin Shuvayu Kanjilal Shuvayu Kanjilal
net8-cman 1830 udp Oracle Net8 CMan Admin Shuvayu Kanjilal Shuvayu Kanjilal
myrtle 1831 tcp Myrtle Ron Achin Ron Achin
myrtle 1831 udp Myrtle Ron Achin Ron Achin
tht-treasure 1832 tcp ThoughtTreasure Erik Mueller Erik Mueller
tht-treasure 1832 udp ThoughtTreasure Erik Mueller Erik Mueller
udpradio 1833 tcp udpradio Guus Sliepen Guus Sliepen
udpradio 1833 udp udpradio Guus Sliepen Guus Sliepen
ardusuni 1834 tcp ARDUS Unicast
ardusuni 1834 udp ARDUS Unicast
ardusmul 1835 tcp ARDUS Multicast Toshikatsu Ito Toshikatsu Ito
ardusmul 1835 udp ARDUS Multicast Toshikatsu Ito Toshikatsu Ito
ste-smsc 1836 tcp ste-smsc Tom Snauwaert Tom Snauwaert
ste-smsc 1836 udp ste-smsc Tom Snauwaert Tom Snauwaert
csoft1 1837 tcp csoft1 John Coll John Coll
csoft1 1837 udp csoft1 John Coll John Coll
talnet 1838 tcp TALNET Aaron Lav Aaron Lav
talnet 1838 udp TALNET Aaron Lav Aaron Lav
netopia-vo1 1839 tcp netopia-vo1
netopia-vo1 1839 udp netopia-vo1
mqtt 1883 tcp Message Queuing Telemetry Transport Protocol OASIS Robin Cover 2015-02-10
mqtt 1883 udp Message Queuing Telemetry Transport Protocol OASIS Robin Cover 2015-02-10
lhtp 1983 tcp Loophole Test Protocol Kade Hansson Kade Hansson
lhtp 1983 udp Loophole Test Protocol Kade Hansson Kade Hansson
radsec 2083 tcp Secure Radius Service IESG IETF Chair 2005-05 RFC 6614 The TCP port 2083 was already previously assigned by IANA for "RadSec", an early implementation of RADIUS/TLS, prior to issuance of this RFC. This early implementation can be configured to be compatible to RADIUS/TLS as specified by the IETF. See RFC 6614, Appendix A for details.
radsec 2083 udp Secure Radius Service IESG IETF Chair 2005-05 2014-07-14 RFC 7360 The UDP port 2083 was already previously assigned by IANA for "RadSec", an early implementation of RADIUS/TLS, prior to issuance of this RFC.
cgn-config 2183 tcp Code Green configuration Chris Michaelson Chris Michaelson 2005-08
cgn-config 2183 udp Code Green configuration Chris Michaelson Chris Michaelson 2005-08
lnvstatus 2283 tcp LNVSTATUS
lnvstatus 2283 udp LNVSTATUS
ms-olap4 2383 tcp Microsoft OLAP Mosha Pasumansky Mosha Pasumansky
ms-olap4 2383 udp Microsoft OLAP Mosha Pasumansky Mosha Pasumansky
ttc 2483 tcp Oracle TTC
ttc 2483 udp Oracle TTC
mon 2583 tcp MON Jim Trocki Jim Trocki
mon 2583 udp MON Jim Trocki Jim Trocki
ncdloadbalance 2683 tcp NCDLoadBalance Tim Stevenson Tim Stevenson
ncdloadbalance 2683 udp NCDLoadBalance Tim Stevenson Tim Stevenson
aises 2783 tcp AISES Daniel Grazioli Daniel Grazioli
aises 2783 udp AISES Daniel Grazioli Daniel Grazioli
silkp2 2830 tcp silkp2
silkp2 2830 udp silkp2
silkp3 2831 tcp silkp3
silkp3 2831 udp silkp3
silkp4 2832 tcp silkp4 Erik Skyten Erik Skyten
silkp4 2832 udp silkp4 Erik Skyten Erik Skyten
glishd 2833 tcp glishd Darrell Schiebel Darrell Schiebel
glishd 2833 udp glishd Darrell Schiebel Darrell Schiebel
evtp 2834 tcp EVTP
evtp 2834 udp EVTP
evtp-data 2835 tcp EVTP-DATA Eric Bruno Eric Bruno
evtp-data 2835 udp EVTP-DATA Eric Bruno Eric Bruno
catalyst 2836 tcp catalyst Garret Tollkuhn Garret Tollkuhn
catalyst 2836 udp catalyst Garret Tollkuhn Garret Tollkuhn
repliweb 2837 tcp Repliweb William Orme William Orme
repliweb 2837 udp Repliweb William Orme William Orme
starbot 2838 tcp Starbot Markus Sabadello Markus Sabadello

Contact Information

Name Organization Contact URI Last Updated
Aaron Lav aaron&taltrade.com
Betsy Alexander tel:+1-604-681-4549
Chris Michaelson chris&codegreennetworks.com 2005-08
Daniel Grazioli dgrazioli&pgaero.co.uk
Darrell Schiebel dschieb&cv.nrao.edu
David Reed
Eric Bruno ebruno&solution-soft.com
Erik Mueller erik&signiform.com
Erik Skyten eki&silknet.com
Frank Blakely frankb&hpptc16.rose.hp.com
Garret Tollkuhn garret&multiviewgroup.com
Guus Sliepen guus&warande3094.warande.uu.nl
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
J. Gabriel Foster fop&gwha.com
Janna Chang janna&pmc.philips.com
Jim Trocki trockij&transmeta.com
John Coll john&csoft.co.uk
Kade Hansson kade_fh&postoffice.utas.edu.au
Ken Hearn hearn&hpindacx.cup.hp.com
Kevin Mooney kevinm&bfs.unibol.com
Markus Sabadello sabadello&starbot.org
Michael R. Pizolato michael&afs.com
Mosha Pasumansky moshap&microsoft.com
OASIS robin&oasis-open.org 2015-02-10
Paul Hoffman phoffman&proper.com 2024-07-23
Robin Cover OASIS KMIP Technical Committee robin&oasis-open.org 2011-07-25
Ron Achin RAchin&genscan.com
Shuvayu Kanjilal
Tim Stevenson tes&ncd.com
Tom Snauwaert tom.snauwaert&st-electronics.be
Toshikatsu Ito ito-t&pfu.co.jp
William Orme bill&repliweb.com
naonao&kikaku.mmp.fujitsu.co.jp